Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] sa-update non funziona con SpamAssassin 3.2.5

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] sa-update non funziona con SpamAssassin 3.2.5

Messaggioda DanBadJar » gio feb 18, 2010 10:21

Ciao a tutti,
sulla Slackware 13.0 ho installato SpamAssassin 3.2.5 dal repository di Slacky, comprese le sue dipendenze.
Funziona tutto, tranne l'aggiornamento col comando sa-update.
L'errore:
Codice: Seleziona tutto
Can't locate LWP/UserAgent.pm in @INC (@INC contains: /usr/lib/perl5/site_perl/5.10.0/i486-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/5.10.0/i486-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.10.0/i486-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl) at /usr/bin/sa-update line 76.
BEGIN failed--compilation aborted at /usr/bin/sa-update line 76.

Manca qualche dipendenza? Qualcuno ha lo stesso problema?
Eventualmente, chiedo ai pacchettizzatori, questo problema si può risolvere con la pacchettizzazione di SpamAssassin 3.3.0 (già segnalato su pkgreports)?
Grazie
Ultima modifica di DanBadJar il gio feb 18, 2010 16:36, modificato 1 volta in totale.
Avatar utente
DanBadJar
Linux 3.x
Linux 3.x
 
Messaggi: 1027
Iscritto il: ven lug 28, 2006 18:27
Località: Bologna
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda NetNightmare » gio feb 18, 2010 11:28

hai questo modulo installato ?

http://search.cpan.org/~gaas/libwww-perl-5.834/ lo puoi installare utilizzando cpan

x spamassassin 3.3.0 http://slackbuilds.org/repository/13.0/network/spamassassin/ se vuoi io ho il pacchetto compilato ma su slack 12.2 ....
Avatar utente
NetNightmare
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: lun ago 18, 2008 10:00
Località: Rome
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda DanBadJar » gio feb 18, 2010 11:37

Ho installato il modulo e ora funziona!
Grazie mille, mi era sfuggito. Suggerisco quindi ai pacchettizzatori di includerlo nelle dipendenze del pacchetto!
Avatar utente
DanBadJar
Linux 3.x
Linux 3.x
 
Messaggi: 1027
Iscritto il: ven lug 28, 2006 18:27
Località: Bologna
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda NetNightmare » gio feb 18, 2010 11:40

Ad ogni modo queste sono a grosse linee i pacchetti che ti servono cosi verifichi ;-) =D> =D> :

Richiesti

Net-DNS
NetAddr-IP
libwww-perl
HTML-Parser
Digest-SHA1
re2c

Optional

IO-Socket-SSL
IP-Country
IO-Socket-INET
Net-Ident
razor-agents
Encode-Detect
Mail-SPF
Avatar utente
NetNightmare
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: lun ago 18, 2008 10:00
Località: Rome
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda DanBadJar » gio feb 18, 2010 11:43

Grazie!
Ho verificato e ho tutto quello che mi serve.
Nel pacchetto qui su slacky non era segnata la dipendenza: libwww-perl ;)
Avatar utente
DanBadJar
Linux 3.x
Linux 3.x
 
Messaggi: 1027
Iscritto il: ven lug 28, 2006 18:27
Località: Bologna
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda Burroughs » gio feb 18, 2010 11:51

DanBadJar ha scritto:Grazie!
Ho verificato e ho tutto quello che mi serve.
Nel pacchetto qui su slacky non era segnata la dipendenza: libwww-perl ;)

Dipendenza aggiunta! :)
Ad onor di cronaca, riferisco che è uscita da qualche settimana la 3.3.0.
Quest'ultima, però, a differenza delle precedenti, proprio per avviare sa-update, si appoggia su parecchie altre dipendenze.
Per farla corta, chi volesse pacchettizzarle, sarebbe il benvenuto. :)

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)
Avatar utente
Burroughs
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: mer dic 15, 2004 0:00
Località: Lago Patria (NA)
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda DanBadJar » gio feb 18, 2010 11:58

@burroughs:
Ho provveduto a segnalare l'uscita della 3.3.0 su pkgreports, se sai precisamente le dipendenze nuove che servono potresti segnalarle per agevolare il lavoro ai pacchettizzatori, io non le conosco!
Avatar utente
DanBadJar
Linux 3.x
Linux 3.x
 
Messaggi: 1027
Iscritto il: ven lug 28, 2006 18:27
Località: Bologna
Nome Cognome: Daniele Malavasi
Slackware: 13.1
Kernel: 2.6.34.1
Desktop: XFCE - Gnome

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda Burroughs » gio feb 18, 2010 12:32

DanBadJar ha scritto:@burroughs:
Ho provveduto a segnalare l'uscita della 3.3.0 su pkgreports, se sai precisamente le dipendenze nuove che servono potresti segnalarle per agevolare il lavoro ai pacchettizzatori, io non le conosco!

Ho segnalato il tutto il 27 gennaio, sul forum riservato ai pacchettizzatori.
Purtroppo siamo in pochi e mancano le risorse, le energie ed il tempo per farlo.
Considera, poi, che quasi tutte le dipendenze sono nuove per cui c'è da creare lo slackbuild e tutti gli annessi e connessi.
Per questo prima invitavo qualche volenteroso a farsi avanti.

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)
Avatar utente
Burroughs
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: mer dic 15, 2004 0:00
Località: Lago Patria (NA)
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda NetNightmare » gio feb 18, 2010 14:38

Ciao,

se volete ci penso io a spamassassin
Avatar utente
NetNightmare
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: lun ago 18, 2008 10:00
Località: Rome
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda Burroughs » gio feb 18, 2010 15:50

NetNightmare ha scritto:Ciao,

se volete ci penso io a spamassassin

Devi mandare un PM a Loris chiedendogli di essere inserito nell'elenco dei pacchettizzatori, dopodiché, al di là della ricompilazione di spamassassin, occorre predisporre gli slackbuild e quindi i pacchetti delle dipendenze richieste dalla versione 3.3.0 dell'applicativo principale, se non ricordo male sono 11-12.

Burroughs.
"Two things are infinite: the universe and human stupidity; and I'm not sure about the universe" (Albert Einstein)
Avatar utente
Burroughs
Linux 2.6
Linux 2.6
 
Messaggi: 968
Iscritto il: mer dic 15, 2004 0:00
Località: Lago Patria (NA)
Nome Cognome: Andrea Lutri
Kernel: 3.16.0
Desktop: KDE SC 4.13.3
Distribuzione: Arch Linux

Re: sa-update non funziona con SpamAssassin 3.2.5

Messaggioda NetNightmare » gio feb 18, 2010 15:55

Si chiaro ... adesso lo mando per le dipendenze la cosa era chiaro ...
Avatar utente
NetNightmare
Linux 2.0
Linux 2.0
 
Messaggi: 175
Iscritto il: lun ago 18, 2008 10:00
Località: Rome
Nome Cognome: Giuseppe De Nicolo'
Slackware: 13.37 x86_64
Kernel: 2.6.37.6-smp
Desktop: Fluxbox


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti