STE e icone fantasma

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
aschenaz
Staff
Staff
Messaggi: 4541
Iscritto il: mer lug 28, 2004 0:00
Nome Cognome: Nino
Slackware: current 64bit
Kernel: as in current
Desktop: XFCE
Località: Reggio Calabria
Contatta:

STE e icone fantasma

Messaggioda aschenaz » lun mar 22, 2010 21:24

Ho installato STE dal repository, ma ho un problemino.
Ho avuto modo di provare questo editor in ufficio, sotto winz, e l'ho trovato
ottimo: leggero e completo, tanto che penso che userò quello sotto quel
sistema, se ne dovessi avere l'esigenza...

Il problema qui su Slackware è che non vengono visualizzate le icone delle
barre degli strumenti! Pensavo potesse dipendere dallo stile in uso (così
come succedeva con Openoffice), ma, a quanto pare, non è così.

È un problema che rilevo solo io?

Avatar utente
SIV
Linux 2.6
Linux 2.6
Messaggi: 921
Iscritto il: mer apr 25, 2007 14:07

Re: STE e icone fantasma

Messaggioda SIV » lun mar 22, 2010 22:24

Ma quali icone aschenaz?
A me appare così:
http://img697.imageshack.us/img697/7953 ... shotdz.png

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4541
Iscritto il: mer lug 28, 2004 0:00
Nome Cognome: Nino
Slackware: current 64bit
Kernel: as in current
Desktop: XFCE
Località: Reggio Calabria
Contatta:

Re: STE e icone fantasma

Messaggioda aschenaz » mar mar 23, 2010 7:52

Questo è invece quello che vedo io:

Immagine

Evidentemente c'è incompatibilità con qualche libreria della current.
Lo ricompilo. Mi chiedo se devo ricompilare tutte le dipendenze... :-k

Avatar utente
Loris
Admin
Admin
Messaggi: 7666
Iscritto il: lun mar 31, 2003 0:00
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5
Località: Gradisca D'Isonzo
Contatta:

Re: STE e icone fantasma

Messaggioda Loris » mar mar 23, 2010 13:34

prova prima a ricompilare solo STE.
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett

Avatar utente
conraid
Staff
Staff
Messaggi: 12689
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: STE e icone fantasma

Messaggioda conraid » mar mar 23, 2010 13:48

probabilmente è il problema con libpng nuovo di cui si lamentava alien bob in quel changelog massiccio della -current

Avatar utente
danix
Staff
Staff
Messaggi: 3287
Iscritto il: ven ott 27, 2006 19:32
Nome Cognome: Danilo M.
Slackware: 64 14.1
Kernel: 4.4.0
Desktop: kde4
Località: Siderno (RC)
Contatta:

Re: STE e icone fantasma

Messaggioda danix » mar mar 23, 2010 13:52

io dopo un po' di peripezie l'ho ricompilato su -current a 64bit e mi sembra funzioni bene...
danix

myself ha scritto:non sono molto presente sul forum, e di ciò mi scuso con tutti

Avatar utente
Kristos
Packager
Packager
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: STE e icone fantasma

Messaggioda Kristos » mar mar 23, 2010 18:03

Volevo segnalare che anche a me S.T.E. funziona perfettamente con tanto di icone sulla barra di stato però uso Slackware 13.0 stabile e non la current in questo momento.

Avatar utente
aschenaz
Staff
Staff
Messaggi: 4541
Iscritto il: mer lug 28, 2004 0:00
Nome Cognome: Nino
Slackware: current 64bit
Kernel: as in current
Desktop: XFCE
Località: Reggio Calabria
Contatta:

Re: STE e icone fantasma

Messaggioda aschenaz » mar mar 23, 2010 21:53

La compilazione (durata un po' troppo mi pare) è fallita. Le ultime righe
riportano:

Codice: Seleziona tutto

styles.o: In function `StyleManager::doCreateLexer(int)':
styles.cpp:(.text+0xaa): undefined reference to `QsciLexerVerilog::QsciLexerVerilog(QObject*)'
styles.cpp:(.text+0x14a): undefined reference to `QsciLexerSpice::QsciLexerSpice(QObject*)'
collect2: ld returned 1 exit status
make: *** [ste] Error 1

:?:

Avatar utente
SIV
Linux 2.6
Linux 2.6
Messaggi: 921
Iscritto il: mer apr 25, 2007 14:07

Re: STE e icone fantasma

Messaggioda SIV » mar mar 23, 2010 23:16

Stessi errori che da a me se compilo a manina!

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: STE e icone fantasma

Messaggioda gohanz » mer mar 24, 2010 8:52

Usate lo SlackBuild. STE usa una versione interna di QScintilla. Occorre prima compilare staticamente la versione interna di QScintillla

Codice: Seleziona tutto

3rdparty/qscintilla/Qt4
e poi compilare STE.

Avatar utente
SIV
Linux 2.6
Linux 2.6
Messaggi: 921
Iscritto il: mer apr 25, 2007 14:07

Re: STE e icone fantasma

Messaggioda SIV » mer mar 24, 2010 17:29

Ho fatto anche quello, ma niente. Ho seguito le istruzioni nel file INSTALL

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: STE e icone fantasma

Messaggioda gohanz » sab mar 27, 2010 9:45

Ho trovato qual'e' il problema. Occorre, prima di compilare, rimuove il pacchetto QScintilla della 13.0. Altrimenti va in conflitto con la versione statica di QScintilla presente in Ste. In pratica Ste cerca di linkarsi con le librerie del pacchetto QScintilla della 13, al posto della versione statica, contenuta nei suoi sorgenti.


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti