Repository 32bit  Forum
Repository 64bit  Wiki

kovercd

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

kovercd

Messaggioda goldy » sab gen 01, 2005 16:14

Kover cd è un bel programma che uso da tanto e mi sono sempre tovato bene , <BR>uso la versione tgz di slacky , ma visto che è uscita la nuova versione la 2.9.6 , ho provato a compilarla, <BR>però ricevo degli errori al make riguardanti le qt <BR>di questo tipo: <BR> <BR>usr/lib/qt/include/qstring.h:868: error: QString& <BR> QString::operator=(QChar) <BR>/usr/lib/qt/include/qstring.h:871: error: QString& <BR> QString::operator=(char) <BR>make[3]: *** [cddb_fill.o] Error 1 <BR>make[3]: Leaving directory `/home/walter/kover-2.9.6/kover´ <BR>make[2]: *** [all-recursive] Error 1 <BR>make[2]: Leaving directory `/home/walter/kover-2.9.6/kover´ <BR>make[1]: *** [all-recursive] Error 1 <BR>make[1]: Leaving directory `/home/walter/kover-2.9.6´ <BR>make: *** [all] Error 2 <BR> <BR>Quindi volevo chiedere a Lorys: <BR>pensi di pacchettizzare la nuova versione e metterla sul sito? <BR> <BR>Oppure c´è qualcuno che può spiegarmi meglio questo errore? <BR> <BR> Thanks <BR> <BR><br>
Avatar utente
goldy
Packager
Packager
 
Messaggi: 1267
Iscritto il: dom mag 02, 2004 23:00
Località: Bologna
Slackware: Current
Kernel: 2.6.26.5
Desktop: KDE 3.5.10

kovercd

Messaggioda Loris » sab gen 01, 2005 17:39

:) ho riscontrato pure io stesso errore, infatti sono fermo alla vecchia versione per quel motivo li... in ogni caso non credo sia un problema di qt ma del file include cdrom.h<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7583
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

kovercd

Messaggioda goldy » sab gen 01, 2005 21:56

eh già, hai ragione......... <BR>le qt c´entrano poco, infatti non avevo notato che al configure <BR>ricevo questo warning <BR> <BR>checking linux/cdrom.h usability... no <BR>checking linux/cdrom.h presence... yes <BR>configure: WARNING: linux/cdrom.h: present but cannot be compiled <BR>configure: WARNING: linux/cdrom.h: check for missing prerequisite headers? <BR>configure: WARNING: linux/cdrom.h: see the Autoconf documentation <BR>configure: WARNING: linux/cdrom.h: section "Present But Cannot Be Compiled" <BR>configure: WARNING: linux/cdrom.h: proceeding with the preprocessor´s result <BR>configure: WARNING: linux/cdrom.h: in the future, the compiler will take precedence <BR>configure: WARNING: ## ------------------------------------------ ## <BR>configure: WARNING: ## Report this to the AC_PACKAGE_NAME lists. ## <BR>configure: WARNING: ## ------------------------------------------ ## <BR>checking for linux/cdrom.h... yes <BR>checking linux/ucdrom.h usability... no <BR>checking linux/ucdrom.h presence... no <BR>checking for linux/ucdrom.h... no <BR> <BR>Quindi che facciamo ? <BR>dobbiamo tenerci la vecchia versione? o si può bypassare il problema? <BR>Ma toglimi una curiosità in questi casi l´errore da cosa dipende? <BR>dal programma o dal mio/nostro sistema.? <BR>Io in rete ho visto che per questo errore in un forum di bsd proprio per compilare kovercd consigliano di scaricare una patch nel kernel da un loro ports. <BR>Ho capito male io (mi sembra esagerato patchare un kernel per compilare un programma che deve stampare delle copertine) o potrebbe anche essere? <BR> <BR><br>
Avatar utente
goldy
Packager
Packager
 
Messaggi: 1267
Iscritto il: dom mag 02, 2004 23:00
Località: Bologna
Slackware: Current
Kernel: 2.6.26.5
Desktop: KDE 3.5.10

kovercd

Messaggioda Loris » sab gen 01, 2005 22:05

Non sono andato a fondo per bene... ma da quello che scrivono è vero quello che dici, personalmente lo ritengo esagerato, alla fine come dici tu stampa copertine :) <BR>Invece cercavo un programmino simile per stampare anche le copertine dei dvd, tu ne conosci ? magari da sostituire kover con uno più completo... che dici ?<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7583
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

kovercd

Messaggioda goldy » sab gen 01, 2005 22:13

Per le cover dei dvd uso gimp ho già le misure belle e fatte , va una meraviglia , <BR>inserisco l´immagine che mi interessa e stampo. <BR>Quando mi funzionava la stampante :-) <BR><BR><BR>[ Questo Messaggio è stato Modificato da: goldy il 01-01-2005 22:15 ]<br>
Avatar utente
goldy
Packager
Packager
 
Messaggi: 1267
Iscritto il: dom mag 02, 2004 23:00
Località: Bologna
Slackware: Current
Kernel: 2.6.26.5
Desktop: KDE 3.5.10


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite