Repository 32bit  Forum
Repository 64bit  Wiki

Wally 2.3.2

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Wally 2.3.2

Messaggioda elaphe » dom apr 18, 2010 18:36

Salve a tutti,utilizzo slackware 13 aggiornata alla current e come da titolo sto cercando di installare wally scarcicato dai repo senza riuscirci,ottengo sempre lo stesso errore relativo a librerie libpng.
Ho tentato anche la via della ricompilazione ma senza risultati,qualcuno ci e' riuscito o puo' aiutarmi, grazie !
elaphe
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: lun gen 21, 2008 17:25

Re: Wally 2.3.2

Messaggioda Kristos » dom apr 18, 2010 18:46

elaphe ha scritto:Salve a tutti,utilizzo slackware 13 aggiornata alla current e come da titolo sto cercando di installare wally scarcicato dai repo senza riuscirci,ottengo sempre lo stesso errore relativo a librerie libpng.
Ho tentato anche la via della ricompilazione ma senza risultati,qualcuno ci e' riuscito o puo' aiutarmi, grazie !


Ma tu hai scaricato wally-2.3.2 dai repo della 13.0 stable? :?:

Se cortesemente posti anche l'output dell'errore/mancanza delle librerie png ti si può dare un aiuto migliore.

Edit: sulla mia 13.0 stable wally funziona benissimo.
Avatar utente
Kristos
Packager
Packager
 
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: Wally 2.3.2

Messaggioda elaphe » dom apr 18, 2010 19:08

Ciao Kristos grazie per la risposta,in un primo momento avevo scaricato wally per la 13 stable poi ho tentato di ricompilare scaricando dal sito ufficiale,ho inoltre installato quelle librerie che mi davano errore ma null !!! Questo l'errore

libpng warning: Application was compiled with png.h from libpng-1.4.0
libpng warning: Application is running with png.c from libpng-1.2.43
libpng error: Incompatible libpng version in application and library
elaphe
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: lun gen 21, 2008 17:25

Re: Wally 2.3.2

Messaggioda Kristos » dom apr 18, 2010 19:17

elaphe ha scritto:Ciao Kristos grazie per la risposta,in un primo momento avevo scaricato wally per la 13 stable poi ho tentato di ricompilare scaricando dal sito ufficiale,ho inoltre installato quelle librerie che mi davano errore ma null !!! Questo l'errore

libpng warning: Application was compiled with png.h from libpng-1.4.0
libpng warning: Application is running with png.c from libpng-1.2.43
libpng error: Incompatible libpng version in application and library


L'errore riguarda proprio le libpng che sono secondo quello che posso dedurre troppo aggiornate per l'uso con -current.
In parole povere wally gira con libpng-1.2.43 (addirittura nella 13.0 stable libpng è nella versione 1.2.37), mentre tu hai libpng-1.4.0 usando le più aggiornate.
L'unica soluzione sarebbe ricompilare ossia ricreare il pacchetto per current.
Avatar utente
Kristos
Packager
Packager
 
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: Wally 2.3.2

Messaggioda elaphe » dom apr 18, 2010 19:31

Si in effetti grazie alla tua segnalazione mi sto rendendo conto che le mie libpng sono troppo nuove per wally,ora cerchero' di capire come ricompilare per la current anche perche' e' una cosa che non ho mai fatto....grazie per le info !
elaphe
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: lun gen 21, 2008 17:25

Re: Wally 2.3.2

Messaggioda Kristos » dom apr 18, 2010 19:48

elaphe ha scritto:Si in effetti grazie alla tua segnalazione mi sto rendendo conto che le mie libpng sono troppo nuove per wally,ora cerchero' di capire come ricompilare per la current anche perche' e' una cosa che non ho mai fatto....grazie per le info !

Non posso esserti di grande aiuto in questo perchè quando creo i pacchetti li faccio espressamente per la stabile, dovrai lavorarci un pò, ma sono certo che alla fine ci riuscirai. :thumbright:
Avatar utente
Kristos
Packager
Packager
 
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: Wally 2.3.2

Messaggioda danix » lun apr 19, 2010 10:10

se usi slackyd è semplicissimo,
Codice: Seleziona tutto
slackyd -b wally

e ti scarica tutto il necessario per compilare wally, poi ti basterà lanciare lo slackbuild e il gioco è fatto...

se non usi slackyd ti basta andare nel repository di slacky (meglio se usi un mirror), entri nella directory di wally e scarichi tutto quello che trovi nella directory src quando hai tutto, lanci lo slackbuild e aspetti...


;)
Ultima modifica di danix il gio apr 22, 2010 8:28, modificato 1 volta in totale.
Motivazione: refuso :)
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: Wally 2.3.2

Messaggioda elaphe » mer apr 21, 2010 22:30

Ciao danix, solo per ringraziarti per i tuoi preziosi consigli grazie ai quali ora wally gira perfettamente, colgo l'occasione per chiederti se wally e' compatibile anche con xfce,ciao e grazie di nuovo.
danilo
elaphe
Linux 1.0
Linux 1.0
 
Messaggi: 20
Iscritto il: lun gen 21, 2008 17:25

Re: Wally 2.3.2

Messaggioda danix » gio apr 22, 2010 8:27

non saprei dirti, io non uso wally, quella che ti ho indicato è la procedura standard che adotto io per ricompilare i pacchetti slacky su current a 64bit, ma nel caso specifico non saprei dirti... comunque sul sito di wally c'è scritto che usa qt4, quindi è probabile che sia per kde... ma sicuramente gira anche su altri de/wm...


puoi provare :D
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti