Clementine 0.3 aggiornamento.

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Kristos
Packager
Packager
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Clementine 0.3 aggiornamento.

Messaggioda Kristos » sab mag 29, 2010 14:19

:wave: a tutti,

poco fà ho voluto provare ad aggiornare il player in oggetto alla versione più recente dalla 0.2 alla 0.3 e come risultato in apparenza fila tutto liscio, inoltre compaiono le icone regolarmente sulla barra di stato, sul pannello etc.etc. ma mi dà un errore sullo Gstreamer dicendomi che non è aggiornato, difatti non genera suoni di nessun tipo.
Premetto che ho modificato lo SlackBuild già presente sulla 13.0, quest'ultimo invece, funziona perfettamente, ma dove dovrebbe apparire l'icona sul pannello in basso, resta presente solo un'area di color bianco, mentre con la nuova versione 0.3 appare tutto, ma non si sentono suoni. :sad2:

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Clementine 0.3 aggiornamento.

Messaggioda gohanz » sab mag 29, 2010 14:51

Clementine 0.3 usa Gstreamer di default. La versione precedente usava Xine. Quindi non senti i suoni perche' ti mancano i vari plugin di gstreamer, ancora non pacchettizzati per la 13.1.

Avatar utente
conraid
Staff
Staff
Messaggi: 12727
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Clementine 0.3 aggiornamento.

Messaggioda conraid » sab mag 29, 2010 15:00

gohanz ha scritto:Clementine 0.3 usa Gstreamer di default. La versione precedente usava Xine. Quindi non senti i suoni perche' ti mancano i vari plugin di gstreamer, ancora non pacchettizzati per la 13.1.


i plugin base e good fanno parte della Slackware

Avatar utente
Kristos
Packager
Packager
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: Clementine 0.3 aggiornamento.

Messaggioda Kristos » sab mag 29, 2010 15:14

Ho fatto una cosa diversa da parte mia, ho scaricato e ricompilato lo SlackBuild da slackbuilds.com e mi segnala la versione 0.1 per Slackware 13.1.
In parole povere mi sono ricompilato questa versione e funziona tutto, compreso l'audio.
Unica pecca è che se ad esempio voglio aggiungere uno streaming radio non presente di default, non mi permette di farlo perchè non c'è l'opzione per aggiungere il path dello streaming.
Penso a questo punto che "forse" lo aggiungeranno nelle versioni successive.

Avatar utente
conraid
Staff
Staff
Messaggi: 12727
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: Clementine 0.3 aggiornamento.

Messaggioda conraid » sab mag 29, 2010 15:20

kristos va bene prendere gli slackbuild da SBo, ma almeno guarda che versione hanno

ti dice che hai la 0.1 perché sono rimasti indietro per clementine, che facciamo, downgradiamo il pacchetto dalla 13.0 alla 13.1? mi sembra uno scenario un po' strano
a meno che le altre versioni non abbiano problemi così evidenti

Avatar utente
Kristos
Packager
Packager
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: Clementine 0.3 aggiornamento.

Messaggioda Kristos » sab mag 29, 2010 17:20

conraid ha scritto:kristos va bene prendere gli slackbuild da SBo, ma almeno guarda che versione hanno

ti dice che hai la 0.1 perché sono rimasti indietro per clementine, che facciamo, downgradiamo il pacchetto dalla 13.0 alla 13.1? mi sembra uno scenario un po' strano
a meno che le altre versioni non abbiano problemi così evidenti


Installando la 0.2 funziona, ma di icone se ne vedono poche sul mio desktop, mentre con la 0.1 tutto và al suo posto.
Per adesso utilizzo questa, inoltre mi sono prelevato lo SB della 13.0 e lo ricompilato per la 13.1, ma anche qui di icone ne vedo poche (anzi per niente) sulla barra di stato mi compare una X stilizzata.

Avatar utente
Blallo
Packager
Packager
Messaggi: 3271
Iscritto il: ven ott 12, 2007 11:37
Nome Cognome: Savino Liguori
Slackware: 14.2 / 12.2
Kernel: 4.4.14-smp
Desktop: DWM
Località: Torino / Torremaggiore (FG)
Contatta:

Re: Clementine 0.3 aggiornamento.

Messaggioda Blallo » sab mag 29, 2010 17:24

a me l'icona di stato funziona alla perfezione
il problema è che non ha un decodificatore mp3 (forse devo installare gst-ffmpeg)
anche se guardando la compilazione dovrebbe essere possibile abilitare xine al posto di gstreamer (lo mette tra i motori scartati, insieme a libvlc)
My DWM configuration: https://github.com/8lall0/dwm

Feel free to use.

Avatar utente
gohanz
Staff
Staff
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Clementine 0.3 aggiornamento.

Messaggioda gohanz » sab mag 29, 2010 20:29

Gstreamer con i plugin base ed good, quelli presenti sulla Slackware, non riproducono i file mp3. Occorre installare, per gli mp3, gst-plugins-ugly.



Codice: Seleziona tutto

/media/xp# gst-launch playbin uri=file:///media/xp/Vasco\ Rossi\ -\ Portatemi\ Dio.mp3
Impostazione della pipeline a PAUSED ...
** Message: don't know how to handle audio/mpeg, mpegversion=(int)1, layer=(int)3
La pipeline è in PREROLLING ...
ERRORE: dall'elemento /GstPlayBin:playbin0: Non risulta installato alcun decoder in grado di gestire questo file. Potrebbe essere necessario installare gli opportuni plugin.
Informazioni di debug aggiuntive:
gstplaybasebin.c(2326): prepare_output (): /GstPlayBin:playbin0
ERRORE: la pipeline non vuole fare il preroll.
Impostazione della pipeline a NULL ...
Esecuzione di free sulla pipeline...

Avatar utente
Kristos
Packager
Packager
Messaggi: 630
Iscritto il: sab dic 19, 2009 11:40
Slackware: 13.37
Kernel: 2.6.37.6-smp
Desktop: KDE
Distribuzione: PCLinuxOS

Re: Clementine 0.3 aggiornamento.

Messaggioda Kristos » dom mag 30, 2010 9:29

gohanz ha scritto:Gstreamer con i plugin base ed good, quelli presenti sulla Slackware, non riproducono i file mp3. Occorre installare, per gli mp3, gst-plugins-ugly.


Installando altre applicazioni come ad esempio exaile le dipendenze gst-xxx vengono richieste d'obbligo se si vuole che exaile funzioni, e quest'ultimo funziona perfettamente a discapito di clementine in versione 0.3 che resta muto, nonostante ci sia tutto il necessario.
Guardando lo SlackBuild, secondo il mio parere da non esperto il problema deriva proprio da qui, cioè nella compilazione di clementine, che con molta probabilità non incrementa un qualche cosa che non conosco e che non lo fà funzionare correttamente perchè (mi chiedo), nelle altre versioni allora funziona anche se non propriamente come dovrebbe per quello che riguarda le icone? :?: :-k


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Exabot [Bot], Yahoo [Bot] e 1 ospite