Repository 32bit  Forum
Repository 64bit  Wiki

Avant Window Navigator e dipendenze

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Avant Window Navigator e dipendenze

Messaggioda Thraphyx » ven ott 08, 2010 18:16

Allora, rieccomi.. scusate per la lunga assenza, ma tra la riparazione del pc, la scuola, e altre cose, solo da poco ho avuto tempo per riprendere il lavoro :)

Tornando a noi..
Innanzitutto, ho compilato gnome-menus per i 64 bit, e di conseguenza ho aggiornato awn-extras col supporto a tale libreria (oltre a fixare le dipendenze mancanti della precedente versione).
Ho ricompilato anche avant-window-navigator, fixando le dipendenze mancanti (requiredbuilder non le trovava, le ho dovute aggiungere a mano, si veda slackbuild) e inserendo direttamente nello SB la parte riguardo gconf, così com'è su slackbuilds.org in quanto più completa di quella che avevo usato precedentemente.

Per quanto riguarda le applet che non funzionano, il mistero è presto svelato. Ogni applet necessita di qualche modulo, e questi moduli sono presenti in vari pacchetti.

I vari moduli necessari per tutte le applet sono questi, elencati nella forma
nomemodulo: applet che dipendono da lui :

Codice: Seleziona tutto
gnome-menus: main-menu, cairo-menu
librsvg: clock
libgtop: system monitor
libsexy: Awn Notification Daemon, cairo-menu
libnotify: Awn Notification Daemon, cairo-menu
gnome-python-desktop: Cairo Clock (rsvg module), Mail (gnomekeyring module), showdesktop (wnck module)
libvte: Awn Terminal
feedparser: Arss, mail, Comics
python-gst (gst-python): lastfm, volume-control
pygtkmozembed: Meebo, Digg, Pandora, RTM
python-xlib: PvNot
python-dateutil: Calendar (0.3.3 and later), optional for Cairo Clock since 0.3.2
GData Python Client: Calendar applet's Google Calendar integration (0.3.3 and later)
VObject: Calendar applet's Evolution integration (0.3.3 and later)


Questi moduli sono contenuti in vari pacchetti. Per i 32 bit, sono disponibili tutti tranne uno, mentre per i 64bit ne mancano ancora alcuni.

I pacchetti sono, elencati secondo
modulo: pacchetto che lo contiene (repository in cui risiede il pacchetto)

Codice: Seleziona tutto
gnome-menus: gnome-menus (slacky32 & slacky64)
librsvg: librsvg (slackware32 & slackware64)
libgtop: libgtop (slacky32 & slacky64)
libsexy: libsexy (slacky32)
libnotify: libnotify (slackware32 & slackware64)
gnome-python-desktop: gnome-python-desktop (slacky32)
libvte: (slackware32 & slackware64)
feedparser: feedparser (slacky32 & slacky64)
python-gst: gst-python (slacky32)
pygtkmozembed: gnome-python-extras (slacky32)
python-dateutil: python-dateutil (slacky32)
GData Python Client: gdata (slacky32 & slacky64)
VObject: vobject (slacky32)

dove slacky32/64 è il repo di slacky.eu, e slackware32/64 sono i pacchetti ufficiali di slackware.
L'unico che manca sia a 32 che a 64 è python-xlib.

Quindi, ricapitolando, chi ha un sistema 32bit può tranquillamente installare le dipendenze delle app che gli interessano.. Mentre chi ha i 64bit, intanto dovrà accontentarsi di quelle gia disponibili (che non sono poche :o ).
Cercherò di compilare i restanti pacchetti al più presto (per alcuni ci sono delle dipendenze infinite.. tipo gnome-python-desktop che si tira dietro mezzo gnomo).

Non mi pare il caso di mettere come dipendenza di awn-extras tutti questi pacchetti.. Comunque valuterò la cosa (chiederò anche agli altri packager), e vi farò sapere!

PS.
@ brainvision:
aggiorna il pacchetti a 32bit di avant-window-navigator, inserendo la parte per gconf e le dipendenze mancanti ;)
Avatar utente
Thraphyx
Linux 2.4
Linux 2.4
 
Messaggi: 212
Iscritto il: ven ago 28, 2009 21:43
Slackware: 14.1 multilib
Kernel: 3.10.17
Desktop: KDE 4.11.5

Re: Avant Window Navigator e dipendenze

Messaggioda gigiobagiano » ven ott 08, 2010 19:36

Ma a te funziona il file browser launcher? a me molte delle applet danno problemi nel cercare le icone...ho guardato di sfuggita il file-brower-ecc.py e si affida a pygtk per prelevare il default icon theme tramite l'apposita funzione, ora se non trova nulla o è mal configurato ( forse ho capito male...) si affida alla directory stock presente del tema hicolor. Ho messo una directory stock_folder ( che non trovava ) sotto 24x24/stock/places, lì dovrebbero andare i folder, ma ancora va in crash per lo stesso motivo.
Voi cosa avete configurato?
Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
 
Messaggi: 503
Iscritto il: dom mar 11, 2007 12:58
Slackware: 11 - 13.1
Kernel: 2.6.35.6_tuxonice
Desktop: Openbox

Re: Avant Window Navigator e dipendenze

Messaggioda brainvision » sab ott 09, 2010 8:36

gigiobagiano ha scritto:Ma a te funziona il file browser launcher? a me molte delle applet danno problemi nel cercare le icone...ho guardato di sfuggita il file-brower-ecc.py e si affida a pygtk per prelevare il default icon theme tramite l'apposita funzione, ora se non trova nulla o è mal configurato ( forse ho capito male...) si affida alla directory stock presente del tema hicolor. Ho messo una directory stock_folder ( che non trovava ) sotto 24x24/stock/places, lì dovrebbero andare i folder, ma ancora va in crash per lo stesso motivo.
Voi cosa avete configurato?


mi pare di ricordare che nel wiki di awn venisse fatta una domanda simili (problemi con le icone) e gli veniva consigliato di resettare tutto con un un comando
# gconf "etcetera"
perché ogni lanciatore dovrebbe avere un file corrispondente gestito proprio da GConf..
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Avant Window Navigator e dipendenze

Messaggioda LoneStar » sab ott 09, 2010 10:06

tieni presente anche il fatto che sulle icone di awn ha influenza ciò che hai settato in .gtkrc-2.0 (oppure .gtkrc-2.0-kde4) alla voce "gtk-icon-theme-name"
Avatar utente
LoneStar
Linux 1.0
Linux 1.0
 
Messaggi: 88
Iscritto il: ven ago 15, 2008 10:10
Località: Ragusa
Slackware: current 32 & 64
Kernel: 3.4.2
Desktop: KDE4

Re: Avant Window Navigator e dipendenze

Messaggioda gigiobagiano » sab ott 09, 2010 18:21

dopo aver scritto il messaggio, ho pensato bene di guardare se per caso avevo configurato il gtkrc, in maniera particolare e in effetti ho inserito un tema di icone iravequalcosa, quindi mi rimane ancora più strano il fatto che vada a cercare uno stock-folder, quando in realtà dovrebbe cercare nella directory del tema impostato da me ( e perfettamente funzionante in fluxbox con pcmanfm ).
Appena posso mi studio i comandi da passare a gconf per fare questo reset...vi terrò aggiornati...
Avatar utente
gigiobagiano
Linux 2.6
Linux 2.6
 
Messaggi: 503
Iscritto il: dom mar 11, 2007 12:58
Slackware: 11 - 13.1
Kernel: 2.6.35.6_tuxonice
Desktop: Openbox

Re: Avant Window Navigator e dipendenze

Messaggioda LoneStar » sab feb 19, 2011 16:19

riapro un thread un po' vecchio, scusate :)

mi sembra che alcuni moduli di awn-extras dipendano da HAL, in particolare quello per lo stato delle batterie, anche se in effetti hal non è citato tra i required.

E' possibile ricompilare awn-extras per non dipendere piu' da HAL, oppure è necessaria una fix a livello di sorgenti?
Avatar utente
LoneStar
Linux 1.0
Linux 1.0
 
Messaggi: 88
Iscritto il: ven ago 15, 2008 10:10
Località: Ragusa
Slackware: current 32 & 64
Kernel: 3.4.2
Desktop: KDE4

Precedente

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite