[Risolto] Adobe AIR 2.0 su Slacky

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
sreview
Linux 2.0
Linux 2.0
Messaggi: 159
Iscritto il: mer lug 27, 2005 0:00
Nome Cognome: Fabrizio Di Carlo
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Xfce 4.6.1
Località: Latina
Contatta:

[Risolto] Adobe AIR 2.0 su Slacky

Messaggioda sreview » lun lug 19, 2010 17:38

Salve a tutti, ho provato ad installare Adobe AIR sulla mia distro preferita ma dal .bin ho ricevuto un errore che si riferiva a KWallet (premetto che sono su Xfce), poi successivamente ho provato a installare l'rpm attraverso KPackage, ma mi da errore non trovando /usr/bin/awk quando invece awk c'è :?
Poi successivamente vado nel sito della Adobe e trovo scritto che in distribuzione Slackware like non è possibile installarlo, qualcuno di voi lo ha installato? Se sì come ci è riuscito?
Ultima modifica di sreview il lun lug 26, 2010 7:56, modificato 1 volta in totale.

Avatar utente
Ansa89
Iper Master
Iper Master
Messaggi: 2700
Iscritto il: mer ago 29, 2007 17:57
Nome Cognome: Stefano Ansaloni
Slackware: 14.1 64bit
Kernel: 4.8.11-ck8
Desktop: XFCE 4.10
Località: Modena
Contatta:

Re: Adobe AIR 2.0 su Slacky

Messaggioda Ansa89 » lun lug 19, 2010 17:48

1) È piuttosto sconveniente installare pacchetti rpm, giusto per il motivo che non sono pacchetti per slackware.
2) Se nel sito dice che su slackware non funziona, probabilmente ci sarà qualche ragione che rende il software incompatibile con la distro (anche se non saprei cosa può essere).

sreview
Linux 2.0
Linux 2.0
Messaggi: 159
Iscritto il: mer lug 27, 2005 0:00
Nome Cognome: Fabrizio Di Carlo
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Xfce 4.6.1
Località: Latina
Contatta:

[Risolto] Adobe AIR 2.0 su Slacky

Messaggioda sreview » dom lug 25, 2010 20:18

Risolto, a breve un piccolo tutorial per l'installazione

Avatar utente
ildiama
Linux 2.6
Linux 2.6
Messaggi: 536
Iscritto il: mar dic 27, 2005 16:49
Slackware: mine
Kernel: 2.6.alto..
Desktop: KDE4
Località: Senigallia
Contatta:

Re: [Risolto] Adobe AIR 2.0 su Slacky

Messaggioda ildiama » dom lug 25, 2010 20:21

sreview ha scritto:Risolto, a breve un piccolo tutorial per l'installazione

Fantastico!! Grazie.. :D

sreview
Linux 2.0
Linux 2.0
Messaggi: 159
Iscritto il: mer lug 27, 2005 0:00
Nome Cognome: Fabrizio Di Carlo
Slackware: 13.0
Kernel: 2.6.29.6
Desktop: Xfce 4.6.1
Località: Latina
Contatta:

Re: [Risolto] Adobe AIR 2.0 su Slacky

Messaggioda sreview » dom lug 25, 2010 22:59

Per far funzionare AIR sulle distribuzioni non-RPM/Deb come Slackware esiste un componente presente nella SDK di AIR chiamato ADL; quindi:

Download e installazione AIR SDK:

1) Andiamo su http://www.adobe.com/cfusion/entitlemen ... m?e=airsdk
2) Creiamo una directory per il runtime; io ho creato /opt/AIR-SDK
3) Estraiamo il pacchetto .tbz2 nella directory appena creata

Codice: Seleziona tutto

cd /opt/AIR-SDK
tar jxvf /path/to/AdobeAIRSDK.tbz2

creiamo un'altra directory per le applicazioni; /opt/AIR-apps

Download e installazione applicazioni

1) Scarichiamo le applicazioni, deve finire con l'estensione .air
2) Creiamo una sottocartella per ogni applicazione; /opt/AIR-apps/applicazione
3) usiamo unzip per estrarre i contenuti dell'applicazione

Codice: Seleziona tutto

cd /opt/AIR-apps/applicazione
unzip /path/to/applicazione.air


usiamo ADL per lanciare l'applicazione:

Codice: Seleziona tutto

/opt/AIR-SDK/bin/adl -nodebug /opt/AIR-apps/applicazione/META-INF/AIR/application.xml /opt/AIR-apps/applicazione


Torna a “Packages”

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti