Repository 32bit  Forum
Repository 64bit  Wiki

errore libstdc++.so.6 con lyx 1.6.6.1

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

errore libstdc++.so.6 con lyx 1.6.6.1

Messaggioda lopont » mer lug 21, 2010 16:11

Salve a tutti. Sono nuovo del forum e spero di non aver sbagliato sezione nel postare :roll:....
Come da titolo, ho provato a installare su Slackware 12.2 la versione 1.6.6.1 di Lyx (presente nel repository della 13.1). Tuttavia, all'avvio del programma il terminale mi restituisce il seguente errore:
Codice: Seleziona tutto
lyx: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by lyx)

Capisco che si tratta di un problema di librerie, ma, di preciso, che cosa manca?
Sono nelle vostre mani... [-o<
lopont
 

Re: errore libstdc++.so.6 con lyx 1.6.6.1

Messaggioda JohnnyMnemonic » mer lug 21, 2010 16:14

Intanto benvenuto!

Il problema sta proprio nella libreria, è presente, ma non è quella che si aspetta lyx, quindi non funziona.
Hai due soluzioni: o installi lyx dal repo della 12.2 o lo ricompili nella nuova versione modificando lo slackbuild
Avatar utente
JohnnyMnemonic
Staff
Staff
 
Messaggi: 2732
Iscritto il: sab set 04, 2004 23:00
Località: Bologna
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos

Re: errore libstdc++.so.6 con lyx 1.6.6.1

Messaggioda lopont » mer lug 21, 2010 19:34

Grazie del benvenuto e dei preziosi consigli. :)
Ho scaricato dal repository (della 13.1) lo slackbuild, modificando il parametro "VERSION" come segue:
Codice: Seleziona tutto
VERSION=1.6.6.1

Quindi l'ho eseguito; tutto andava per il meglio finché il make ha dato l'errore seguente:
Codice: Seleziona tutto
In file included from /usr/include/bits/errno.h:25,
                 from /usr/include/errno.h:36,
                 from /usr/lib/gcc/i486-slackware-linux/4.2.4/../../../../include/c++/4.2.4/cerrno:50,
                 from docstream.cpp:16:
/usr/include/linux/errno.h:4:23: error: asm/errno.h: No such file or directory
docstream.cpp: In member function 'std::codecvt_base::result<unnamed>::iconv_codecvt_facet::do_iconv(void*, const char**, size_t*, char**, size_t*) const':
docstream.cpp:266: error: 'EINVAL' was not declared in this scope
docstream.cpp:267: error: 'E2BIG' was not declared in this scope
docstream.cpp:269: error: 'EILSEQ' was not declared in this scope
make[5]: *** [docstream.lo] Error 1
make[5]: Leaving directory `/tmp/tgz/lyx-1.6.6.1/src/support'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/tmp/tgz/lyx-1.6.6.1/src/support'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/tmp/tgz/lyx-1.6.6.1/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/tmp/tgz/lyx-1.6.6.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/tgz/lyx-1.6.6.1'
make: *** [all] Error 2

Meglio che utilizzo la versione del repository 12.2 o cerco di risolvere l'errore (non sono molto pratico, ma sto cercando di imparare ;))?
lopont
 

Re: errore libstdc++.so.6 con lyx 1.6.6.1

Messaggioda JohnnyMnemonic » mer lug 21, 2010 20:44

Ma se tu hai una 12.2 non dovresti scaricare lo slackbuild della 12.2 e aggiornarlo?
Avatar utente
JohnnyMnemonic
Staff
Staff
 
Messaggi: 2732
Iscritto il: sab set 04, 2004 23:00
Località: Bologna
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos

Re: errore libstdc++.so.6 con lyx 1.6.6.1

Messaggioda lopont » gio lug 22, 2010 14:49

JohnnyMnemonic ha scritto:Ma se tu hai una 12.2 non dovresti scaricare lo slackbuild della 12.2 e aggiornarlo?

Hai ragione. Ho sbagliato a scrivere nel mio messaggio precedente... chiedo perdono per la mia "svista" fuorviante [-o< in realtà ho
1 Scaricato lo slackbuild per Lyxdal repository della 12.2
2 Modificato il parametro VERSION mettendolo uguale alla versione di Lyx del repository della 13.1
3 Eseguito lo slackbuild
Il problema è che ad un tratto mi si presenta l'errore che ho riportato precedentemente....
lopont
 


Torna a Packages

Chi c’è in linea

Visitano il forum: rik70 e 1 ospite