Repository 32bit  Forum
Repository 64bit  Wiki

vlc 1.1.1 e slackyd

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

vlc 1.1.1 e slackyd

Messaggioda RedSkull92 » mer lug 28, 2010 12:59

ho un problemino, ho visto che è stato aggiornato vlc alla versione 1.1.1
Uso slackyd : slackyd -u e dopo slackyd -g vlc (l'avevo rimosso tempo fa)

ma mi da questo risultato:
Codice: Seleziona tutto
root@darkness:/home/redskull/Desktop$ slackyd -g vlc

Searching vlc:
*** Warning:
Some package data found in file `/var/slackyd/slacky/PACKAGES.TXT' seems to be too long. Continuing.
found 1 package.

vlc-1.1.0-i486-1sl.txz [from slacky]

Download vlc-1.1.0-i486-1sl.txz [from slacky] ? [y/N]

che devo fare ?
Cioè vlc ha parecchie (parecchie è dire poco) dipendenze e sarebbe un suicidio mettermi li a scaricarle tutte 1 ad 1
Grazie.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: vlc 1.1.1 e slackyd

Messaggioda Ansa89 » mer lug 28, 2010 14:08

Usare slapt-get?
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: vlc 1.1.1 e slackyd

Messaggioda RedSkull92 » mer lug 28, 2010 20:06

ho provato, ma....
Codice: Seleziona tutto
root@darkness:/home/redskull$ slapt-get -i vlc
Reading Package Lists... Done
Excluding vlc, use --ignore-dep to override
The following packages have unmet dependencies:
  avahi: Depends: libpng >= 1.4.3-i486-1_slack13.1
The following packages have been EXCLUDED:
  vlc
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Done
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: vlc 1.1.1 e slackyd

Messaggioda erio » mer lug 28, 2010 20:17

se provi a ridare slackyd -u, che dovrebbe aggiornare i file dei repositorry...credo,non sono sicuro
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1084
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: vlc 1.1.1 e slackyd

Messaggioda erio » mer lug 28, 2010 20:18

come non letto..detto
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1084
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: vlc 1.1.1 e slackyd

Messaggioda Ansa89 » mer lug 28, 2010 20:21

Devi fare gli aggiornamenti di sicurezza delle libpng.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2623
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: vlc 1.1.1 e slackyd

Messaggioda Blallo » mer lug 28, 2010 22:11

approfitto per chiedere:
potrebbe avere senso un vlc-static, come quello di AlienBob, nel repo?
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3234
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: vlc 1.1.1 e slackyd

Messaggioda RedSkull92 » mer lug 28, 2010 22:18

Codice: Seleziona tutto
root@darkness:/home/redskull$ slapt-get -i vlc
Reading Package Lists... Done
Excluding vlc, use --ignore-dep to override
The following packages have unmet dependencies:
  fluidsynth: Depends: lash >= 0.6.0~rc2-i486-3sl
The following packages have been EXCLUDED:
  vlc
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Done
root@darkness:/home/redskull$ ls /var/log/packages/ | grep lash     
flash-player-plugin-10.1-i386-1sl
flash_player_standalone-9.0.21.78-i686-4as
lash-0.6.0~rc2-i486-3sl

Non capisco cosa sbaglio.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: vlc 1.1.1 e slackyd

Messaggioda erio » mer lug 28, 2010 23:30

a me dice cosi:root@slax:~# slapt-get -i vlc
Reading Package Lists... Done
Excluding vlc, use --ignore-dep to override
The following packages have unmet dependencies:
avahi: Depends: libpng >= 1.4.3-i486-1_slack13.1
The following packages have been EXCLUDED:
vlc
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

ora provo a upgradare questa libreria e rido il comando
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1084
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: vlc 1.1.1 e slackyd

Messaggioda shark1500 » gio lug 29, 2010 8:58

Ma se guardi su PACKAGES.TXT con due righe in bash ti fai uno script che ti scarica tutte le dipendenze con slackyd (dato che sembra non andare).
Avatar utente
shark1500
Linux 2.6
Linux 2.6
 
Messaggi: 785
Iscritto il: gio apr 03, 2008 13:33
Località: Modna
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde

Re: vlc 1.1.1 e slackyd

Messaggioda erio » gio lug 29, 2010 9:06

io uso solo slackyd,che trova anche le dipendenze,slapt-get era più una curiosità
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1084
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: vlc 1.1.1 e slackyd

Messaggioda RedSkull92 » gio lug 29, 2010 12:18

Slackyd non va e lo script non saprei come farlo.
Cioè prima slackyd andava perfettamente, appena è uscita la 13.1 ha smesso di funzionare.
E le dipendenze di vlc sono troppe, shark saresti così gentile da scrivermi uno script apposito ?
Grazie
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: vlc 1.1.1 e slackyd

Messaggioda shark1500 » gio lug 29, 2010 12:57

Codice: Seleziona tutto
a52dec
aalib
alsa-lib
amrnb
amrwb
atk
attr
avahi
bzip2
cairo
celt
cxxlibs
cyrus-sasl
dbus
dbus-glib
dirac
e2fsprogs
enca
expat
faac
faad2
ffmpeg
flac
fontconfig
freetype
fribidi
gcc
glib2
glibc-solibs
gnutls
goom
gpm
gtk+2
hal
jack-audio-connection-kit
lame
libICE
libSM
libX11
libXau
libXcomposite
libXcursor
libXdamage
libXdmcp
libXext
libXfixes
libXi
libXinerama
libXrandr
libXrender
libXt
libXv
libXxf86vm
libass
libavc1394
libcaca
libcap
libcddb
libcdio
libdca
libdrm
libdvbpsi5
libdvdcss
libdvdnav
libdvdread
libebml
libgcrypt
libgpg-error
libgsf
libgsm
libjpeg
libkate
libmad
libmatroska
libminizip
libmodplug
libmpcdec
libmpeg2
libmtp
libnotify
libogg
liboil
libpng
libproxy
libraw1394
librsvg
libsamplerate
libshout
libtheora
libtiff
libtiger
libupnp
libusb
libv4l
libvorbis
libxcb
libxml2
lirc
lua
mesa
ncurses
opencore-amr
openjpeg
openldap-client
openssl
pango
pixman
qt
readline
samba
schroedinger
sdl
slang
speex
svgalib
sysfsutils
taglib
tremor
twolame
vcdimager
x264
xcb-util
xosd
xvidcore
zlib
zvbi


Queste sono le dipendenze di vlc.

Fai un

Codice: Seleziona tutto
for dep in $(cat listdep) ; do slackyd -g $dep ; done


e cosi` dovresti scaricarle tutte, poi le installi tutte.
Avatar utente
shark1500
Linux 2.6
Linux 2.6
 
Messaggi: 785
Iscritto il: gio apr 03, 2008 13:33
Località: Modna
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde

Re: vlc 1.1.1 e slackyd

Messaggioda RedSkull92 » gio lug 29, 2010 13:31

perfetto grazie.
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: vlc 1.1.1 e slackyd

Messaggioda erio » gio lug 29, 2010 20:22

comunque slackyd funziona,solo che la versione di vlc è quella vecchia invece slapt-get ha quella nuova che non scarica dopo l'aggiornamento di libpng,avevo il tuo stesso errore.bho!!
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1084
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde


Torna a Packages

Chi c’è in linea

Visitano il forum: Google [Bot] e 2 ospiti