Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Virtualbox 3.2.6 richiede Qt4.6.x, ma ce le ho...

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Virtualbox 3.2.6 richiede Qt4.6.x, ma ce le ho...

Messaggioda daniele50 » ven ago 20, 2010 16:00

Ciao,
ho appena installato il pacchetto virtualbox-ose-3.2.6-i486-1sl.txz (che non richiede dipendenze) sulla mia slackware current (anche se sono fermo con gli aggiornamenti da un mesetto).
Ho dato poi un /etc/rc.d/rc.vboxdrv setup con esito positivo, ma quando poi lancio virtualbox mi esce il seguente errore:
Executable Qt-subapplication requires Qt 4.6.x, found Qt 4.5.2.
Eppure dovrei avere le Qt 4.6.x:

bash-4.1# ls /var/log/packages/ | grep -i qt
PyQt-4.7.3-i486-1
polkit-qt-1-r1145513-i486-1
qt-4.6.3_ef2e850-i486-1
qt3-3.3.8b-i486-opt1
qt4-4.5.2-i686-1as
qtscriptgenerator-0.1.0-i486-2
bash-4.1#

Cosa potrei fare?
Ultima modifica di daniele50 il ven ago 20, 2010 16:34, modificato 1 volta in totale.
Avatar utente
daniele50
Linux 2.6
Linux 2.6
 
Messaggi: 928
Iscritto il: mar apr 10, 2007 12:58
Località: San Zenone al Lambro (MI)
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.0
Kernel: 3.2.29
Desktop: Xfce 4.10

Re: Virtualbox 3.2.6 richiede Qt4.6.x, ma ce le ho...

Messaggioda ildiama » ven ago 20, 2010 16:27

mah.. io vedo installate anche le qt4-4.5.2. Probabilmente in /opt. Probabilmente con /opt/bin prima di /usr/bin nel tuo path. Rimuovile, riavvia e vedrai che funziona tutto.
Avatar utente
ildiama
Linux 2.6
Linux 2.6
 
Messaggi: 536
Iscritto il: mar dic 27, 2005 16:49
Località: Senigallia
Slackware: mine
Kernel: 2.6.alto..
Desktop: KDE4

Re: Virtualbox 3.2.6 richiede Qt4.6.x, ma ce le ho...

Messaggioda daniele50 » ven ago 20, 2010 16:34

Avevi ragione, io aggiorno sempre a current, ma mi dimentico di togliere quello che non serve più ;)

Ciao e grazie!
Avatar utente
daniele50
Linux 2.6
Linux 2.6
 
Messaggi: 928
Iscritto il: mar apr 10, 2007 12:58
Località: San Zenone al Lambro (MI)
Nome Cognome: Daniele Cinquanta
Slackware: Slackware64 14.0
Kernel: 3.2.29
Desktop: Xfce 4.10


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti