Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Installare iMule su Slackware 13.1 32 bit

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Installare iMule su Slackware 13.1 32 bit

Messaggioda nyquist » sab feb 12, 2011 18:58

Ciao a tutti!
Qualcuno di voi è riuscito a installare iMule sulla Slackware?
Io ho provato a installare il pacchetto a questo indirizzo: http://aceini.no-ip.info/imule/1.4.6/iM ... .6_src.tbz
Ma quando dopo aver scompattato il pacchetto con
Codice: Seleziona tutto
tar -xvjf iMule_1.4.6_src.tbz

do il ./configure, mi esce con questo errore
Codice: Seleziona tutto
...
checking for zlib >= 1.1.4... yes (version 1.2.3)
checking whether we need the GUI... yes
checking for wx-config... /usr/bin/wx-config
checking for wxWidgets version >= 2.8.7... no
configure: error:
                wxWidgets must be installed on your system but wx-config
                script couldn't be found. Please check that wx-config is
                in path or specified by --with-wx-config=path flag, the
                directory where wxWidgets libraries are installed (returned
                by 'wx-config --libs' command) is in LD_LIBRARY_PATH or
                equivalent variable and wxWidgets version is 2.6.0 or above.

Da notare che dando un ls /var/log/packages | grep wxwidgets ottengo
Codice: Seleziona tutto
wxwidgets-2.8.11-i486-1sl

Quindi la versione è ok.
Qualcuno ha avuto lo stesso problema?
Ultima modifica di nyquist il dom feb 13, 2011 21:38, modificato 2 volte in totale.
Avatar utente
nyquist
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: sab ago 02, 2008 15:02
Località: Gonars (UD)
Nome Cognome: Cristiano Urban
Slackware: 14.1 x86
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: CentOS, Fedora

Re: Installare imule su Slackware 13.1 32 bit

Messaggioda slux » sab feb 12, 2011 23:43

Nel pacchetto wx-widgets manca lo script wx-config ,necessario per compilare imule.Devi ricreare il pacchetto wx-widgets assicurandoti di includere nello Slackbuild anche questo file.Trovi tutto qui su Slacky,correggi lo Slackbuild e risolvi.
Avatar utente
slux
Linux 2.6
Linux 2.6
 
Messaggi: 782
Iscritto il: dom mar 20, 2005 0:00
Località: Prato
Nome Cognome: Andrea Amerini
Slackware: 14.1 x86
Kernel: 3.12.0-smp
Desktop: xfce 4.10

Re: Installare imule su Slackware 13.1 32 bit

Messaggioda 414N » dom feb 13, 2011 10:41

slux ha scritto:Nel pacchetto wx-widgets manca lo script wx-config ,necessario per compilare imule.Devi ricreare il pacchetto wx-widgets assicurandoti di includere nello Slackbuild anche questo file.Trovi tutto qui su Slacky,correggi lo Slackbuild e risolvi.

Non mi sembra, anche perché
nyquist ha scritto:
Codice: Seleziona tutto
checking for wx-config... /usr/bin/wx-config


quindi wx-config viene trovato, ma il suo output viene mal interpretato dal configure.
Ho fatto un po' di prove ed analizzato lo script di configure stesso, e mi sono accorto che, se non si aggiunge il flag --disable-debug quando si chiama il configure, questi va ad aggiungere un'opzione di debug a wx-config che non funziona e non restituisce la versione, causando il problema.
In soldoni, prova a lanciare il configure aggiungendo come opzione --disable-debug.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Installare imule su Slackware 13.1 32 bit

Messaggioda hashbang » dom feb 13, 2011 11:15

414N ha scritto:Ho fatto un po' di prove ed analizzato lo script di configure stesso, e mi sono accorto che, se non si aggiunge il flag --disable-debug quando si chiama il configure, questi va ad aggiungere un'opzione di debug a wx-config che non funziona e non restituisce la versione, causando il problema.
In soldoni, prova a lanciare il configure aggiungendo come opzione --disable-debug.
Confermo quanto detto da 414N. Ho provato a fare una compilazione di iMule e con l'opzione "--disable-debug" il configure viene completato.
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1823
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: Installare imule su Slackware 13.1 32 bit

Messaggioda nyquist » dom feb 13, 2011 21:25

Si funziona!
Vi ringrazio per l'aiuto!
Ricapitolando, la procedura è la seguente:

1) Scaricare il pacchetto
2) Decomprimere il pacchetto con tar -xvjf iMule_1.4.6_src.tbz
3) Accedere alla directory appena creata
4) Lanciare da utente il configure con ./configure --disable-debug
5) Dare il comando make sempre da utente
6) Loggarsi come super user e dare il comando make install
Avatar utente
nyquist
Linux 2.4
Linux 2.4
 
Messaggi: 217
Iscritto il: sab ago 02, 2008 15:02
Località: Gonars (UD)
Nome Cognome: Cristiano Urban
Slackware: 14.1 x86
Kernel: 3.10.17-smp
Desktop: KDE 4.10.5
Distribuzione: CentOS, Fedora


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti