Repository 32bit  Forum
Repository 64bit  Wiki

Crash di firefox in Slackware 13.1

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Crash di firefox in Slackware 13.1

Messaggioda fgcl2k » mar mar 08, 2011 10:16

Dopo aver ricompilato i pacchetti freetype, fontconfig, libXft, cairo e mozilla-firefox, per il subpixel rendering come suggerito in http://www.vcn.bc.ca/~dugan/slackware-fonts/, mi sono accorto che firefox andava sempre in crash visitando la pagina http://code.google.com/webfonts.
Ho riportato i pacchetti alla versione iniziale della 13.1 (e ho fatto il reboot). Attualmente ho:
- freetype-2.3.12-i486-1
- fontconfig-2.8.0-i486-1
- libXft-2.1.14-i486-1
- cairo-1.8.8-i486-3
- mozilla-firefox-3.6.3-i686-1
Nonostante tutto il crash si ripete puntualmente, quindi penso che non sia da imputare alle patch per il subpixel-rendering.
Ho fatto i test con XFCE (con e senza anti-aliasing nel menu Aspetto) e fluxbox: stesso risultato.

Su Debian (sullo stesso PC) il crash non si verifica.

Qualcun altro ho lo stesso problema o ha qualche suggerimento da darmi?

Grazie,

fgcl2k
Avatar utente
fgcl2k
Linux 2.0
Linux 2.0
 
Messaggi: 129
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Crash di firefox in Slackware 13.1

Messaggioda murdock » mar mar 08, 2011 20:17

Lo fa anche a me, niente patches. FF 3.6.15
Muore con un bel:
/usr/lib64/firefox-3.6.15/run-mozilla.sh: line 131: 6626 Floating point exception"$prog" ${1+"$@"}

Saluti,
MuRdOcK
Avatar utente
murdock
Linux 2.4
Linux 2.4
 
Messaggi: 451
Iscritto il: ven mag 25, 2007 11:58
Slackware: 64 14.1
Kernel: 3.14.4
Desktop: KDE 4.12.5

Re: Crash di firefox in Slackware 13.1

Messaggioda fgcl2k » mer mar 09, 2011 10:05

Ho approfondito il problema eseguendo firefox nel debugger, con il comando:

Codice: Seleziona tutto
$ /usr/lib/firefox-3.6.3/run-mozilla.sh -g /usr/lib/firefox-3.6.3/firefox-bin -d gdb


Il risultato è:

Codice: Seleziona tutto
Program received signal SIGFPE, Arithmetic exception.
0xb62f218e in ?? () from /usr/lib/libpangoft2-1.0.so.0
(gdb) bt
#0  0xb62f218e in ?? () from /usr/lib/libpangoft2-1.0.so.0
#1  0xb62f296c in ?? () from /usr/lib/libpangoft2-1.0.so.0
#2  0xb62e72bc in ?? () from /usr/lib/libpangoft2-1.0.so.0
#3  0xb62e290d in ?? () from /usr/lib/libpangoft2-1.0.so.0
#4  0xb62df613 in pango_ot_info_get () from /usr/lib/libpangoft2-1.0.so.0
#5  0xb5c4df25 in ?? () from /usr/lib/pango/1.6.0/modules/pango-basic-fc.so
#6  0xb6bb1bfa in ?? () from /usr/lib/libpango-1.0.so.0
#7  0xb6bc464c in pango_shape () from /usr/lib/libpango-1.0.so.0
...


libpangoft2 fa parte del pacchetto pango-1.26.2-i486-1

Firefox riesce a aprile la pagina problematica senza andare in crash disabilitando la casella "Allow pages to choose their own fonts, instead of my selections above" nella finestra di dialogo "Preferences|Fonts".

fgcl2k
Avatar utente
fgcl2k
Linux 2.0
Linux 2.0
 
Messaggi: 129
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3

Re: Crash di firefox in Slackware 13.1

Messaggioda fgcl2k » gio mar 10, 2011 11:55

Ho risolto compilando mozilla 3.6.15 con l'opzione --disable-pango (ho usato lo slackbuild della versione a 64 bit impostando ARCH=i486).
Cercando un po' sul web non ho trovato particolari controindicazioni.

fgcl2k
Avatar utente
fgcl2k
Linux 2.0
Linux 2.0
 
Messaggi: 129
Iscritto il: gio ott 29, 2009 10:14
Nome Cognome: Federico
Slackware: 14.1 (64bit)
Kernel: 3.10.17
Desktop: KDE 4.13.3


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron