Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] problemi installazione cairo-compmgr

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] problemi installazione cairo-compmgr

Messaggioda james2221 » sab apr 23, 2011 12:17

ciao
slack 13.1 fluxbox
questa mattina ho installato cairo-compmgr e mi da errore di libreria
Codice: Seleziona tutto
bash-4.1$ cairo-compmgr
cairo-compmgr: error while loading shared libraries: libbfd-2.21.51.0.6.20110118.so: cannot open shared object file: No such file or directory
bash-4.1$

la quale libreria è nelle binutils, mentre la mia versione è
Codice: Seleziona tutto
/var/log/packages/binutils-2.20.51.0.8-i486-1:usr/lib/libbfd.a


ho trovato qualcosa in queste pagine
[url]
search.php?keywords=libbfd
[/url]
ma niente che funzioni

riedito per una novità, non so quanto importante: riaccendendo e spegnendonon mi dice piu niente della libreria,non so se la cosa è andata a posto con il fatto di aver rinominato la libreria o se è collegata a quest'altro errore
Codice: Seleziona tutto
bash-4.1$ cairo-compmgr
cairo-compmgr: symbol lookup error: cairo-compmgr: undefined symbol: g_malloc0_n
bash-4.1$


qualche idea?
grazie
james
Ultima modifica di james2221 il mar apr 26, 2011 19:10, modificato 1 volta in totale.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: libbfd non va bene versione

Messaggioda conraid » sab apr 23, 2011 12:34

sembra compilato su una -current, da dove lo hai scaricato?

p.s.
metti un titolo meno generico
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: libbfd non va bene versione e anche altro errore

Messaggioda james2221 » sab apr 23, 2011 12:55

wahww quale onore il grande conraid

per il titolo effettivamente messo cosi è un po' osceno, accetto suggerimemti

in quanto al pacchetto l'ho installato dai repositori 32bit stable, pero credo di aver fatto questo errore: dandomi il problema libbfd di cui sopra ho installato bin-utils dal repository current di zenwalk.
e mo' come la sistemo sta storia? vorrei mai che fossero troppo avanti rispetto ai nostri


grazie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: libbfd non va bene versione e anche altro errore

Messaggioda conraid » sab apr 23, 2011 13:05

suggerimenti? non c'è scritto nemmeno quale pacchetto ti da errore, come fa una persona a capire di cosa parli dal titolo? :-)


non hai ancora detto da dove hai installato il pacchetto che ti da errore. 32bit stable cosa? su Slackware non c'è cairo-comp. Qui su slacky da quel che vedo è linkato alle librerie corrette.

Se poi fai mix con pacchetti di altre distribuzioni (zenwalk è un'altra distribuzione), anche di grande importanza come le binutils, che qualcosa non vada mi sembra il minimo
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: libbfd non va bene versione e anche altro errore

Messaggioda hashbang » sab apr 23, 2011 18:46

james2221 ha scritto:wahww quale onore il grande conraid

per il titolo effettivamente messo cosi è un po' osceno, accetto suggerimemti

in quanto al pacchetto l'ho installato dai repositori 32bit stable, pero credo di aver fatto questo errore: dandomi il problema libbfd di cui sopra ho installato bin-utils dal repository current di zenwalk.
e mo' come la sistemo sta storia? vorrei mai che fossero troppo avanti rispetto ai nostri


grazie
james

Se devi risolvere il problema delle binutils dovresti risolvere con
Codice: Seleziona tutto
# slackpkg reinstall binutils


O le scarichi da quì e le installi con
Codice: Seleziona tutto
# upgradepkg --reinstall binutils-2.20.51.0.8-i486-1.txz
Adoro il pragmatismo della lingua giapponese, è l'unica in cui per dire ad una ragazza che la ami le dici "suki". (cit.)
Avatar utente
hashbang
Packager
Packager
 
Messaggi: 1842
Iscritto il: ven giu 04, 2010 9:27
Località: Lecce
Nome Cognome: Luca De Pandis
Distribuzione: Windows 8.1 Pro

Re: libbfd non va bene versione e anche altro errore

Messaggioda 414N » dom apr 24, 2011 10:38

james2221 ha scritto:in quanto al pacchetto l'ho installato dai repositori 32bit stable, pero credo di aver fatto questo errore: dandomi il problema libbfd di cui sopra ho installato bin-utils dal repository current di zenwalk.

Siamo proprio "de coccio", eh?
Oltre a prendere pacchetti da un'altra distro (perché non da Ubuntu, a questo punto?), li prendi pure dalla loro versione in sviluppo, quindi ancora più incompatibili di quanto potrebbero esserli quelli della stable.
Forse non mi sono spiegato nell'altro thread: EVITA PACCHETTI DI ALTRE DISTRO come linea di massima.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2884
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: libbfd non va bene versione e anche altro errore

Messaggioda james2221 » dom apr 24, 2011 10:55

cenere sul capo...cancellato zenwalk-packages dai preferiti del web-browser
comunque ho preso binutils da zenwalk perchè cairo-compmgr mi chiedeva una libreria piu aggiornata da quella installata, che poi ho risolto la questione librerie

[url]search.php?keywords=libbfd[/url]

rinominando la lib, come appunto da link qui sopra.

in ogni caso ancora ieri prima delle Vs risposte ho smanettato su fluxbox e xcompmgr e sono riuscito comunque ad avere ottimi effetti come ombre e trasparenze sufficienti per lavorare in ambiente gradevole.
L'unica cosa, anche se siamo leggermente OT, ho disinstallato pcmanfm e utilizzato thunar (installato di default dalla .iso) perchè comunque leggero ma certamente piu completo (cestino e altro).

ciao e grazie a tutti

james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: libbfd non va bene versione e anche altro errore

Messaggioda james2221 » mar apr 26, 2011 19:09

ciao
oltre che mettere risolto ho cambiato il titolo al thread
sono riuscito a far fungere cairo-compmgr risolvendo i problemi posti in precedenza.
ho disinstallato vala e cairo-comp e reinstallati da repo di slack , come peraltro erano prima
[url]
http://repository.slacky.eu/slackware-1 ... la/0.11.6/
http://repository.slacky.eu/slackware-1 ... mgr/0.3.0/
[/url]
però al dunque mi dava ancora errore di librerie, chiedeva libvala0.10 ovverosia uno step indietro, pertanto sono andato a farmi un giretto sul web, ho up-gradato vala0.10 e adesso va.
dal mio slapt-get --installed:
Codice: Seleziona tutto
vala-0.10.2-i486-70.1 [inst=yes]: vala - compiler for the GObject type system
vala-0.11.6-i486-1sl [inst=yes]: Vala (Gnome  GObject Compiler)

ovviamente provvedo a pulire la versione non confacente.
grazie a tutti per la pazienza
james
nb detto inte-rnos: fluxbox e xcompmgr ben configurati sono moooolto meglio e ben piu leggeri di cairo-comp, comunque spero che a qualcuno sul forum possa servire.

ciaooo
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite