Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto] libltdl.so.7 mancante

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto] libltdl.so.7 mancante

Messaggioda james2221 » mar mag 17, 2011 16:58

ciao
slackware 13.1 fluxbox
questa mattina quando ho acceso mi sono trovato un messaggio nel quale mi si dice di eseguire il seguente comando

Codice: Seleziona tutto
display -geometry 3520x1080+0+0 -window root /home/piero/Immagini/wall10.jpg


per caricare lo sfondo.
Al che mi da errore
Codice: Seleziona tutto
display: error while loading shared libraries: libltdl.so.7: cannot open shared object file: No such file or directory


non so che librerie siano ne di che pacchetto facciano parte.
Non aggiorno da alcuni giorni, e questo errore è comunque posteriore di parecchi giorni agli aggiornamenti.
ho guardato la seguente pagina web
http://www.slacky.eu/forum/search.php?keywords=libltdl.
ma non ho trovato niente di utile. Il pc funziona, il problema si presenta solo quando lo accendo.
suggerimenti???
grazie
james
Ultima modifica di james2221 il mar mag 17, 2011 18:00, modificato 1 volta in totale.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: libltdl.so.7 mancante

Messaggioda Ansa89 » mar mag 17, 2011 17:08

Il pacchetto "aaa_elflibs-13.1-i486-1" contiene il file "usr/lib/libltdl.so.3.1.6", mentre il pacchetto "libtool-2.2.6b-i486-2" contiene "usr/lib/libltdl.so.7.2.1".
Controlla di avere quei pacchetti/file ed eventualmente fai un
Codice: Seleziona tutto
#cd /usr/lib
#if ! ls libltdl.so.7 &> /dev/null ; then ln -l libltdl.so.7.2.1 libltdl.so.7 ; fi
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2621
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: libltdl.so.7 mancante

Messaggioda james2221 » mar mag 17, 2011 18:00

ho risolto
però non saprei dire come, ovvero:
ho installato libtool-2.2 ma ne faceva di tutti i colori pertanto l'ho disinstallato, ho re-installato fluxbox (stessa versione a quella già presente) e, logout-login, si è messo a posto.
però non ho trovato, tra le lib richieste da fluxbox, libltdl.so.7, per cui mi chiedo: dove è andato a prenderla???
grazie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron