Pagina 1 di 3

DigiKam

Inviato: dom lug 31, 2011 21:52
da roberto67
Ciao, come saprete è uscito digiKam 2.0.
Qualcuno è riuscito fare il pacchetto? Ovviamente no, altrimenti sarebbe già in repository. Io ho seguito le dritte di Willy Sudiarto (http://slackblogs.blogspot.com/2011/07/ ... pdate.html) ma non riesco a compilare e l'errore che ottengo non mi dice molto sulle ulteriori cure possibili (vedere sotto).
Per i prerequisiti mi pare di averli tutti: ho fatto il pacchetto openvc (2.3.0), che richiede ffmpeg (0.6.3 di AlienBob) e lensfun. Le altre dipendenze dovrebbe installarle digiKam dalla sua directory "extra" e il resto è già su Slackware. Purtroppo mi crasha il link a libkface in questo modo, come se openvc non fosse compatibile, eppure Suduarto assicura di aver fatto le cose con queste versioni e con KDE 4.6.5.

mi sarebbe di gran aiuto una dritta da chi l'ha già installato
grazie
Roberto

Codice: Seleziona tutto

Scanning dependencies of target kface
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/kface_automoc.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/database.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/face.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/kfaceutils.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/image.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/facedetector.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/recognitiondatabase.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/__/libface/LibFaceUtils.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/__/libface/FaceDetect.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/__/libface/Face.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/__/libface/Eigenfaces.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/__/libface/LibFace.cpp.o
[  5%] Building CXX object extra/libkface/libkface/CMakeFiles/kface.dir/__/libface/Haarcascades.cpp.o
Linking CXX shared library ../../../lib/libkface.so
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libpthread.so when searching for -lpthread
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libpthread.a when searching for -lpthread
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libstdc++.so when searching for -lstdc++
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libstdc++.a when searching for -lstdc++
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libm.so when searching for -lm
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libm.a when searching for -lm
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libc.so when searching for -lc
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libc.a when searching for -lc
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libgcc_s.so when searching for -lgcc_s
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libc.so when searching for -lc
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libc.a when searching for -lc
/usr/lib64/gcc/x86_64-slackware-linux/4.5.3/../../../../x86_64-slackware-linux/bin/ld: skipping incompatible /usr/share/OpenCV/../../lib/libgcc_s.so when searching for -lgcc_s
collect2: ld returned 1 exit status
make[2]: *** [lib/libkface.so.1.0.0] Error 1
make[1]: *** [extra/libkface/libkface/CMakeFiles/kface.dir/all] Error 2
make: *** [all] Error 2

Re: DigiKam

Inviato: lun ago 01, 2011 9:20
da 414N
Dal messaggio, sembra che il tuo OpenCV (non openvc) abbia degli strani collegamenti a /usr/lib (a 32 bit, quindi).
Sicuro di averlo compilato a 64 bit?

Re: DigiKam

Inviato: lun ago 01, 2011 15:41
da roberto67
414N ha scritto:Dal messaggio, sembra che il tuo OpenCV (non openvc) abbia degli strani collegamenti a /usr/lib (a 32 bit, quindi).
Sicuro di averlo compilato a 64 bit?


credo proprio di no, l'ho anche ricompilato defininendo espressamente l'architettura, e inoltre

Codice: Seleziona tutto

# ls /var/log/packages/opencv*
/var/log/packages/opencv-2.3.0-x86_64-1_SBo

non vorrei che fosse un'interferenza con le multilib.. che però non mi hanno mai dato problemi.
ho anche riprovato a compilare a mano libkface, e mi sono accorto di dover ridefinire QTDIR=/usr/lib64/qt4/ visto che ho anche qt3 installato, ma l'errore è sempre lo stesso

grazie comunque per la risposta
Roberto

Re: DigiKam

Inviato: ven ago 05, 2011 15:06
da roberto67
Torno alla carica con digiKam. Dopo una settimana di prove ancora non riesco ancora a fare il pacchetto.
C'è qualcuno che è riuscito fare il pacchetto sulla piattaforma a 64b? Mi pare che in giro ci siano pacchetti e feedback positivi solo da utenti con piattaforma a 32b.
Se può essere importante uso le multilib (ma nulla da fare anche senza) e KDE 4.7 (ma stessi errori con la 4.6.5). Ho una slackware64-current.

Come vedete sopra c'è un conflitto tra le librerie che servono a digiKam e quelle che vengono installate insieme a opencv.

Quello che non mi è chiaro è quali siano esattamente le dipendenze. openvc non viene citato tra le dipendenze nè su SBo, nè nei pacchetti rilasciati qui da conraid, eppure la pacchettizzazione va a male senza opencv.

Ho provato tutti gli slackbuild reperibili in rete su SBo e qui su slacky.eu, che poi non sono molto dissimili tra loro. Ho seguito le indicazioni di Willy Sudiarto, ma nulla.
Ho fatto anche delle prove con la versione 1.9 e il relativo slackbuild di conraid, ma mi mancano le librerie. Ad esempio libkipi, della quale ho adattato lo slackbuild di alien (vecchissimo per 12.2), ma va in errore non trovando le librerie KDE:

Codice: Seleziona tutto

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE libraries installed. This will fail.
So, check this please and use another prefix!


e ho variato --prefix in tutti i modi possibili.

Per favore datemi voi una dritta [-o<
Grazie in anticipo per ogni risposta.

Re: DigiKam

Inviato: ven ago 05, 2011 19:13
da 414N
roberto67 ha scritto:Quello che non mi è chiaro è quali siano esattamente le dipendenze. openvc non viene citato tra le dipendenze nè su SBo, nè nei pacchetti rilasciati qui da conraid, eppure la pacchettizzazione va a male senza opencv.

Su SBo non è menzionato opencv tra le dipendenze perché la libreria libkface è stata introdotta solo in digikam 2, ed è proprio questa che si appoggia a opencv per effettuare il riconoscimento facciale. Dato che su SBo sono fermi alla 1.9.0, tutto questo è normale.
roberto67 ha scritto:Ho fatto anche delle prove con la versione 1.9 e il relativo slackbuild di conraid, ma mi mancano le librerie. Ad esempio libkipi, della quale ho adattato lo slackbuild di alien (vecchissimo per 12.2), ma va in errore non trovando le librerie KDE:

Codice: Seleziona tutto

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE libraries installed. This will fail.
So, check this please and use another prefix!


e ho variato --prefix in tutti i modi possibili.

Per forza, devi installare quelli che su SBo trovi come kipi-plugins, non libkipi.
Libkipi è deprecata (ed è per quello che la trovi solo per 12.2) ed è anche perfettamente normale che non ti trovi il prefisso di installazione di KDE: è perché cerca KDE3, non KDE4.

Re: DigiKam

Inviato: ven ago 05, 2011 21:13
da erio
guarda che con kde 4.7.0, 3 llibrerie che ti servono sono nel pacchetto di alien bob,ho provato a fare il pacchetto con una 64 senza multitab e ho dovuto fare una libreria aggiuntiva che è questa:libkexiv2-devel-4.7.0-1.fc16.x86_64.txz da un file rpm ora sta compilando,
libkexiv2-4.7.0-x86_64-1alien.txz
libkipi-4.7.0-x86_64-1alien.txz
libkdcraw-4.7.0-x86_64-1alien.txz

Re: DigiKam

Inviato: ven ago 05, 2011 23:08
da Vito

Re: DigiKam

Inviato: sab ago 06, 2011 0:25
da roberto67
erio ha scritto:guarda che con kde 4.7.0, 3 llibrerie che ti servono sono nel pacchetto di alien bob,ho provato a fare il pacchetto con una 64 senza multitab e ho dovuto fare una libreria aggiuntiva che è questa:libkexiv2-devel-4.7.0-1.fc16.x86_64.txz da un file rpm ora sta compilando,
libkexiv2-4.7.0-x86_64-1alien.txz
libkipi-4.7.0-x86_64-1alien.txz
libkdcraw-4.7.0-x86_64-1alien.txz


si grazie, infatti queste librerie ce le ho già installate. E io che stavo impazzendo con libkipi (ma perchè allora non me lo trovava? bah)

***

La situazione attuale è questa: ho fatto il pacchetto kipi-plugins (dopo aver rimosso opencv) e installato il pacchetto digikam 1.9 scaricato da slacky.eu. Dopo aver aggiustato alcuni link simbolici alle librerie libkdcraw ecc., ho lanciato digikam, finalmente mi si apre una finestra (e io felice), faccio la prima configurazione ma subito crasha così:

digikam: symbol lookup error: /usr/lib64/libdigikamcore.so.1: undefined symbol: _ZNK6Marble12MarbleWidget3mapEv


ed è un errore che non mi dice nulla..

che devo fare? #-o

Re: DigiKam

Inviato: sab ago 06, 2011 11:01
da 414N
roberto67 ha scritto:La situazione attuale è questa: ho fatto il pacchetto kipi-plugins (dopo aver rimosso opencv) e installato il pacchetto digikam 1.9 scaricato da slacky.eu. Dopo aver aggiustato alcuni link simbolici alle librerie libkdcraw ecc., ho lanciato digikam, finalmente mi si apre una finestra (e io felice), faccio la prima configurazione ma subito crasha così:

digikam: symbol lookup error: /usr/lib64/libdigikamcore.so.1: undefined symbol: _ZNK6Marble12MarbleWidget3mapEv


ed è un errore che non mi dice nulla..

che devo fare? #-o

Dev'essere perché ti manca qualche libreria relativa a marble.
Io ho installato tutto quanto raccomandato su SBo e non ho alcun problema.
Prova a fartelo te il pacchetto di digikam.

Re: DigiKam

Inviato: sab ago 06, 2011 11:59
da Vito
Ma perchè non lo istalli con le dipendenze del nostro repository?
Richiede solo lensfun.
Poi se cerchi la versione 2.0.0 il discorso è diverso.

EDIT: ho letto solo ora che cerchi la versione 2.0.0. :)

Re: DigiKam

Inviato: sab ago 06, 2011 12:28
da conraid
io la versione 2.0 me la sono compilata su una -current (32 e 64bit con kde di default e senza multilib) senza nessun problema e senza nessuna dipendenza in più rispetto alla 1.9
Però non l'ho installata e non l'ho messa nel repository perché sostituisce delle librerie di sistema che non mi va di sostituire, anche perché uso pochissimo digikam per mettermi a fare cose simili.

Re: DigiKam

Inviato: sab ago 06, 2011 14:26
da roberto67
414N ha scritto:
roberto67 ha scritto:La situazione attuale è questa: ho fatto il pacchetto kipi-plugins (dopo aver rimosso opencv) e installato il pacchetto digikam 1.9 scaricato da slacky.eu. Dopo aver aggiustato alcuni link simbolici alle librerie libkdcraw ecc., ho lanciato digikam, finalmente mi si apre una finestra (e io felice), faccio la prima configurazione ma subito crasha così:

digikam: symbol lookup error: /usr/lib64/libdigikamcore.so.1: undefined symbol: _ZNK6Marble12MarbleWidget3mapEv


ed è un errore che non mi dice nulla..

che devo fare? #-o

Dev'essere perché ti manca qualche libreria relativa a marble.
Io ho installato tutto quanto raccomandato su SBo e non ho alcun problema.
Prova a fartelo te il pacchetto di digikam.


ok grazie, proverò domani notte al mio rientro..

Re: DigiKam

Inviato: sab ago 06, 2011 14:32
da roberto67
Vito ha scritto:Ma perchè non lo istalli con le dipendenze del nostro repository?
Richiede solo lensfun.
Poi se cerchi la versione 2.0.0 il discorso è diverso.

EDIT: ho letto solo ora che cerchi la versione 2.0.0. :)


non mi risulta che lensfun sia l'unica dipendenza.. per quanto riguarda 1.9 ho dovuto installare e kipi-plugins, e può darsi che siano necessari alcuni pacchetti già presenti nel KDE 4.7 (libkipi e altri)

facendo il pacchetto 2.0 su una -current (andando a memoria) mi veniva richiesto openvc, che a sua volta richiedeva ffmpeg. Li ho fatti e installati, ma lanciando la creazione del pacchetto digikam, che a sua volta installa tutte le dipendenze nella directory extra, venova fuori il conflitto di cui sopra. Lo stesso compilando a mano i pacchetti presenti in extra.

Re: DigiKam

Inviato: sab ago 06, 2011 14:36
da roberto67
conraid ha scritto:io la versione 2.0 me la sono compilata su una -current (32 e 64bit con kde di default e senza multilib) senza nessun problema e senza nessuna dipendenza in più rispetto alla 1.9
Però non l'ho installata e non l'ho messa nel repository perché sostituisce delle librerie di sistema che non mi va di sostituire, anche perché uso pochissimo digikam per mettermi a fare cose simili.


ciao conraid, e grazie per il tuo pacchetto. Ho aperto questo thread proprio perchè sto rimbecillendo per capire esattamente qual è la sequenza dei prerequisiti da installare. Può darsi che ci siano delle differenze con il KDE di default sulla 13.37, e comunque da più parti ho letto che è necessario opencv, ma tu mi scrivi di no. Non è che per caso a te e gli altri non viene richiesto per il fatto che ce l'avete già installato?

Edit: ehi! Ho superato i 100 post e mi ha messo una stellina! Ma continuo a sentirmi un novellino.. :D

Re: DigiKam

Inviato: sab ago 06, 2011 16:09
da conraid
opencv ci vuole anche per digikam 1.9, o meglio per kipi-plugins 1.9, infatti ho scritto "senza alcuna dipendenza in più rispetto alla 1.9", tieni presente che le dipendenze di digikam e kipi-plugins adesso sono unite.
Kipi-plugins aveva bisogno (o almeno io lo avevo compilato con queste) di:

Codice: Seleziona tutto

libgpod
libplist
opencv
qjson


digikam invece:

Codice: Seleziona tutto

lensfun
liblqr


ora sono unificate