Repository 32bit  Forum
Repository 64bit  Wiki

[Risolto]: virtualbox non va a buon fine la compilazione

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[Risolto]: virtualbox non va a buon fine la compilazione

Messaggioda james2221 » mar ago 30, 2011 14:20

ciao
dopo aver strenuamente lottato con la mia stampante (ho scritto su tutti i forum d'Europa ma non riesco a farla andare) mi sono deciso a virtualizzare xp.
Ma ovviamente sono già fermo al primo passo.
Dunque: ho scaricato questa versione:
VirtualBox-4.1.0_OSE_BETA1
e ho iniziato la solita procedura, ovvero scompattato e dato il
Codice: Seleziona tutto
./configure

al che mi compare questa dicitura
Codice: Seleziona tutto
root@piero:/home/piero/Downloads/VirtualBox-4.1.0_OSE_BETA1# ./configureChecking for environment: Determined build machine: linux.x86, target machine: linux.x86, OK.
Checking for kBuild: found, OK.
Checking for gcc:
  ** g++ (variable CXX) not found!
Check /home/piero/Downloads/VirtualBox-4.1.0_OSE_BETA1/configure.log for details
root@piero:/home/piero/Downloads/VirtualBox-4.1.0_OSE_BETA1#

mi viene il dubbio che mi manchino i tools per compilare.
tra i pacchetti installati mi pare di avere tutto, e comunque ho già compilato, però sono passati alcuni mesi, non vorrei mai con qualche aggiornamento aver fatto danni...

qualche anima buona sul forum ?
grazie
james
Ultima modifica di james2221 il sab ott 29, 2011 7:42, modificato 1 volta in totale.
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10

Re: virtualbox non va a buon fine la compilazione

Messaggioda 414N » mar ago 30, 2011 17:04

james2221 ha scritto:ciao
dopo aver strenuamente lottato con la mia stampante (ho scritto su tutti i forum d'Europa ma non riesco a farla andare) mi sono deciso a virtualizzare xp.

Visto che avevo un po' di tempo a disposizione e il problema non l'hai ancora risolto, ti ho creato un pacchetto io con la procedura che ti ho riportato.
Maggiori dettagli nell'altro thread ;)
Venendo all'attuale problema, sembra proprio che il configure non trovi g++.
Se provi ad immetterlo da riga di comando cosa ti compare? A me compare
Codice: Seleziona tutto
g++: no input files

Controlla di avere installato il pacchetto gcc-g++, che dovrebbe essere sotto la categoria d/ (development).
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: virtualbox non va a buon fine la compilazione

Messaggioda james2221 » sab ott 29, 2011 7:41

ciao
il thread è leggermente stantio ma mi scocciava non poterci scrivere : Risolto.
Il problema è superato in quanto per varie ragioni ho re-installato Slackware 13.37 64bit invece di 32bit, Xfce4 invece di Kde.
Con la nuova installazione mi sono accertato che tutti i pacchetti della sezione development fossero installati. Ho poi scaricato da sito oracle
https://www.virtualbox.org/wiki/Linux_Downloads
la versione 64bit e tutto è sistemato, tra l'altro la versione
VirtualBox-4.1.0_OSE_BETA1
che avrei voluto installare non prevedeva, se non erro, il supporto per le USB e mi sarei ritrovato con windows virtualizzato ma senza possibilità di stampare.
grazie in particolare a
414N
che si è dato tanto da fare, ma per mia manifesta incapacità il tutto non è andato a buon fine.
grazie
james
james2221
Linux 2.4
Linux 2.4
 
Messaggi: 200
Iscritto il: dom feb 06, 2011 0:28
Località: brescia
Slackware: 14 86_64
Desktop: xfce4.10


Torna a Packages

Chi c’è in linea

Visitano il forum: Bing [Bot] e 5 ospiti

cron