Repository 32bit  Forum
Repository 64bit  Wiki

installazione di wine 1.4.rc4

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

installazione di wine 1.4.rc4

Messaggioda tornadomig » gio mar 01, 2012 18:11

ciao!

spero sia utile, metto solo la mia esperienza sull' installazione di wine e office 2003 + sp3.

per far cio' son partito con una installazione fresca della slack64 current rilasciata da slackware.no il 28-02-2012. con i pacchetti di alienbob e' ora una multilib.
il pc dove ho per ultimo fatto questa prova riuscita e' un quad core con gpu nvidia, per ora ho i driver nouveau. questa procedura e' andata a buon fine anche su un altro pc dual core sempre con slack64 current kernel 3.2.8. cosi' vi e' un precedente :)

come si indica saggiamente sul repo di slacky.eu, dopo aver reso multilib la mia 64 current, installo wine_gecko che la prima volta ho compilato con lo slackbuild, ma ieri e oggi mi da' error not found dal server, boh :-k comunque installo con pkgtool il pacchetto binario.

poi installo webcore-fonts (cabextract e libreoffice di alienbob son gia' stati installati, rimosso pure il font 60-liberation.conf) con il suo slackbuild dopo averlo prima pero' modificato con nano alla voce ARCH in x86_64 (prima era indicato -i486 o o -i686).

poi e' la volta di openal-soft, come prima modifico il suo slackbuild inserendo alla voce ARCH di nuovo, x86_64 al posto di -i486 o -i686.

ora tocca a fontforge, cui mi ha aiutato il gentilissimo 414N, consigliandomi un suo personale script oltre all'utilizzo di quest'altro script . /etc/profile.d/32dev.sh che servono per compilare a 32 bit.
ecco, dato che sono niubbo, io ho utilizzato questi script ed ho ottenuto i pacchetti compat32 per le dipendenze, ma alla fine dei conti, con questi non arrivavo mai alla fine con wine e quindi a installare office 2003.

fontforge mi ha davvero rallentato e dopo un po' di tentativi volevo rinunciare; perche' mancante alla compilazione, ho dovuto installare da slackbuilds.org/mirror/slackware/slackware64-current/source/l/ il pacchetto freetype-2.4.8, modifico lo slackbuild inserendo -2.4.8 al posto di -2.4.4 dove indicava FREETYPE, poi al posto di -i486 inserisco -86_64 sempre dove vi e' ARCH. fontforge cosi' mi compila e lo installo.

wine: ieri, con gli script build32 di 414N e l'altro che ho indicato prima, non c'era verso di arrivare alla fine della compilazione, vi erano sempre errori o dll mancanti di cui sono ignorante. ecco perche' ho deciso oggi di reinstallare la slack64 current.

quindi, modifico lo slackbuild di wine, tolgo -i486 o -i686 e inserisco -86_64 sempre dove indica ARCH e finalmente ottengo il pacchetto di wine.

ieri invece, con i pacchetti compat32 delle dipendenze installavo wine, sempre con ARCH -x86_64 ma office 2003 si bloccava all'inizio dell'installazione.

oggi evitando di convertire i pacchetti in compat32 e con la modifica ARCH -x86_64 nello slackbuid di wine, ho fatto tutto, in piu' office.
mi scarico poi il sp3 di office nella mia /home, installo visio dal cd di office e poi il sp3 scaricato prima, il tutto senza ottenere errori.
apro word e funzia, excel prima si pianta poi mi fa avviare in mod. provv. ma riavviando tutto torna normale. i fonts ci sono...per me e' ok.

che sia compilato a 32 o 64 bit, a me interessa che funzioni.


spero di non essere stato noioso. a me e' andata cosi' ma credetemi volevo piantare tutto. #-o dato che con gentoo multilib ero riuscito, volevo farlo andare anche su slack.

ripeto, e' solo la mia esperienza poi se altri son riusciti diversamente, son curioso di sapere come gli e' andata.



grazie sempre dell'impegno nel portare avanti la slack! :thumbright:
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: installazione di wine 1.4.rc4

Messaggioda tornadomig » sab mar 10, 2012 22:17

mmmmm e non funzia outlook :D

il resto va ;)
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo

Re: installazione di wine 1.4.rc4

Messaggioda tornadomig » ven mar 23, 2012 23:06

mmmmm di nuovo...con gli upgrade di wine il trucchetto postato non funziona piu', peccato. non mi va nemmeno facendolo come dovrebbe essere fatto, boh, io ho i miei limiti :)...pero' con il pacchetto di alienbob la cosa va a posto lo stesso. forse anche meglio. qualcuno storcera' il naso, lo so, chiedo venia ma ho la coscienza a posto :)

un caro saluto a tutti gli slackers!
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.6
Linux 2.6
 
Messaggi: 507
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -curr64 uefi_grub
Kernel: 3.14.17
Desktop: KDE-4.14.0
Distribuzione: gentoo


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti