Repository 32bit  Forum
Repository 64bit  Wiki

pacchetti mancanti nelle dipendenze del repo

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

pacchetti mancanti nelle dipendenze del repo

Messaggioda tornadomig » sab mar 10, 2012 14:06

ciao a tutti


nelle dipendenze di ffmpeg per slackware 13.37-64, manca scons come dipendenze di libffado.

mi capita come qualcun'altro che usa gli slackbuild, di rinvenire questi pacchetti mancanti. e' lecito segnalarli successivamente in questo forum?

grazie!
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: pacchetti mancanti nelle dipendenze del repo

Messaggioda tornadomig » sab mar 10, 2012 14:55

manca anche libnut come dipendenza di ffmpeg
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: pacchetti mancanti nelle dipendenze del repo

Messaggioda miklos » sab mar 10, 2012 15:20

mancano(ma sono presenti comunque nel repo per l'installazione) perchè sono pacchetti che servono esclusivamente per compilare e non per il corretto funzionamento. in particolare

- scons è un sistema per i build tipo make
- lbnut viene compilata staticamente all'interno di ffmpeg.

per questo motivo non sono menzionate come dipendenze del pacchetto.
all'interno del tool che usiamo noi packager c'e' una sezione ad-hoc per segnalare questo tipo di dipendenze, pero' il pkgmanager del sito elenca solo quelle che servono a runtime e non quelle per un eventuale ricompilazione.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1200
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: pacchetti mancanti nelle dipendenze del repo

Messaggioda tornadomig » sab mar 10, 2012 15:31

grazie!

e oltretutto ffmpeg mi chiede libopenjpeg pure quando openjpeg e' gia' installato...son bloccato, mannaggia
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: pacchetti mancanti nelle dipendenze del repo

Messaggioda tornadomig » sab mar 10, 2012 15:34

vabbe'...uso ffmpeg di alienbob...vediamo come va...
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: pacchetti mancanti nelle dipendenze del repo

Messaggioda miklos » sab mar 10, 2012 15:35

ma che versione stai compilando??
tieni conto che l'ffmpeg che trovi nel repo l'ho ricompilato da poco senza alcun problema.
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1200
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: pacchetti mancanti nelle dipendenze del repo

Messaggioda tornadomig » sab mar 10, 2012 22:16

beh mi sembra ovvio, quella del repo di slacky, se no non l'avrei scritto. comunque con quella di alienbob ho risolto, compilato in una botta sola in automatico. io sono su current. magari e' li' il problema.
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: pacchetti mancanti nelle dipendenze del repo

Messaggioda miklos » dom mar 11, 2012 3:12

tornadomig ha scritto:beh mi sembra ovvio
a me non è sembrato tanto ovvio visto che volutamente quel pacchetto è fermo alla 0.8 e ho pensato che magari volevi compilarti una versione successiva.
comunque ho dato un occhiata allo slackbuild di alien e non viene compilato col supporto a openjpeg.
e anche se sarebbe stato utile anche per me capire che tipo di problema avevi sono contento che hai risolto :)

Offtopic: lode e gloria al grande alien, pero' sti slackbuilds all in one non li riesco proprio a vedere.. preferisco le code di sbopkg
ho visto cose che voi astemi non potete immaginare
miklos
Linux 3.x
Linux 3.x
 
Messaggi: 1200
Iscritto il: lun lug 16, 2007 16:39
Località: Roma
Slackware: 14.1 64bit
Kernel: 3.12.6
Desktop: openbox 3.5.2

Re: pacchetti mancanti nelle dipendenze del repo

Messaggioda tornadomig » dom mar 11, 2012 20:53

eh mi scuso e chiarisco. prima di tutto utilizzo il repo slacky poi ripiego su alienbob. certo che mi sarebbe piaciuto capire perche' libopenjpeg non va. eppure ho cercato di essere piu' simple che si puo' nel seguire la coda di tutte queste benedette dipendenze. che poi preferisco sempre usare i vostri slackbuilds proprio per vedere se occorrono altre dipendenze appunto...ma forse e' perche' sono sulla current. ogni tanto capita di inceppare qualche compilazione...mah


grazie miklos del supporto!!!
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite