Pagina 6 di 10

Re: flash in blu

Inviato: sab ott 20, 2012 1:36
da tornadomig
al momento su youtube non ho video puffati con firefox ultimo. sono slack 14 stable
nvidia 304.60 presi e compilati dal tuo repo
flashplayer-plugin-11.2.202.243-x86_64-1alien compilato
libvdpau-0.4.1-x86_64-1ponce preso da slackbuilds.org

altro non e' stato toccato

sul gioco da te postato anche se non mi piace :roll: va tutto senza blu e per ora e' cosi'. domani ti confermo se rimane tale. anzi se vuoi suggerirmi tu altri test, basta dirlo

Re: flash in blu

Inviato: sab ott 20, 2012 1:52
da ZeroUno
Il gioco non ha il problema del blu ma della lentezza (o meglio, lampeggio di alcune sezioni che non fanno un buon rendering)

Hai file quali /etc/adobe/mms.cfg o /etc/vdpau_wrapper.cfg ? sono loro che eliminano l'effetto puffo.

Re: flash in blu

Inviato: sab ott 20, 2012 8:23
da Trotto@81
Lo vedo bene quel gioco, ed è pure fluido.
Senza pacchetto esterno a te viene visualizzato meglio oppure carica di meno la cpu?

Re: flash in blu

Inviato: sab ott 20, 2012 9:41
da tornadomig
@ZeroUno

altro non e' stato toccato
nessuna modifica al file menzionato

poi guardo ancora quel giochetto...

Re: flash in blu

Inviato: sab ott 20, 2012 22:22
da ZeroUno
Ho caricato tutto su slacky (saranno su domattina)

Re: flash in blu

Inviato: dom ott 21, 2012 19:25
da ZeroUno
mmm. Da quando ho messo i 304.60 non mi funziona più la gestione della luminosità dello scrermo sul portatile via software (cioè dall'icona della batteria) e se stacco l'alimentatore quindi non varia la luminosità.
Se invece uso i pulsanti Fn+F4/F5 funziona.

Il changelog riporta:
Fixed a bug that caused the X server to crash if a display was put into DPMS off mode and subsequently reenabled while screen transformations are in use.

Added support for the "Backlight" RandR output property for configuring the brightness of some notebook internal panels.

Re: flash in blu

Inviato: mer ott 24, 2012 21:12
da Trotto@81
Hanno fixato e non ti funziona più?
Purtroppo non ho un portatile per darti il mio risconto.

Re: flash in blu

Inviato: mer ott 24, 2012 21:42
da ZeroUno
fixato?
Prima funzionava, ora no.
Non mi sembra una granfix ;)

appena posso faccio il downgrade così scopro se il problema rimane (magari ho sbagliato la configurazione, ma non mi sembra di averla toccata.
Comunque la fix era sul crash di X e a me non ha mai crashato.


Domanda.. Flash in blu é solo a 64bit o anche a 32?

Re: flash in blu

Inviato: mer ott 24, 2012 21:44
da boh
A me capita solo nel sistema a 64bit.
Però il sistema a 32bit non ha una scheda grafica nvidia.

EDIT: come feedback, volevo dire che ho installato i driver nvidia 304.60 (con il loro installer, non il pacchetto di ZeroUno) e l'effetto puffo era presente. Successivamente ho installato le libvdpau 0.5 e l'effetto è svanito! Il tutto con accelerazione hardware attiva :D

Re: flash in blu

Inviato: mer ott 24, 2012 22:51
da ZeroUno
come feedback, volevo dire che ho installato i driver nvidia 304.60 (con il loro installer, non il pacchetto di ZeroUno) e l'effetto puffo era presente. Successivamente ho installato le libvdpau 0.5 e l'effetto è svanito! Il tutto con accelerazione hardware attiva :D

Si, è ormai un dato di fatto (v. qualche pagina indietro) che l'ultima versione di libvdpau risolve il problema, mentre il vdpau di nvidia (pacchetto o installer che sia) no.
Io al momento mantengo quelle di nvidia perchè qualche problema con l'accelerazione ce l'ho.

Re: flash in blu

Inviato: mer ott 24, 2012 23:09
da ZeroUno
ZeroUno ha scritto:appena posso faccio il downgrade così scopro se il problema rimane (magari ho sbagliato la configurazione, ma non mi sembra di averla toccata.
Comunque la fix era sul crash di X e a me non ha mai crashato.

Confermo. Ho downgradato a 304.51 ed ora se stacco il cavo di alimentazione la luminosità varia (pur non avendo toccato la configurazione).
A meno che la 304.60 non abbia introdotto una nuova entry da dover configurare per attivare la gestione della luminosità.

Per ora mi tengo questa (con nvidia-vdpau, poi la provo anche con libvdpau 0.5) finchè nvidia non tira fuori un'altra fix o scopro l'arcano.

Purtroppo non posso fare troppi reboot al giorno (per lavorare tengo aperte 100 finestre, tra multiple login ssh, pagine web e documenti che non sono convenienti chiudere)

Re: flash in blu

Inviato: gio ott 25, 2012 10:11
da ZeroUno
http://www.nvidia.com/object/linux-disp ... river.html

Implemented workarounds for two Adobe Flash bugs by applying libvdpau commit ca9e637c61e80145f0625a590c91429db67d0a40 to the version of libvdpau shipped with the NVIDIA driver.


wow, li provo subito, e chissenefrega che sono beta, se è vero.


edit: questo credo che dimostri che le api (gli header) di nvidia-vdpau e libvdpau siano compatibili se non gli stessi. Il che significa che se rifaccio il pacchetto nvidia-vdpau posso anche fare un merge con libvdpau.

Re: flash in blu

Inviato: gio ott 25, 2012 10:18
da Trotto@81
Attendo sviluppi per fare un upgrade del tuo pacchetto nvidia 304.43 che uso con le libvdpau esterne.

Re: flash in blu

Inviato: gio ott 25, 2012 10:23
da ZeroUno
le vdpau esterne le ho messe sul 304.60

Re: flash in blu

Inviato: gio ott 25, 2012 10:31
da Trotto@81
Hanno gli header per compilare MPlayer con il supporto a vdpau?
La cosa che mi da fastidio è che sulle animazioni o video in flash ho l'effetto scia durante lo scrolling.
Ho tolto le due opzioni dal file nvidia.conf perchè mi rallentavano molto.