Repository 32bit  Forum
Repository 64bit  Wiki

Aggiornamento Skype

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Aggiornamento Skype

Messaggioda RedSkull92 » lun mag 14, 2012 12:42

http://www.megalab.it/8033/skype-per-gn ... to-sistema
Che ne pensate ?
Secondo voi n futuro sarà aggiornato più spesso ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Aggiornamento Skype

Messaggioda ZeroUno » lun mag 14, 2012 13:22

Sinceramente non sapevo che fosse stata acquisita da microsoft!!!


Comunque a quanto pare non è stato solo un bugfix della libpng, come dichiarato dall'articolo o da skype stesso.

Lo sto ripacchettizzando ed ho notato un paio di differenze:
1) la directory del tar scompattato non è più skype_static-VERSIONE ma skype_staticQT-VERSIONE
che includa già le qt la versione statica?
2) dal confronto dell'output di ldd del nuovo e del vecchio:
il vecchio mi da
-libXi.so.6
-libXrandr.so.2
il nuovo
+libgobject-2.0.so.0
+libtiff.so.4

Altre le vedo dopo. ora vado a pranzo. :-)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Aggiornamento Skype

Messaggioda conraid » lun mag 14, 2012 14:26

libtiff.so.4 su -current ancora non c'è, speriamo basti un link simbolico

basta un link simbolico alla versione .so.3
inoltre chiede libjpeg.so.8
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Aggiornamento Skype

Messaggioda ZeroUno » lun mag 14, 2012 15:23

strano. il primo ldd non me l'ha tirato fuori il libjpeg. ora invece si.

Confermo che il link è sufficiente.

Sto cercando di capire invece se ha bisogno delle qt o ce l'ha dentro. Il binario è 4M più grande.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Aggiornamento Skype

Messaggioda conraid » lun mag 14, 2012 15:32

4mb sono perché MS ci ha messo le mani :-)
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Aggiornamento Skype

Messaggioda ZeroUno » lun mag 14, 2012 15:39

mmm
ldd mi dice che non vuole libXrandr ma lsof mi dice di si. anzi, vuole anche libXfixes
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Aggiornamento Skype

Messaggioda conraid » lun mag 14, 2012 15:43

ZeroUno ha scritto:mmm
ldd mi dice che non vuole libXrandr ma lsof mi dice di si. anzi, vuole anche libXfixes


io ho lasciato tutte le librerie che c'erano prima, aggiungendo quelle 3 :-)
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Aggiornamento Skype

Messaggioda ZeroUno » lun mag 14, 2012 16:12

è una svista... libXfixes lo chiedeva pure prima e infatti ce l'avevo messo. la Xi però l'ho tolta (non voglio avere roba in più). E ancora non sono riuscito a capire se le qt le vuole o meno.

Prima di upparlo però devo risolvere qualche problema.
Di tanto in tanto quando la lancio crasha.
Codice: Seleziona tutto
/usr/bin/skype: line 16:   619 Aborted                 LD_PRELOAD=/usr/share/skype/lib32/libv4l/v4l2convert.so GCONV_PATH=/usr/share/skype/lib32/gconv QT_PLUGIN_PATH=/usr/share/skype/lib32/plugins /usr/share/skype/lib32/ld-linux.so.2 --library-path /usr/share/skype/lib32/ /usr/share/skype/skype
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Aggiornamento Skype

Messaggioda ZeroUno » lun mag 14, 2012 16:30

caricato: http://www.z01.eu/repo-slack/slackware6 ... pe_static/

Quando ho un po' più di tempo vedo di fare anche la versione per slacky (ovvero per -stable) ma questa dovrebbe funzionare anche con la 13.37.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Aggiornamento Skype

Messaggioda conraid » mar mag 15, 2012 8:55

ZeroUno ha scritto:è una svista... libXfixes lo chiedeva pure prima e infatti ce l'avevo messo. la Xi però l'ho tolta (non voglio avere roba in più). E ancora non sono riuscito a capire se le qt le vuole o meno.



ma le QT io non le avevo nemmeno prima, tranne che per i plugin

prima
Codice: Seleziona tutto
/opt/skype.old/lib32/ld-2.15.so
/opt/skype.old/lib32/libICE.so.6.3.0
/opt/skype.old/lib32/libSM.so.6.0.1
/opt/skype.old/lib32/libX11.so.6.3.0
/opt/skype.old/lib32/libXau.so.6.0.0
/opt/skype.old/lib32/libXcursor.so.1.0.2
/opt/skype.old/lib32/libXdmcp.so.6.0.0
/opt/skype.old/lib32/libXext.so.6.4.0
/opt/skype.old/lib32/libXfixes.so.3.1.0
/opt/skype.old/lib32/libXi.so.6.1.0
/opt/skype.old/lib32/libXinerama.so.1.0.0
/opt/skype.old/lib32/libXrandr.so.2.2.0
/opt/skype.old/lib32/libXrender.so.1.3.0
/opt/skype.old/lib32/libXss.so.1.0.0
/opt/skype.old/lib32/libXv.so.1.0.0
/opt/skype.old/lib32/libasound.so.2.0.0
/opt/skype.old/lib32/libc-2.15.so
/opt/skype.old/lib32/libcrypto.so.0.9.8
/opt/skype.old/lib32/libdl-2.15.so
/opt/skype.old/lib32/libexpat.so.1.5.2
/opt/skype.old/lib32/libfontconfig.so.1.4.4
/opt/skype.old/lib32/libfreetype.so.6.6.2
/opt/skype.old/lib32/libgcc_s.so.1
/opt/skype.old/lib32/libglib-2.0.so.0.2800.6
/opt/skype.old/lib32/libgthread-2.0.so.0.2800.6
/opt/skype.old/lib32/libm-2.15.so
/opt/skype.old/lib32/libnsl-2.15.so
/opt/skype.old/lib32/libnss_compat-2.15.so
/opt/skype.old/lib32/libnss_dns-2.15.so
/opt/skype.old/lib32/libnss_files-2.15.so
/opt/skype.old/lib32/libnss_nis-2.15.so
/opt/skype.old/lib32/libpthread-2.15.so
/opt/skype.old/lib32/libresolv-2.15.so
/opt/skype.old/lib32/librt-2.15.so
/opt/skype.old/lib32/libssl.so.0.9.8
/opt/skype.old/lib32/libstdc++.so.6.0.14
/opt/skype.old/lib32/libuuid.so.1.3.0
/opt/skype.old/lib32/libv4l/ov511-decomp
/opt/skype.old/lib32/libv4l/ov518-decomp
/opt/skype.old/lib32/libv4l/v4l1compat.so
/opt/skype.old/lib32/libv4l/v4l2convert.so
/opt/skype.old/lib32/libv4l1.so.0
/opt/skype.old/lib32/libv4l2.so.0
/opt/skype.old/lib32/libv4lconvert.so.0
/opt/skype.old/lib32/libxcb.so.1.1.0
/opt/skype.old/lib32/libz.so.1.2.5


adesso

Codice: Seleziona tutto
/opt/skype/lib32/ld-2.15.so
/opt/skype/lib32/libICE.so.6.3.0
/opt/skype/lib32/libSM.so.6.0.1
/opt/skype/lib32/libX11.so.6.3.0
/opt/skype/lib32/libXau.so.6.0.0
/opt/skype/lib32/libXcursor.so.1.0.2
/opt/skype/lib32/libXdmcp.so.6.0.0
/opt/skype/lib32/libXext.so.6.4.0
/opt/skype/lib32/libXfixes.so.3.1.0
/opt/skype/lib32/libXi.so.6.1.0
/opt/skype/lib32/libXinerama.so.1.0.0
/opt/skype/lib32/libXrandr.so.2.2.0
/opt/skype/lib32/libXrender.so.1.3.0
/opt/skype/lib32/libXss.so.1.0.0
/opt/skype/lib32/libXv.so.1.0.0
/opt/skype/lib32/libasound.so.2.0.0
/opt/skype/lib32/libc-2.15.so
/opt/skype/lib32/libcrypto.so.0.9.8
/opt/skype/lib32/libdl-2.15.so
/opt/skype/lib32/libexpat.so.1.5.2
/opt/skype/lib32/libfontconfig.so.1.4.4
/opt/skype/lib32/libfreetype.so.6.6.2
/opt/skype/lib32/libgcc_s.so.1
/opt/skype/lib32/libglib-2.0.so.0.2800.6
/opt/skype/lib32/libgobject-2.0.so.0.2800.6
/opt/skype/lib32/libgthread-2.0.so.0.2800.6
/opt/skype/lib32/libjpeg.so.8.0.1
/opt/skype/lib32/libm-2.15.so
/opt/skype/lib32/libnsl-2.15.so
/opt/skype/lib32/libnss_compat-2.15.so
/opt/skype/lib32/libnss_dns-2.15.so
/opt/skype/lib32/libnss_files-2.15.so
/opt/skype/lib32/libnss_nis-2.15.so
/opt/skype/lib32/libpthread-2.15.so
/opt/skype/lib32/libresolv-2.15.so
/opt/skype/lib32/librt-2.15.so
/opt/skype/lib32/libssl.so.0.9.8
/opt/skype/lib32/libstdc++.so.6.0.14
/opt/skype/lib32/libtiff.so.3.9.6
/opt/skype/lib32/libuuid.so.1.3.0
/opt/skype/lib32/libv4l/ov511-decomp
/opt/skype/lib32/libv4l/ov518-decomp
/opt/skype/lib32/libv4l/v4l1compat.so
/opt/skype/lib32/libv4l/v4l2convert.so
/opt/skype/lib32/libv4l1.so.0
/opt/skype/lib32/libv4l2.so.0
/opt/skype/lib32/libv4lconvert.so.0
/opt/skype/lib32/libxcb.so.1.1.0
/opt/skype/lib32/libz.so.1.2.5


senza contare link simbolici gconv e plugins appunto
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Aggiornamento Skype

Messaggioda ZeroUno » mar mag 15, 2012 19:28

si, intendevo qt plugin
Questa è roba tua: viewtopic.php?f=51&t=35228&start=15#p313536
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Aggiornamento Skype

Messaggioda RedSkull92 » mar mag 15, 2012 20:52

ma per la 32 bit ?
Avatar utente
RedSkull92
Linux 2.6
Linux 2.6
 
Messaggi: 554
Iscritto il: mar apr 21, 2009 16:25
Località: Palermo
Slackware: 64bit -current
Kernel: 3.5.4
Desktop: FluxBox

Re: Aggiornamento Skype

Messaggioda ZeroUno » mar mag 15, 2012 22:31

per 32 bit 2.2.0.35 su slacky.

Comunque non ho dubbi che la versione skype_static a 64 bit per current funzioni perfettamente su una slackware 32 current o 13.37 che sia. Certo, introduce ridondanza (sulle librerie già presenti nel sistema) ma dovrebbe funzionare
Magari per pulizia rinomina il pacchetto in i486 invece di x86_64.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current

Re: Aggiornamento Skype

Messaggioda conraid » mer mag 16, 2012 9:25

ZeroUno ha scritto:si, intendevo qt plugin
Questa è roba tua: http://www.slacky.eu/forum/viewtopic.ph ... 15#p313536


ed avevo lo stesso dubbio :-)
per il pacchetto hai ragione, per il resto ce le lascio. Mi sembra provavo per le emoticon e cose simili, che non vanno ugualmente. Poi faccio delle prove
Avatar utente
conraid
Staff
Staff
 
Messaggi: 12023
Iscritto il: mer lug 13, 2005 23:00
Località: Livorno
Nome Cognome: Corrado Franco
Slackware: current

Re: Aggiornamento Skype

Messaggioda ZeroUno » mer mag 16, 2012 9:27

A me le emoticon funzionano.
vabbé, ora non ho tempo, dopo parliamo dei residui funzionanti e non.
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg
Codice: Seleziona tutto
1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111
Avatar utente
ZeroUno
Staff
Staff
 
Messaggi: 4420
Iscritto il: ven giu 02, 2006 13:52
Località: Roma / Castelli
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current


Torna a Packages

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 1 ospite