Repository 32bit  Forum
Repository 64bit  Wiki

Clementine 1.0.1 e compilazione

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Clementine 1.0.1 e compilazione

Messaggioda F4B1CK » mer ago 29, 2012 9:40

Ciao a tutti,
sto provando a compilare l'ultima versione di Clementine (il player derivato da Amarok 1.4), su una macchina dove è installata l'ultima versione della current.
Provo a compilarmi il pacchetto perché comunque la versione 0.7.1 che si trova sui repository non và :-(

Detto ciò, penso di aver soddisfatto tutte le dipendenze, ho scaricato i sorgenti e lo slackbuild, ma una volta che parte la compilazione,
arrivati a circa la metà del processo, se ne esce con :

Codice: Seleziona tutto
[ 52%] Building CXX object src/CMakeFiles/clementine_lib.dir/core/organise.o
[ 52%] Building CXX object src/CMakeFiles/clementine_lib.dir/core/organiseformat.o
[ 52%] Building CXX object src/CMakeFiles/clementine_lib.dir/core/player.o
In file included from /tmp/SBo/clementine-1.0.1/src/core/player.cpp:30:0:
/tmp/SBo/clementine-1.0.1/src/internet/lastfmservice.h:30:24: fatal error: lastfm/Track: No such file or directory
compilation terminated.
make[2]: *** [src/CMakeFiles/clementine_lib.dir/core/player.o] Error 1
make[1]: *** [src/CMakeFiles/clementine_lib.dir/all] Error 2
make: *** [all] Error 2


ho capito che c'è qualcosa relativo a lastfm, ma non capisco come potrei risolvere.

Qualcuno mi da una mano?
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: Clementine 1.0.1 e compilazione

Messaggioda erio » mer ago 29, 2012 11:08

prova ad usare lo slackbuild di phantomX,e vedi se cambia la compilazione,perche' ha delle patch e mi pare anche per /clementine/patches/clementine-liblastfm1-compatibility.patch,se hai tutte le dipendenze a posto, provalo.
erio
Linux 3.x
Linux 3.x
 
Messaggi: 1065
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Clementine 1.0.1 e compilazione

Messaggioda d4z_c0nf » mer ago 29, 2012 11:09

Guarda ho dato un'occhiata veloce. Io non sto sull'ultima current ma ho notato questo:
pacchetto liblastfm (solo la parte interessante) del mio sistema (non aggiornato):
usr/include/lastfm/Mbid
usr/include/lastfm/Album
usr/include/lastfm/InternetConnectionMonitor
usr/include/lastfm/ws.h
usr/include/lastfm/global.h
usr/include/lastfm/Audioscrobbler
usr/include/lastfm/UrlBuilder
usr/include/lastfm/FingerprintableSource
usr/include/lastfm/Fingerprint
usr/include/lastfm/MutableTrack
usr/include/lastfm/FingerprintId
usr/include/lastfm/ScrobblePoint
usr/include/lastfm/Artist
usr/include/lastfm/Track
usr/include/lastfm/Scrobble
usr/include/lastfm/NetworkAccessManager
usr/include/lastfm/User
usr/include/lastfm/XmlQuery
usr/include/lastfm/misc.h
usr/include/lastfm/ParseError
usr/include/lastfm/RadioTuner
usr/include/lastfm/Tag
usr/include/lastfm/AuthenticatedUser
usr/include/lastfm/RadioStation
usr/include/lastfm/Playlist
usr/include/lastfm/Xspf
usr/include/lastfm/ScrobbleCache


pacchetto della current, preso dal MANIFEST:
drwxr-xr-x root/root 0 2012-08-14 11:22 usr/include/lastfm/
-rw-r--r-- root/root 1527 2012-06-18 05:37 usr/include/lastfm/Chart.h
-rw-r--r-- root/root 1340 2012-06-18 05:37 usr/include/lastfm/NetworkConnectionMonitor.h
-rw-r--r-- root/root 1106 2012-06-18 05:37 usr/include/lastfm/Tasteometer.h
-rw-r--r-- root/root 1610 2012-06-18 05:37 usr/include/lastfm/FingerprintableSource.h
-rw-r--r-- root/root 1661 2012-06-18 05:37 usr/include/lastfm/ScrobbleCache.h
-rw-r--r-- root/root 2495 2012-06-18 05:37 usr/include/lastfm/UrlBuilder.h
-rw-r--r-- root/root 5202 2012-06-18 05:37 usr/include/lastfm/User.h
-rw-r--r-- root/root 2061 2012-06-18 05:37 usr/include/lastfm/Tag.h
-rw-r--r-- root/root 1022 2012-06-18 05:37 usr/include/lastfm/Auth.h
-rw-r--r-- root/root 1722 2012-06-18 05:37 usr/include/lastfm/ScrobblePoint.h
-rw-r--r-- root/root 1421 2012-06-18 05:37 usr/include/lastfm/Playlist.h
-rw-r--r-- root/root 1874 2012-06-18 05:37 usr/include/lastfm/RadioTuner.h
-rw-r--r-- root/root 2571 2012-06-18 05:37 usr/include/lastfm/Album.h
-rw-r--r-- root/root 3138 2012-06-18 05:37 usr/include/lastfm/RadioStation.h
-rw-r--r-- root/root 2513 2012-06-18 05:37 usr/include/lastfm/Audioscrobbler.h
-rw-r--r-- root/root 1330 2012-06-18 05:37 usr/include/lastfm/Xspf.h
-rw-r--r-- root/root 3335 2012-06-18 05:37 usr/include/lastfm/Fingerprint.h
-rw-r--r-- root/root 2365 2012-06-18 05:37 usr/include/lastfm/global.h
-rw-r--r-- root/root 2456 2012-06-18 05:37 usr/include/lastfm/XmlQuery.h
-rw-r--r-- root/root 9593 2012-06-18 05:37 usr/include/lastfm/Track.h
-rw-r--r-- root/root 3439 2012-06-18 05:37 usr/include/lastfm/Artist.h
-rw-r--r-- root/root 2120 2012-06-18 05:37 usr/include/lastfm/NetworkAccessManager.h
-rw-r--r-- root/root 1972 2012-06-18 05:37 usr/include/lastfm/InternetConnectionMonitor.h
-rw-r--r-- root/root 2022 2012-06-18 05:37 usr/include/lastfm/Library.h
-rw-r--r-- root/root 1464 2012-06-18 05:37 usr/include/lastfm/AbstractType.h
-rw-r--r-- root/root 1718 2012-06-18 05:37 usr/include/lastfm/FingerprintId.h
-rw-r--r-- root/root 5269 2012-06-18 05:37 usr/include/lastfm/ws.h
-rw-r--r-- root/root 1404 2012-06-18 05:37 usr/include/lastfm/Mbid.h
-rw-r--r-- root/root 1603 2012-06-18 05:37 usr/include/lastfm/misc.h


Come vedi nel nuovo pacchetto tutte quelle librerie hanno l'estensione ".h".

Ora non so se il problema è della current o di clementine che non è aggiornato alle nuove liblastfm.
Se ti va puoi provare a modificare i sorgenti di Clementine per fargli vedere quei file:
rock@localhost:~/clementine-1.0.1 $ grep "lastfm/" src/internet/lastfm* | grep include
src/internet/lastfmservice.cpp:#include <lastfm/Audioscrobbler>
src/internet/lastfmservice.cpp:#include <lastfm/misc.h>
src/internet/lastfmservice.cpp:#include <lastfm/RadioStation>
src/internet/lastfmservice.cpp:#include <lastfm/Scrobble>
src/internet/lastfmservice.cpp:#include <lastfm/ScrobbleCache>
src/internet/lastfmservice.cpp:#include <lastfm/ScrobblePoint>
src/internet/lastfmservice.cpp:#include <lastfm/ws.h>
src/internet/lastfmservice.cpp:#include <lastfm/XmlQuery>
src/internet/lastfmservice.h:#include <lastfm/Track>
src/internet/lastfmservice.h:#include <lastfm/ws.h>
src/internet/lastfmsettingspage.cpp:#include <lastfm/ws.h>


Dovresti aggiungere l'esensione ".h".
Avatar utente
d4z_c0nf
Packager
Packager
 
Messaggi: 1293
Iscritto il: mar mar 14, 2006 18:07
Località: Salerno
Nome Cognome: Rocco Aliberti
Slackware: 14.1-64bit
Kernel: 3.10.17
Desktop: xfce

Re: Clementine 1.0.1 e compilazione

Messaggioda 414N » mer ago 29, 2012 16:39

Strano, io col tarball ricavato da git non ho problemi...
Ti allego lo script per scaricare un tarball di clementine da git che uso io. Occhio che verrà creata una directory clementine/ con tutto il ramo git nel path dove porrai lo script.
Successive esecuzioni riutilizzeranno quanto già scaricato per creare un tarball aggiornato.
Allegati
mksrc-tarball.sh
Tarball-generator per clementine-git
(716 Byte) Scaricato 14 volte
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Clementine 1.0.1 e compilazione

Messaggioda d4z_c0nf » mer ago 29, 2012 17:20

414N ha scritto:Strano, io col tarball ricavato da git non ho problemi...
Ti allego lo script per scaricare un tarball di clementine da git che uso io. Occhio che verrà creata una directory clementine/ con tutto il ramo git nel path dove porrai lo script.
Successive esecuzioni riutilizzeranno quanto già scaricato per creare un tarball aggiornato.


Non è strano, lui stava provando a compilare la 1.0.1, nella git ci sono delle variazioni, esempio:
da https://code.google.com/p/clementine-pl ... fmcompat.h (header che non esiste proprio nella 1.0.1)
Codice: Seleziona tutto
#ifdef HAVE_LIBLASTFM1
  #include <lastfm/Audioscrobbler.h>
  #include <lastfm/misc.h>
  #include <lastfm/ScrobbleCache.h>
  #include <lastfm/ScrobblePoint.h>
  #include <lastfm/User.h>
  #include <lastfm/ws.h>
  #include <lastfm/XmlQuery.h>
#else
  #include <lastfm/Audioscrobbler>
  #include <lastfm/misc.h>
  #include <lastfm/ScrobbleCache>
  #include <lastfm/ScrobblePoint>
  #include <lastfm/User>
  #include <lastfm/ws.h>
  #include <lastfm/XmlQuery>
#endif

Avatar utente
d4z_c0nf
Packager
Packager
 
Messaggi: 1293
Iscritto il: mar mar 14, 2006 18:07
Località: Salerno
Nome Cognome: Rocco Aliberti
Slackware: 14.1-64bit
Kernel: 3.10.17
Desktop: xfce

Re: Clementine 1.0.1 e compilazione

Messaggioda F4B1CK » gio ago 30, 2012 15:29

Ho provato a seguire il metodo di d4z_c0nf, andando ad editare i files per aggiungere .h ai nomi delle librerie da includere, ma anche così ancora mi dà errore di compilazione quando arriva ad AudioScrobber (avrò saltato qualche passaggio?) :

Codice: Seleziona tutto
In file included from /tmp/SBo/clementine-1.0.1/src/core/player.cpp:30:0:
/tmp/SBo/clementine-1.0.1/src/internet/lastfmservice.h:196:3: error: 'Audioscrobbler' in namespace 'lastfm' does not name a type
make[2]: *** [src/CMakeFiles/clementine_lib.dir/core/player.o] Error 1
make[1]: *** [src/CMakeFiles/clementine_lib.dir/all] Error 2
make: *** [all] Error 2


Invece il tarball scaricato con lo script di 414N non viene compilato perché lo slackbuild, in fase di configurazione, si ferma con degli errori.
Vorrei capire da dove poter scaricare uno slackbuild alternativo (si parlava di versioni con patch), o se esiste qualche repository contenente la versione compilata (visto che io non riesco a crearmi il pacchetto).

Grazie ancora per l'aiuto! :-(
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: Clementine 1.0.1 e compilazione

Messaggioda d4z_c0nf » gio ago 30, 2012 15:38

Spiace che non abbia funzionanto. Evidentemente non basta, sono cambiate altre cose nelle librerie di last.fm.
Comunque posta il problema nella fase di configurazione magari è un caso noto.
Avatar utente
d4z_c0nf
Packager
Packager
 
Messaggi: 1293
Iscritto il: mar mar 14, 2006 18:07
Località: Salerno
Nome Cognome: Rocco Aliberti
Slackware: 14.1-64bit
Kernel: 3.10.17
Desktop: xfce

Re: Clementine 1.0.1 e compilazione

Messaggioda 414N » gio ago 30, 2012 15:42

Ti riporto allora lo SlackBuild che uso io. È quello che trovi su slackbuilds.org con qualche piccola modifica ai CFLAGS, ma nulla di più.
Nessuna patch viene applicata, tra l'altro.
EDIT: SlackBuild allegato ricaricato e riportato inline nel seguito:
Codice: Seleziona tutto
#!/bin/sh

# Slackware build script for clementine

# Copyright 2010  David Woodfall <dave@dawoodfall.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# Modified by SlackBuilds.org

PRGNAM=clementine
VERSION=${VERSION:-0.5.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) export ARCH=i486 ;;
    arm*) export ARCH=arm ;;
       *) export ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

mkdir build
cd build
  cmake \
   -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
   -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
   -DCMAKE_INSTALL_PREFIX=/usr \
   -DLIBRARY_OUTPUT_PATH=$PKG/usr/lib${LIBDIRSUFFIX} \
   -DLIB_SUFFIX=${LIBDIRSUFFIX} \
   -DMAN_INSTALL_DIR=/usr/man \
   -DCMAKE_BUILD_TYPE=Release \
   ..
  make ${NUMJOBS:--j4} all CFLAGS="-fPIC" PMFLAGS="-DNEWBUFFER"
  make install DESTDIR=$PKG
cd ..

for i in 16 32 64 ; do
  install -m 0644 -D dist/${PRGNAM}_${i}.png \
    $PKG/usr/share/icons/hicolor/${i}x${i}/apps/application-x-clementine.png
done
install -m 0644 -D dist/${PRGNAM}.desktop $PKG/usr/share/applications/

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
#cp -a TODO $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
Allegati
clementine.tar.bz2
SlackBuild per clementine (2)
(10 KiB) Scaricato 3 volte
Ultima modifica di 414N il gio set 06, 2012 14:46, modificato 2 volte in totale.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Clementine 1.0.1 e compilazione

Messaggioda erio » gio ago 30, 2012 16:30

erio
Linux 3.x
Linux 3.x
 
Messaggi: 1065
Iscritto il: ven ott 09, 2009 18:25
Slackware: 13.37
Kernel: 3.0.7
Desktop: kde

Re: Clementine 1.0.1 e compilazione

Messaggioda LoneStar » mer set 05, 2012 23:21

ci vuole una patch...

http://svnweb.mageia.org/packages/cauldron/clementine/current/SOURCES/clementine-1.0.1-liblastfm-1.0.patch?view=log

Comunque a me Clementine 1.0.1 non funziona più sulla Current, da quando s'è passati a OpenSSL 1.0.1 .. compila perfettamente ma poi va in segmentation fault. Pare succeda solo su Slack. Nessun aiuto finora.
Avatar utente
LoneStar
Linux 1.0
Linux 1.0
 
Messaggi: 88
Iscritto il: ven ago 15, 2008 10:10
Località: Ragusa
Slackware: current 32 & 64
Kernel: 3.4.2
Desktop: KDE4

Re: Clementine 1.0.1 e compilazione

Messaggioda F4B1CK » gio set 06, 2012 14:41

414N ha scritto:Ti riporto allora lo SlackBuild che uso io. È quello che trovi su slackbuilds.org con qualche piccola modifica ai CFLAGS, ma nulla di più.
Nessuna patch viene applicata, tra l'altro.


Ho provato a scaricare questo slackbuild, ma quando vado a decomprimerlo per avere lo script mi dà errore sull'archivio. Dato che ho provato più volte penso sia corrotto.

Poi ho provato ad utilizzare lo slackbuild suggerito da ERIO, ma mi dà i seguenti errori (ometto le parti di log che non servono) :

Codice: Seleziona tutto
clementine_pX.SlackBuild: line 107: qmake-qt4: command not found
clementine_pX.SlackBuild: line 108: qmake-qt4: command not found
...
-- The C compiler identification is GNU 4.7.1
-- The CXX compiler identification is GNU 4.7.1
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.25")
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt4: /usr/bin/qmake (found suitable version "4.8.2", required is "4.5.0")
-- Found Qt4: /usr/bin/qmake (found version "4.8.2")
-- Found Qt4: /usr/bin/qmake (found version "4.8.2")
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove 
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Found OpenGL: /usr/lib/libGL.so
-- Boost version: 1.49.0
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.1")
-- Could NOT find PROTOBUF (missing:  PROTOBUF_LIBRARY PROTOBUF_INCLUDE_DIR)
-- checking for module 'taglib>=1.6'
--   found taglib, version 1.7.2
-- checking for module 'QJson'
--   found QJson, version 0.7.1
-- checking for module 'gstreamer-0.10' 
--   found gstreamer-0.10, version 0.10.36
-- checking for module 'gstreamer-base-0.10'
--   found gstreamer-base-0.10, version 0.10.36
-- checking for module 'gstreamer-app-0.10'
--   found gstreamer-app-0.10, version 0.10.36
-- checking for module 'gstreamer-cdda-0.10'
--   found gstreamer-cdda-0.10, version 0.10.36
-- checking for module 'gstreamer-tag-0.10'
--   found gstreamer-tag-0.10, version 0.10.36
-- checking for module 'glib-2.0'
--   found glib-2.0, version 2.32.4
-- checking for module 'libxml-2.0'
--   found libxml-2.0, version 2.8.0
-- checking for module 'gobject-2.0'
--   found gobject-2.0, version 2.32.4
-- checking for module 'libgpod-1.0>=0.7.92'
--   found libgpod-1.0, version 0.8.2
-- checking for module 'gio-2.0'
--   found gio-2.0, version 2.32.4
-- checking for module 'libimobiledevice-1.0'
--   found libimobiledevice-1.0, version 1.0.6
-- checking for module 'libplist' 
--   found libplist, version 1.4   
-- checking for module 'libusbmuxd'
--   found libusbmuxd, version 1.0.7
-- checking for module 'libmtp>=1.0' 
--   found libmtp, version 1.1.3
-- checking for module 'indicate-qt'
--   package 'indicate-qt' not found
-- checking for module 'libspotify>=10.1.16'
--   package 'libspotify>=10.1.16' not found 
-- checking for module 'libcdio'
--   found libcdio, version 0.83   
-- checking for module 'qca2'     
--   found qca2, version 2.0.2
-- checking for module 'libchromaprint'
--   package 'libchromaprint' not found
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found. 
-- Looking for pthread_create in pthreads     
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- checking for module 'libprojectM'   
--   package 'libprojectM' not found   
-- checking for module 'gnutls'
--   found gnutls, version 3.0.22
CMake Error at CMakeLists.txt:314 (add_subdirectory):
  add_subdirectory given source "3rdparty/qtiocompressor" which is not an
  existing directory.


CMake Error at CMakeLists.txt:341 (add_subdirectory):
  add_subdirectory given source "3rdparty/libechonest" which is not an
  existing directory.


Make Error at CMakeLists.txt:361 (add_subdirectory):
  add_subdirectory given source "3rdparty/chromaprint" which is not an
  existing directory.
 

CMake Error at CMakeLists.txt:375 (add_subdirectory):
  add_subdirectory given source "3rdparty/sha2" which is not an existing
  directory.
 

-- Found Qt-Version 4.8.2 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so                                                                                                                                                         
-- Looking for _POSIX_TIMERS                                                                                                                                                             
-- Looking for _POSIX_TIMERS - found                                                                                                                                                     
-- Found Automoc4: /usr/bin/automoc4                                                                                                                                                     
-- Found Perl: /usr/bin/perl (found version "5.16.1")                                                                                                                                     
-- Found Phonon: /usr/include                                                                                                                                                             
-- Performing Test _OFFT_IS_64BIT                                                                                                                                                         
-- Performing Test _OFFT_IS_64BIT - Failed                                                                                                                                               
-- Performing Test HAVE_FPIE_SUPPORT                                                                                                                                                     
-- Performing Test HAVE_FPIE_SUPPORT - Success                                                                                                                                           
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL                                                                                                                                       
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success                                                                                                                             
-- Performing Test __KDE_HAVE_GCC_VISIBILITY                                                                                                                                             
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success                                                                                                                                   
-- Found KDE 4.8 include dir: /usr/include                                                                                                                                               
-- Found KDE 4.8 library dir: /usr/lib                                                                                                                                                   
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler                                                                                                               
-- Found automoc4: /usr/bin/automoc4                                                                                                                                                     

The following components will be built:                                                                                                                                                   
   D-Bus support                                                                                                                                                                         
   Devices: Audio CD support                                                                                                                                                             
   Devices: DeviceKit backend                                                                                                                                                             
   Devices: iPod classic support                                                                                                                                                         
   Devices: iPod Touch, iPhone, iPad support                                                                                                                                             
   Devices: MTP support                                                                                                                                                                   
   Last.fm support                                                                                                                                                                       
   Visualisations                                                                                                                                                                         
   Wiimote support                                                                                                                                                                       

The following components WILL NOT be built:                                                                                                                                               
   Crash reporting                                                                                                                                                                       
   Devices: GIO backend                                                                                                                                                                   
   Gnome sound menu integration
   Spotify support: core code
   Spotify support: non-GPL binary helper
   (KDE) Plasma global search
   (Mac OS X) Sparkle integration
   (unstable) Remote control support

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
QTSINGLEAPPLICATION_INCLUDE_DIRS
   used as include directory in directory /tmp/clementine-1.0.1/src
   used as include directory in directory /tmp/clementine-1.0.1/src
QTSINGLEAPPLICATION_LIBRARIES
    linked by target "clementine_lib" in directory /tmp/clementine-1.0.1/src
QTSINGLECOREAPPLICATION_LIBRARIES
    linked by target "clementine_lib" in directory /tmp/clementine-1.0.1/src
QXTCORE_INCLUDE_DIRS
   used as include directory in directory /tmp/clementine-1.0.1/src
   used as include directory in directory /tmp/clementine-1.0.1/src
QXTGUI_INCLUDE_DIRS
   used as include directory in directory /tmp/clementine-1.0.1/src
   used as include directory in directory /tmp/clementine-1.0.1/src
QXT_LIBRARIES
    linked by target "clementine_lib" in directory /tmp/clementine-1.0.1/src

-- Configuring incomplete, errors occurred!


:-(
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: Clementine 1.0.1 e compilazione

Messaggioda 414N » gio set 06, 2012 14:46

Ricaricato nel post precedente. Prova di nuovo ;)
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Clementine 1.0.1 e compilazione

Messaggioda F4B1CK » ven set 07, 2012 14:14

414N ha scritto:Ti riporto allora lo SlackBuild che uso io. È quello che trovi su slackbuilds.org con qualche piccola modifica ai CFLAGS, ma nulla di più.
Nessuna patch viene applicata, tra l'altro.
EDIT: SlackBuild allegato ricaricato e riportato inline nel seguito:
Codice: Seleziona tutto
#!/bin/sh

# Slackware build script for clementine

# Copyright 2010  David Woodfall <dave@dawoodfall.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# Modified by SlackBuilds.org

PRGNAM=clementine
VERSION=${VERSION:-0.5.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) export ARCH=i486 ;;
    arm*) export ARCH=arm ;;
       *) export ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

mkdir build
cd build
  cmake \
   -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
   -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
   -DCMAKE_INSTALL_PREFIX=/usr \
   -DLIBRARY_OUTPUT_PATH=$PKG/usr/lib${LIBDIRSUFFIX} \
   -DLIB_SUFFIX=${LIBDIRSUFFIX} \
   -DMAN_INSTALL_DIR=/usr/man \
   -DCMAKE_BUILD_TYPE=Release \
   ..
  make ${NUMJOBS:--j4} all CFLAGS="-fPIC" PMFLAGS="-DNEWBUFFER"
  make install DESTDIR=$PKG
cd ..

for i in 16 32 64 ; do
  install -m 0644 -D dist/${PRGNAM}_${i}.png \
    $PKG/usr/share/icons/hicolor/${i}x${i}/apps/application-x-clementine.png
done
install -m 0644 -D dist/${PRGNAM}.desktop $PKG/usr/share/applications/

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
#cp -a TODO $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}



Dopo aver corretto la VERSION (alla 1.0.1) ho provato a rilanciare questo script, ma ho ancora degli errori, che riporto :

Codice: Seleziona tutto
In file included from /tmp/SBo/clementine-1.0.1/src/core/player.cpp:30:0:
/tmp/SBo/clementine-1.0.1/src/internet/lastfmservice.h:30:24: fatal error: lastfm/Track: No such file or directory
compilation terminated.
make[2]: *** [src/CMakeFiles/clementine_lib.dir/core/player.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [src/CMakeFiles/clementine_lib.dir/all] Error 2
make: *** [all] Error 2


non ho messo mano ai sorgenti perché mi pareva di aver capito che questo slackbuild doveva funzionare anche con la current, o sbaglio?
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Re: Clementine 1.0.1 e compilazione

Messaggioda 414N » ven set 07, 2012 14:21

Io quello SlackBuild lo uso con i tarball estratti da git con l'altro script che ho postato, aggiustando la VERSION al volo prima di eseguire lo SlackBuild.
La versione 1.0.1 probabilmente ha qualche errore a livello di build che la versione da git non presenta più (sto attualmente usando una versione risalente a meno di un mese fa), percui o cerchi qualche patch per compilare la versione 1.0.1 oppure scarichi un tarball da git e compili quello.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2877
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Clementine 1.0.1 e compilazione

Messaggioda F4B1CK » ven set 07, 2012 20:22

414N ha scritto:Io quello SlackBuild lo uso con i tarball estratti da git con l'altro script che ho postato, aggiustando la VERSION al volo prima di eseguire lo SlackBuild.
La versione 1.0.1 probabilmente ha qualche errore a livello di build che la versione da git non presenta più (sto attualmente usando una versione risalente a meno di un mese fa), percui o cerchi qualche patch per compilare la versione 1.0.1 oppure scarichi un tarball da git e compili quello.


Ho provato a compilare il tarball scaricato da git con il tuo script (mksrc-tarball.sh).
Ho scaricato il tutto, rinominato la directory di modo da rispettare la version number, creato l'archivio tar.bz2 e poi lanciato lo script slackbuild per la compilazione.
Parte a decomprimere ma alla fine, in fase di compilazione, mi dà il seguente log (con l'errore alla fine) :

Codice: Seleziona tutto
-- The C compiler identification is GNU 4.7.1                                                                                                                                             
-- The CXX compiler identification is GNU 4.7.1                                                                                                                                           
-- Check for working C compiler: /usr/bin/gcc                                                                                                                                             
-- Check for working C compiler: /usr/bin/gcc -- works                                                                                                                                   
-- Detecting C compiler ABI info                                                                                                                                                         
-- Detecting C compiler ABI info - done                                                                                                                                                   
-- Check for working CXX compiler: /usr/bin/c++                                                                                                                                           
-- Check for working CXX compiler: /usr/bin/c++ -- works                                                                                                                                 
-- Detecting CXX compiler ABI info                                                                                                                                                       
-- Detecting CXX compiler ABI info - done                                                                                                                                                 
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.25")                                                                                                                           
-- Looking for Q_WS_X11                                                                                                                                                                   
-- Looking for Q_WS_X11 - found                                                                                                                                                           
-- Looking for Q_WS_WIN                                                                                                                                                                   
-- Looking for Q_WS_WIN - not found.                                                                                                                                                     
-- Looking for Q_WS_QWS                                                                                                                                                                   
-- Looking for Q_WS_QWS - not found.                                                                                                                                                     
-- Looking for Q_WS_MAC                                                                                                                                                                   
-- Looking for Q_WS_MAC - not found.                                                                                                                                                     
-- Found Qt4: /usr/bin/qmake (found suitable version "4.8.2", required is "4.5.0")                                                                                                       
-- Found Qt4: /usr/bin/qmake (found version "4.8.2")                                                                                                                                     
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so                                                                                                                     
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found                                                                                                             
-- Looking for gethostbyname                                                                                                                                                             
-- Looking for gethostbyname - found                                                                                                                                                     
-- Looking for connect                                                                                                                                                                   
-- Looking for connect - found                                                                                                                                                           
-- Looking for remove                                                                                                                                                                     
-- Looking for remove - found                                                                                                                                                             
-- Looking for shmat                                                                                                                                                                     
-- Looking for shmat - found                                                                                                                                                             
-- Looking for IceConnectionNumber in ICE                                                                                                                                                 
-- Looking for IceConnectionNumber in ICE - found                                                                                                                                         
-- Found X11: /usr/lib/libX11.so                                                                                                                                                         
-- Found OpenGL: /usr/lib/libGL.so                                                                                                                                                       
-- Boost version: 1.49.0                                                                                                                                                                 
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.1")                                                                                                                             
-- Could NOT find PROTOBUF (missing:  PROTOBUF_LIBRARY PROTOBUF_INCLUDE_DIR)                                                                                                             
-- checking for module 'taglib>=1.6'                                                                                                                                                     
--   found taglib, version 1.7.2                                                                                                                                                         
-- checking for module 'QJson'                                                                                                                                                           
--   found QJson, version 0.7.1                                                                                                                                                           
-- checking for module 'gstreamer-0.10'                                                                                                                                                   
--   found gstreamer-0.10, version 0.10.36                                                                                                                                               
-- checking for module 'gstreamer-base-0.10'                                                                                                                                             
--   found gstreamer-base-0.10, version 0.10.36                                                                                                                                           
-- checking for module 'gstreamer-app-0.10'                                                                                                                                               
--   found gstreamer-app-0.10, version 0.10.36                                                                                                                                           
-- checking for module 'gstreamer-cdda-0.10'                                                                                                                                             
--   found gstreamer-cdda-0.10, version 0.10.36                                                                                                                                           
-- checking for module 'gstreamer-tag-0.10'                                                                                                                                               
--   found gstreamer-tag-0.10, version 0.10.36                                                                                                                                           
-- checking for module 'glib-2.0'                                                                                                                                                         
--   found glib-2.0, version 2.32.4                                                                                                                                                       
-- checking for module 'libxml-2.0'                                                                                                                                                       
--   found libxml-2.0, version 2.8.0                                                                                                                                                     
-- checking for module 'gobject-2.0'                                                                                                                                                     
--   found gobject-2.0, version 2.32.4                                                                                                                                                   
-- checking for module 'libgpod-1.0>=0.7.92'                                                                                                                                             
--   found libgpod-1.0, version 0.8.2                                                                                                                                                     
-- checking for module 'gio-2.0'                                                                                                                                                         
--   found gio-2.0, version 2.32.4                                                                                                                                                       
-- checking for module 'libimobiledevice-1.0'                                                                                                                                             
--   found libimobiledevice-1.0, version 1.0.6                                                                                                                                           
-- checking for module 'libplist'                                                                                                                                                         
--   found libplist, version 1.4                                                                                                                                                         
-- checking for module 'libusbmuxd'                                                                                                                                                       
--   found libusbmuxd, version 1.0.7                                                                                                                                                     
-- checking for module 'libmtp>=1.0'                                                                                                                                                     
--   found libmtp, version 1.1.3                                                                                                                                                         
-- checking for module 'indicate-qt'                                                                                                                                                     
--   package 'indicate-qt' not found                                                                                                                                                     
-- checking for module 'libspotify>=12.1.45'                                                                                                                                             
--   package 'libspotify>=12.1.45' not found                                                                                                                                             
-- checking for module 'libcdio'                                                                                                                                                         
--   found libcdio, version 0.83                                                                                                                                                         
-- checking for module 'qca2'                                                                                                                                                             
--   found qca2, version 2.0.2                                                                                                                                                           
-- checking for module 'libchromaprint'                                                                                                                                                   
--   package 'libchromaprint' not found                                                                                                                                                   
-- Looking for include file pthread.h                                                                                                                                                     
-- Looking for include file pthread.h - found                                                                                                                                             
-- Looking for pthread_create                                                                                                                                                             
-- Looking for pthread_create - not found.                                                                                                                                               
-- Looking for pthread_create in pthreads                                                                                                                                                 
-- Looking for pthread_create in pthreads - not found                                                                                                                                     
-- Looking for pthread_create in pthread                                                                                                                                                 
-- Looking for pthread_create in pthread - found                                                                                                                                         
-- Found Threads: TRUE                                                                                                                                                                   
-- Found Qt4: /usr/bin/qmake (found version "4.8.2")                                                                                                                                     
-- Performing Test SUPPORTS_OPENMP                                                                                                                                                       
-- Performing Test SUPPORTS_OPENMP - Success                                                                                                                                             
-- Building static qsqlite plugin                                                                                                                                                         
-- Looking for lrintf                                                                                                                                                                     
-- Looking for lrintf - found                                                                                                                                                             
-- Looking for round                                                                                                                                                                     
-- Looking for round - found                                                                                                                                                             
-- Using FFmpeg for FFT calculations                                                                                                                                                     
-- Performing Test SUPPORTS_NOBOOL                                                                                                                                                       
-- Performing Test SUPPORTS_NOBOOL - Success                                                                                                                                             

The following components will be built:                                                                                                                                                   
   D-Bus support                                                                                                                                                                         
   Devices: Audio CD support                                                                                                                                                             
   Devices: DeviceKit backend                                                                                                                                                             
   Devices: GIO device backend
   Devices: MTP support
   Devices: iPod Touch, iPhone, iPad support
   Devices: iPod classic support
   Last.fm support
   Moodbar support
   Visualisations
   Wiimote support

The following components WILL NOT be built:
   Crash reporting (disabled in CMake config)
   Gnome sound menu integration (missing indicate-qt)
   Google Drive support (missing Google sparsehash, Taglib 1.8 beta)
   Sparkle integration (missing Mac OS X, Sparkle)
   Spotify support: blob downloader (disabled in CMake config)
   Spotify support: core code (missing protobuf)
   Spotify support: non-GPL binary helper (missing protobuf, libspotify, Spotify support: core code)

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
PROTOBUF_LIBRARY (ADVANCED)
    linked by target "libclementine-common" in directory /tmp/SBo/clementine-1.0.1/ext/libclementine-common
F4B1CK
Linux 2.0
Linux 2.0
 
Messaggi: 183
Iscritto il: dom gen 11, 2004 0:00
Località: Cosenza
Slackware: current 32 bit
Kernel: 3.x
Desktop: KDE

Prossimo

Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite