Repository 32bit  Forum
Repository 64bit  Wiki

wxgtk & wxpython

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

wxgtk & wxpython

Messaggioda samiel » dom gen 30, 2005 21:49

In slacky è presente la versione 2.4.2 di wxgtk. <BR>Volevo sapere: che differenza c´è con wxPython, <BR>dal momento che mi sembra il contenuto sia lo stesso? <BR>Nel compilare la versione 2.5.3.1 di wxPython <BR>mi crea la dir /usr/bin, ma non mi crea l´eseguibile <BR>che invece c´è in wxgtk 2.5.3. Per cui la dir è vuota... <BR>Sembra che la versione 2.4.2 abbia un bug <BR>che non consente al mitico BitTorrent di funzionare. <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

wxgtk & wxpython

Messaggioda Loris » lun gen 31, 2005 13:19

wxgtk è la versione di librerie classe wxWindows basata su gtk, wxpython è un modulo per usare wxgtk in python, almeno credo :-? in ogni caso nel mio 2.5.3 in /usr/bin c´è un file wxrc-2.5. <BR>A me Bittorrent restituisce questo errore: <BR><!-- BBCode Quote Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE> sh-2.05b$ btdownloadgui.py slackware-10.0-install-d1.torrent <BR>Traceback (most recent call last): <BR> File "/usr/bin/btdownloadgui.py", line 13, in ? <BR> from wxPython.wx import * <BR>ImportError: No module named wxPython.wx </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode Quote End --> <BR>Non ho verificato a fondo, per ora uso btdownloadcurses ma sarebbe bello trovare l´errore.<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7583
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

wxgtk & wxpython

Messaggioda samiel » lun gen 31, 2005 15:44

Anche a me btdownloadcurses funziona. <BR>Come dicevo, ho compilato le versioni più recenti <BR>di entrambi i pacchetti. Ma wxPython mi si compila <BR>senza l´eseguibile in /usr/bin. Anche il tgz di Linuxpackages <BR>è senza l´eseguibile... mah... <BR> <BR>Grazie <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian


Torna a Packages

Chi c’è in linea

Visitano il forum: Bing [Bot], Google [Bot] e 2 ospiti