Repository 32bit  Forum
Repository 64bit  Wiki

Dipendenze vlc

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Dipendenze vlc

Messaggioda 6C33C » lun ott 15, 2012 21:58

Dunque vorrei compilare vlc sulla 14 64bit e stò cercando di capire quali sono le dipendenze.
Sfruttando il lavoro ammirabile fatto per la 32 ho trovato queste:
Codice: Seleziona tutto
a52dec
celt
enca
faac
faad2
ffmpeg
frei0r
game-music-emu
glibmm
goom
id3lib
jack-audio-connection-kit
ladspa_sdk
libavc1394
libbluray
libdc1394
libdca
libdvbpsi
libdvdcss
libdvdnav
libebml
libffado
libgsm
libiec61883
libkate
libmatroska
libmodplug
libmpcdec
libshout
libsigc++
libtar
libtiger
libupnp
libva
libvpx
libxml++
lua
mp4v2
openal-soft
opencore-amr
openjpeg
opus
orc
projectm
recode
rtmdump
shroedinger
sidplay2-libs
speex
twolame
vcdimager
vo-aacenc
vo-amrwbenc
x264
xvidcore

Sapete dirmi se manca qualcosa ?
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Dipendenze vlc

Messaggioda ponce » lun ott 15, 2012 22:07

io non l'ho mai compilato (il pacchetto all-inclusive di alien bob e' troppo comodo), ma so che questo script e' testato e funzionante http://slackbuilds.org/repository/14.0/multimedia/vlc/
Avatar utente
ponce
Linux 3.x
Linux 3.x
 
Messaggi: 1466
Iscritto il: mer mar 05, 2008 16:45
Località: limbo
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.16-rc7
Desktop: lxde

Re: Dipendenze vlc

Messaggioda 6C33C » lun ott 15, 2012 22:19

ponce ha scritto:io non l'ho mai compilato (il pacchetto all-inclusive di alien bob e' troppo comodo), ma so che questo script e' testato e funzionante http://slackbuilds.org/repository/14.0/multimedia/vlc/

Grazie ponce per la risposta sempre gentile 8)
Si io amo farmi del male :D
Forse dovevo scriverlo, però cercavo una risposta dai packagers di slacky per avere qualcosa di compatibile con i loro pacchetti :oops:
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Dipendenze vlc

Messaggioda tornadomig » lun ott 15, 2012 23:33

http://gnu-linux-slackware.blogspot.it/

puoi anche seguire la guida di ismail il turco :) e usi la queue di sbopkg volendo...controlla solo le dipendenze prima di lanciarti, pero' e' carino quando la lanci...zooooommm :lol:

io uso il pacchetto di alienbob perche' contiene libva, l'accelerazione hardware.
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: Dipendenze vlc

Messaggioda 6C33C » mar ott 16, 2012 6:10

tornadomig ha scritto:http://gnu-linux-slackware.blogspot.it/

puoi anche seguire la guida di ismail il turco :) e usi la queue di sbopkg volendo...controlla solo le dipendenze prima di lanciarti, pero' e' carino quando la lanci...zooooommm :lol:

io uso il pacchetto di alienbob perche' contiene libva, l'accelerazione hardware.

Il blog di ismail il turco propio non lo conoscevo :lol:
Grazie anche a te tornadomig.
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Dipendenze vlc

Messaggioda gohanz » mar ott 16, 2012 6:43

Qui c'è l'elenco di tutte le dipendenze del pacchetto VLC a 32 bit di Slacky.
http://www.slacky.eu/asche/pkgs/index.p ... 6&pkg=2438
Avatar utente
gohanz
Staff
Staff
 
Messaggi: 5832
Iscritto il: mar nov 30, 2004 0:00

Re: Dipendenze vlc

Messaggioda Trotto@81 » mar ott 16, 2012 9:43

tornadomig ha scritto:http://gnu-linux-slackware.blogspot.it/

puoi anche seguire la guida di ismail il turco :) e usi la queue di sbopkg volendo...controlla solo le dipendenze prima di lanciarti, pero' e' carino quando la lanci...zooooommm :lol:

io uso il pacchetto di alienbob perche' contiene libva, l'accelerazione hardware.

Questa aggiunta di alien è interessante, le versioni di qualche anno fa non lo avevano, ma vdpau lo tiene ancora giustamente disabilitato.
Lo uso, è troppo comodo.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 2998
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Dipendenze vlc

Messaggioda 6C33C » mar ott 16, 2012 11:43

Grazie ancora a tutti !
gohanz ha scritto:Qui c'è l'elenco di tutte le dipendenze del pacchetto VLC a 32 bit di Slacky.
http://www.slacky.eu/asche/pkgs/index.p ... 6&pkg=2438

Ma se vado sul link di ffmpeg mi da come dipendenza anche libdvpau che però non viene trovato #-o
Manca o ffmpeg è stato compilato senza tale dipendenza?
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Dipendenze vlc

Messaggioda tornadomig » mar ott 16, 2012 13:01

@trotto: ma prego, figurati e poi è bello aiutarsi così :thumbright:

neanche tanto tempo fa su slackbuilds vi era la versione 1.1.12 e la installai pezzo per pezzo ma mi accorsi che non potevo flaggare l'accelerazione hardware. potevo con la versione di slacky e quella di alienbob. alla fine ho optato per quella di alienbob, se ho fretta e non ho voglia ci schiaffo di brutto il pacchetto full altrimenti, il più delle volte uso il comando lftp consigliato da alienbob etc etc bla bla...tutto qui :)
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: Dipendenze vlc

Messaggioda tornadomig » mar ott 16, 2012 20:59

@6C33C

a che punto saresti? scusa se ti abbiamo trascurato...cosa non ti e' chiaro? e poi tu su che piattaforma stai cercando di compilare vlc? 14? -current? solo per capirci, grazie
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: Dipendenze vlc

Messaggioda 6C33C » mar ott 16, 2012 21:52

tornadomig ha scritto:@6C33C

a che punto saresti? scusa se ti abbiamo trascurato...cosa non ti e' chiaro? e poi tu su che piattaforma stai cercando di compilare vlc? 14? -current? solo per capirci, grazie

Dunque pensavo di compilare il tutto per la nuova stable.
Non mi è chiaro se le dipendenze che ho messo nel primo post sono tutte o mi sono perso qualcosa.
Per ora sono con la 13.37 sul portatile e la 14.0 sul fisso tutti e due 64bit .
Penso di installare una macchina virtuale con la 14 sul fisso e cominciare a fare delle prove sabato (moglie e impegni vari permettendo). :D
Vediamo un pò cosa ne viene fuori.
Grazie a voi!
Avatar utente
6C33C
Packager
Packager
 
Messaggi: 254
Iscritto il: gio ott 12, 2006 15:09
Località: Rimini
Nome Cognome: Giorgio
Slackware: 14.0 x86_64
Kernel: 3.9.7
Desktop: kde 4.10.4 ,razorqt

Re: Dipendenze vlc

Messaggioda tornadomig » mar ott 16, 2012 23:26

@Trotto

questo e' quanto ha risposto ismail a proposito di libva e dell' accelerazione hardware non inclusa nel pacchetto vlc di slackbuilds.org
Codice: Seleziona tutto
I do not have deep knowledge on HWA, but inter-operability may be the reason for the non-inclusion of VA Library even in exceptional dependencies section of VLC SlackBuild script, because VA API is not natively supported by all hardware and drivers although it is supported by VLC Media Player.
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: Dipendenze vlc

Messaggioda tornadomig » mar ott 16, 2012 23:41

@6C33C

dunque, se sei su architettura solo 64 (quindi pura), non hai scelta. ti prendi e compili prima ffmpeg da slackbuilds.org con tutte le sue dipendenze, occhio alle customizzazioni quando lanci gli SB poi passi a vlc.
oppure vai a trovare alienbob e fai con i suoi slackbuilds (compilati staticamente pero' e qui sul forum puoi trovare anche recenti e svariati threads sull'argomento per documentarti meglio di come posso farlo io :D ).

comunque e' buona regola far diventare multilib la slack 64 prima di iniziare a compilare pacchetti. io lo faccio sempre.

macchine virtuali....brrrrr francamente non le amo, davvero riduttive al confronto pero' se servono a far scuola, ah beh altro discorso. io piuttosto battevo il naso secco :D
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Re: Dipendenze vlc

Messaggioda Trotto@81 » mer ott 17, 2012 9:43

tornadomig ha scritto:@Trotto

questo e' quanto ha risposto ismail a proposito di libva e dell' accelerazione hardware non inclusa nel pacchetto vlc di slackbuilds.org
Codice: Seleziona tutto
I do not have deep knowledge on HWA, but inter-operability may be the reason for the non-inclusion of VA Library even in exceptional dependencies section of VLC SlackBuild script, because VA API is not natively supported by all hardware and drivers although it is supported by VLC Media Player.

Per ora uso il MPlayer con SMPlayer che formano un'accoppiata fantastica per sfruttare vdpau e non solo.
Per abilitarla in VLC dovrei abilitare vdpau nello slackbuild di alien e non mi va.
Avatar utente
Trotto@81
Iper Master
Iper Master
 
Messaggi: 2998
Iscritto il: ven giu 25, 2004 23:00
Località: Monasterace M. (RC)
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Kernel: default
Desktop: KDE 4.10.5

Re: Dipendenze vlc

Messaggioda tornadomig » mer ott 17, 2012 10:55

@Trotto

oh son contento che anche tu usi smplayer, pensavo di essere l'unico :D collegato con l'impianto cinema in casa smplayer e' una bomba ;)
rm -rf / && rm -rf . && rm -rf *
Avatar utente
tornadomig
Linux 2.4
Linux 2.4
 
Messaggi: 492
Iscritto il: gio set 30, 2010 14:17
Nome Cognome: giorgio
Slackware: -current64 uefi_grub
Kernel: 3.14.13
Desktop: KDE-4.13.3
Distribuzione: gentoo

Prossimo

Torna a Packages

Chi c’è in linea

Visitano il forum: boh, TurnitinBot [Bot] e 2 ospiti