Pagina 1 di 1

Inkscape & libgiomm

Inviato: mar ott 23, 2012 13:31
da sunreal
Ciao, ho installato inkscape tramite slakyd, ma quando cerco di avviarlo ho questo errore:
inkscape: error while loading shared libraries: libgiomm-2.4.so.1: cannot open shared object file: No such file or directory
Ho tentato anche di ricreare il pacchetto tramite slackbuilb, ma la compilazione si arresta per lo stesso problema:
checking for CAIRO_USER_FONTS... yes
checking for INKSCAPE... no
configure: error: Package requirements (gdkmm-2.4 glibmm-2.4 giomm-2.4 gtkmm-2.4 >= 2.10.0 gtk+-2.0 libxml-2.0 >= 2.6.11 libxslt >= 1.0.15 cairo sigc++-2.0 >= 2.0.12 gtkspell-2.0 gthread-2.0 >= 2.0 libpng >= 1.2 gsl) were not met:

Package giomm-2.4 was not found in the pkg-config search path.
Perhaps you should add the directory containing `giomm-2.4.pc'
to the PKG_CONFIG_PATH environment variable
Package 'giomm-2.4', required by 'gdkmm', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables INKSCAPE_CFLAGS
and INKSCAPE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Ho cercato in rete ed ho trovato una mezza risposta ma non ho capito che c'è da fare, la risposta è questa:
https://answers.launchpad.net/inkscape/+question/87980
Aiuto!!!!

Re: Inkscape & libgiomm

Inviato: mar ott 23, 2012 13:51
da gohanz
Devi installare le dipendenze elencante. Nel caso l'errore è generato dalla mancanza di glibmm.

Re: Inkscape & libgiomm

Inviato: mar ott 23, 2012 14:08
da legura
Ciao,

l'ho giusto installato l'altro ieri.

Usa i pacchetti di slackbuils. Ci vuole un po' di pazienza perchè i pacchetti da installare
sono parecchi.

d.

Re: Inkscape & libgiomm

Inviato: mar ott 23, 2012 14:22
da Loris
legura ha scritto:Ciao,

l'ho giusto installato l'altro ieri.

Usa i pacchetti di slackbuils. Ci vuole un po' di pazienza perchè i pacchetti da installare
sono parecchi.

d.


Andrea ha già dato la soluzione bisogna installare le dipendenze... già belle e pronte.

Codice: Seleziona tutto

atkmm, cairomm, gc, glibmm, gsl, gtkmm, libsigc++, libwpg, lxml, numpy, pangomm

Re: Inkscape & libgiomm

Inviato: mar ott 23, 2012 14:26
da legura
e io che ho detto... ?

Re: Inkscape & libgiomm

Inviato: mar ott 23, 2012 14:57
da Loris
Di usare i pacchetti di slackbuils? (slackbuilds)

Re: Inkscape & libgiomm

Inviato: mar ott 23, 2012 15:41
da sunreal
Dipendenze installate (autoamticamente da slackyd):
atkmm-2.22.6
cairomm-1.10.0
gc-7.1
gsl-1.15
gtkmm-2.24.2
libsigc++-2.2.11
libwpg-0.2.1
lxml-2.3.5
numpy-1.6.2
pangomm-2.28.4

Nella pagina di download sono elencate queste dipendenze

atkmm, cairomm, gc, glibmm, gsl, gtkmm, libsigc++, libwpg, lxml, numpy, pangomm
In pratica slackyd si era scordato glibmm, scusate ma avevo dato per scontato che almeno le dipendenze segnalate nella pagina del pacchetto fossero automaticamente installate. Sorry.

Re: Inkscape & libgiomm

Inviato: mar ott 23, 2012 16:26
da Loris
Bisogna capire perché è accaduto questo :-k

Re: Inkscape & libgiomm

Inviato: mar ott 23, 2012 19:46
da gohanz
Effettivamente sembra che slackyd non veda glibmm.

Codice: Seleziona tutto

slackyd -g glibmm

Searching glibmm: nothing found.

Re: Inkscape & libgiomm

Inviato: ven ott 26, 2012 13:57
da sunreal
Non so perchè capita, ma a me qualche volta qualche pacchetto slackyd non lo trova, mi pare di ricordarmi che mi è capitato con gc o GConf? Però magari se il pacchetto è uno e non ci sono dipendenze, è più semplice, stavolta mi ha proprio fregato.
Ciao.

Re: Inkscape & libgiomm

Inviato: sab ott 27, 2012 12:50
da ZeroUno
riprova ora

Re: Inkscape & libgiomm

Inviato: sab ott 27, 2012 19:50
da gohanz
Ho provato con glibmm e sembra funzionare adesso.