Repository 32bit  Forum
Repository 64bit  Wiki

QBittorrent

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

QBittorrent

Messaggioda joe » lun nov 04, 2013 11:32

Una volta tanto scrivo per riportare un esperienza e non per fare domande.

Fino a ieri utilizzavo la versione:

Codice: Seleziona tutto
qbittorrent - 3.0.4
libtorrent-rasterbar - 0.15.10


E notavo una particolare difficoltà nell'avvio di torrents aggiunti attraverso i magnet links. Spesso i trasferimenti restavano perennemente in "Stalled status".
Mi sono deciso ad aggiornare alle versioni seguenti:

Codice: Seleziona tutto
qbittorrent - 3.1.1
libtorrent-rasterbar - 0.16.3


E ho notato un pesante miglioramento nella rapidità con cui i trasferimenti vengono iniziati o ripresi dopo una pausa.
L'incremento d'efficienza l'ho notato avendo gli stessi due trasferimenti in coda, prima e dopo l'aggiornamento... Quindi non dipende dai torrents particolari e neanche dalle condizioni momentanee perchè ho testato praticamente nel giro di mezzora le due diverse versioni.

Tutto questo solo per dire che se utilizzate qbittorrent e rilevate una certa inefficienza, potrebbe essere una buona scelta aggiornare i due pacchetti di cui sopra.

Come ho installato i pacchetti. Praticamente ho ricompilato il tutto:

- sfruttando sbopkg per quanto riguarda le libtorrent-rasterbar e quindi accontentandomi della versione che hanno nel repo. Non è l'ultima stabile infatti dal sito del progetto che se non mi sbaglio è:
https://code.google.com/p/libtorrent/
Si vede disponibile la 0.16.12.
Volendo avrei potuto provare a compilare quest'ultima modificando lo slackbuild di SBo. Fatto 30... avrei anche potuto far 31. Va bè. Adesso sembra che l'accrocchio funzioni bene così, quindi rimando la faccenda.

- modificando lo slackbuild di SBo per qbittorent. In modo da compilare l'ultima versione.

Ordine di compilazione/installazione:
Prima le libtorrent-rasterbar.
Poi qbtittorrent.

Se compilate prima qbittorrent, si appoggerà alle libtorrent-rasterbar che avete già nel sistema. E quando poi andrete ad aggiornare queste ultime vi troverete un qbittorrent che non si avvia perchè probabilmente cerca le vecchie libtorrent-rasterbar.
Insomma se aggiornate la dipendenza dovete riaggiornare anche qbittorrent in modo che si appoggi sulla nuova versione dlla libreria libtorrent. Penso d'essermi spiegato, se ho detto una castroneria correggete.
Avevo provato ad aggiornare le libtorrent-rasterbar e poi ad avviare il vecchio qbittorrent, ma questo non s'avviava, quando poi ne ho compilato la versione nuova appoggiandomi quindi alle nuove rasterbar ecco che s'è avviato senza problemi.

Non so chi si occupa dei pacchetti sopracitati qui sul repo di slacky. Anzi per qbittorrent mi sembra che non vi siano pacchetti almeno per la 14 a 32 bit. Ma eventualmente sarebbe il caso di tenere in conto quanto ho riportato e quindi di aggiornare le libtorrent-rasterbar ed eventualmente se si decidesse d'aggiungere qbittorrent meglio la versione più recente.
Ovviamente non so se aggiornando le rasterbar poi si creerebbero problemi con altri pacchetti tipo ktorrent o altro. Quindi prendete quanto ho riportato con le pinze.

Ok, direi che è tutto. Spero possa essere di utilità a qualcuno.
Alla prossima :D
Avatar utente
joe
Iper Master
Iper Master
 
Messaggi: 2007
Iscritto il: ven apr 27, 2007 10:21
Slackware: 14.0
Kernel: 3.2.29-smp
Desktop: KDE-4.8.5

Torna a Packages

Chi c’è in linea

Visitano il forum: Google [Bot] e 1 ospite