Test per darktable e digikam in current 64bit

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
conraid
Staff
Staff
Messaggi: 12955
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Test per darktable e digikam in current 64bit

Messaggioda conraid » lun ott 26, 2015 19:34

Hi Folks,
Mi servirebbe un favore, chi può e vuole.

Ho avuto dei problemi a compilare digikam.
Prima mi dava errore con imagamagick, ed ho dovuto disabilitare videoslideshow, non trovando patch in rete.
Poi errori di librerie exiv2 non trovate, l'errore classico di quando compili digikam con digikam installato, solo che io l'avevo prima disinstallato.
Dopo varie prove ho risolto reinstallando il pacchetto libkexiv2. Probabilmente si era rotto qualche link simbolico o chissà cosa.
Però vorrei sapere se va anche in un ambiente che non è il mio, non vorrei che si è legato a qualche libreria in modo strano dopo tutte queste prove, nonostante abbia poi ricompilato il tutto.

Per darktable invece ho creato il pacchetto lua52, che può essere installato in parallelo a lua-5.3
Ho preso spunto, e patch, da archlinux.
Anche qui se lo provate in ambiente diverso sarebbe utile.

Insomma, se volete installare i pacchetti per digikam (digikam, opencv, libkface, libkgeomaps, liblqr, libpgf e lensfun) e/o per darktable (lensfun,flickcurl,json-glib, graphicsmagick e lua52) e mi dite se vanno bene, mi fate un piacere :-)

I pacchetti li trovate su http://ponce.cc/slackers/repository/

Thanks