inkscape 0.91 e poppler 0.42

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
conraid
Staff
Staff
Messaggi: 12953
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

inkscape 0.91 e poppler 0.42

Messaggioda conraid » lun mar 21, 2016 19:21

Qualcuno ha provato a compilare inkscape dopo l'ultimo aggiornamento della current? Quello "Mon Mar 21 03:19:48 UTC 2016" con upgrade di poppler a 0.42.

A me compila, ma poi va in crash appena provo a fare qualcosa. Non riesco a capire dove sia il problema, ho visto nei bug reports che ci sono alcuni bug critici con crash, ma non sembravo stesso problema.
Non so nemmeno se incida poppler, ho messo la versione per far capire il momento della compilazione.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda ponce » lun mar 21, 2016 20:04

l'ho appena compilato con le sue dipendenze e sembra funzionare

http://ponce.cc/slackware/testing/inko/

Avatar utente
conraid
Staff
Staff
Messaggi: 12953
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda conraid » lun mar 21, 2016 20:28

Questo funziona.
Tengo il tuo e tolgo inkscape dal repository :)

Ho provato a compilarlo due volte, siccome la compilazione è lunga desisto.

Avatar utente
conraid
Staff
Staff
Messaggi: 12953
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda conraid » sab apr 30, 2016 17:11

Hai mica compilato anche dopo l'aggiornamento di poppler? A me da lo stesso problema :(

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda ponce » sab apr 30, 2016 21:31

si, l'ho compilato poco fa: trovi il pacchetto qui

http://ponce.cc/slackware/slackware64-current/packages/

Avatar utente
sya54M
Master
Master
Messaggi: 1600
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.9.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda sya54M » dom mag 01, 2016 8:35

l'ho compilato anch'io, sia l'altra volta che ieri e non crasha, funziona

Avatar utente
conraid
Staff
Staff
Messaggi: 12953
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda conraid » dom mag 01, 2016 9:57

Questa volta mi andava in crash anche quello di ponce, ed ho scoperto l'inghippo. Il motore di temi qtcurve. Me ne sono accorto perché ho lanciato inkscape da rott e funzionava. Allora ho provato senza le differenze tra i due utenti.
Ricompilando qtcurve dalla versione git funziona anche con quello.

Avatar utente
sya54M
Master
Master
Messaggi: 1600
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.9.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda sya54M » dom mag 01, 2016 12:53

giusto per capire, prima col pacchetto di ponce che ti funzionava non avevi sempre qtcurve?

Avatar utente
conraid
Staff
Staff
Messaggi: 12953
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda conraid » dom mag 01, 2016 14:27

sya54M ha scritto:giusto per capire, prima col pacchetto di ponce che ti funzionava non avevi sempre qtcurve?


con la versione precedente di current con quello di ponce funzionava, sì.
Nella current attuale anche il pacchetto di ponce andava in crash. Un segfault guardando con strace.
Va in crash quasi subito, basta aprire qualche voce del menù e va in crash. Quello compilato da me basta che clicco e va in crash invece. Sempre con qtcurve stable, con qtcurve git vanno entrambi tranquillamente.

Avatar utente
sya54M
Master
Master
Messaggi: 1600
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.9.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda sya54M » dom mag 01, 2016 15:23

tutto è bene quel che finisce bene

Avatar utente
conraid
Staff
Staff
Messaggi: 12953
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda conraid » dom mag 01, 2016 15:42

sya54M ha scritto:tutto è bene quel che finisce bene


cosa usi te come tema qt e gtk?

qtcurve mi piace, ma non è la prima volta che mi procura problemi che non riesco mai a capire.

Avatar utente
sya54M
Master
Master
Messaggi: 1600
Iscritto il: mer giu 06, 2007 14:44
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 4.9.x
Desktop: KDE
Località: (Salerno)
Contatta:

Re: inkscape 0.91 e poppler 0.42

Messaggioda sya54M » dom mag 01, 2016 17:20

Quello che trovo :) cioè ora sul fisso sto usando KDE5 di Alien e quindi il tema Breeze per tutti, QT e GTK.
Su altri PC ho KDE4 e ho lasciato oxygen.