Pagina 1 di 1

inkscape 0.91 e poppler 0.42

Inviato: lun mar 21, 2016 19:21
da conraid
Qualcuno ha provato a compilare inkscape dopo l'ultimo aggiornamento della current? Quello "Mon Mar 21 03:19:48 UTC 2016" con upgrade di poppler a 0.42.

A me compila, ma poi va in crash appena provo a fare qualcosa. Non riesco a capire dove sia il problema, ho visto nei bug reports che ci sono alcuni bug critici con crash, ma non sembravo stesso problema.
Non so nemmeno se incida poppler, ho messo la versione per far capire il momento della compilazione.

Re: inkscape 0.91 e poppler 0.42

Inviato: lun mar 21, 2016 20:04
da ponce
l'ho appena compilato con le sue dipendenze e sembra funzionare

http://ponce.cc/slackware/testing/inko/

Re: inkscape 0.91 e poppler 0.42

Inviato: lun mar 21, 2016 20:28
da conraid
Questo funziona.
Tengo il tuo e tolgo inkscape dal repository :)

Ho provato a compilarlo due volte, siccome la compilazione è lunga desisto.

Re: inkscape 0.91 e poppler 0.42

Inviato: sab apr 30, 2016 17:11
da conraid
Hai mica compilato anche dopo l'aggiornamento di poppler? A me da lo stesso problema :(

Re: inkscape 0.91 e poppler 0.42

Inviato: sab apr 30, 2016 21:31
da ponce
si, l'ho compilato poco fa: trovi il pacchetto qui

http://ponce.cc/slackware/slackware64-current/packages/

Re: inkscape 0.91 e poppler 0.42

Inviato: dom mag 01, 2016 8:35
da sya54M
l'ho compilato anch'io, sia l'altra volta che ieri e non crasha, funziona

Re: inkscape 0.91 e poppler 0.42

Inviato: dom mag 01, 2016 9:57
da conraid
Questa volta mi andava in crash anche quello di ponce, ed ho scoperto l'inghippo. Il motore di temi qtcurve. Me ne sono accorto perché ho lanciato inkscape da rott e funzionava. Allora ho provato senza le differenze tra i due utenti.
Ricompilando qtcurve dalla versione git funziona anche con quello.

Re: inkscape 0.91 e poppler 0.42

Inviato: dom mag 01, 2016 12:53
da sya54M
giusto per capire, prima col pacchetto di ponce che ti funzionava non avevi sempre qtcurve?

Re: inkscape 0.91 e poppler 0.42

Inviato: dom mag 01, 2016 14:27
da conraid
sya54M ha scritto:giusto per capire, prima col pacchetto di ponce che ti funzionava non avevi sempre qtcurve?


con la versione precedente di current con quello di ponce funzionava, sì.
Nella current attuale anche il pacchetto di ponce andava in crash. Un segfault guardando con strace.
Va in crash quasi subito, basta aprire qualche voce del menù e va in crash. Quello compilato da me basta che clicco e va in crash invece. Sempre con qtcurve stable, con qtcurve git vanno entrambi tranquillamente.

Re: inkscape 0.91 e poppler 0.42

Inviato: dom mag 01, 2016 15:23
da sya54M
tutto è bene quel che finisce bene

Re: inkscape 0.91 e poppler 0.42

Inviato: dom mag 01, 2016 15:42
da conraid
sya54M ha scritto:tutto è bene quel che finisce bene


cosa usi te come tema qt e gtk?

qtcurve mi piace, ma non è la prima volta che mi procura problemi che non riesco mai a capire.

Re: inkscape 0.91 e poppler 0.42

Inviato: dom mag 01, 2016 17:20
da sya54M
Quello che trovo :) cioè ora sul fisso sto usando KDE5 di Alien e quindi il tema Breeze per tutti, QT e GTK.
Su altri PC ho KDE4 e ho lasciato oxygen.