Repository 32bit  Forum
Repository 64bit  Wiki

Problema slackbuild

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema slackbuild

Messaggioda teme » lun feb 14, 2005 20:41

Salve ragazzi, <BR>sto compilando kdelibs ma ho questi errori: <BR><!-- BBCode Start --><TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Code:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><PRE>../../kdeui/kaction.h:40: warning: forward declaration of `struct QPopupMenu´ <BR>/usr/lib/qt/include/qptrlist.h:150: note: neither the destructor nor the class-specific operator delete will be called, even if they are declared when the class is defined. <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: `libkdeinit_dcopserver.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `/compile/tmp/kdelibs-3.3.2/dcop/libDCOP.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib/kde3´ <BR>libtool: install: warning: `../libDCOP.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `../libDCOP.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `../libDCOP.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `../libDCOP.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: `./libkdecore.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `/compile/tmp/kdelibs-3.3.2/dcop/libDCOP.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `/compile/tmp/kdelibs-3.3.2/kdefx/libkdefx.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `./libkdefakes.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `../../kdecore/libkdecore.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `/compile/tmp/kdelibs-3.3.2/dcop/libDCOP.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: `/compile/tmp/kdelibs-3.3.2/kdefx/libkdefx.la´ has not been installed in `/opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib/kde3´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib/kde3´ <BR>libtool: install: warning: remember to run `libtool --finish /opt/kde/lib´ </PRE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE><!-- BBCode End --> <BR>etc etc etc....che posso fare? libtool pure l´ho compilato....<br>
Avatar utente
teme
Linux 2.4
Linux 2.4
 
Messaggi: 362
Iscritto il: mar gen 27, 2004 0:00

Problema slackbuild

Messaggioda samiel » lun feb 14, 2005 20:53

Non è un errore. Solo che, visto che stai facendo il pacchetto, <BR>quei files non li installa dove dovrebbe, ma nella dir del pacchetto <BR>che stai costruendo <BR>Chiedere a Lorys per conferma... <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Problema slackbuild

Messaggioda useless » lun feb 14, 2005 20:55

x quel che può contare io sono d´accordo :-].<br>
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Problema slackbuild

Messaggioda teme » lun feb 14, 2005 21:37

grazie per la tempestività... <BR>quindi dovrei recuperarli uno a uno(in teoria)?<br>
Avatar utente
teme
Linux 2.4
Linux 2.4
 
Messaggi: 362
Iscritto il: mar gen 27, 2004 0:00

Problema slackbuild

Messaggioda samiel » lun feb 14, 2005 21:46

Noooooooooooooooooooo <BR>Quindi quando installi il tgz <BR>te li mette al posto giusto <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Problema slackbuild

Messaggioda teme » lun feb 14, 2005 21:56

Ha quindi è perfetto.... :)<br>
Avatar utente
teme
Linux 2.4
Linux 2.4
 
Messaggi: 362
Iscritto il: mar gen 27, 2004 0:00

Problema slackbuild

Messaggioda samiel » lun feb 14, 2005 22:26

Direi di sì. Il concetto è che quando fai un tgz, <BR>lui colloca i file in dir uguali a dove andranno poi installate. <BR>Dai un´occhiata agli how-to su slacky sui pacchetti <BR>e capirai bene il meccanismo <BR> <BR>M.<br>
samiel
Staff
Staff
 
Messaggi: 5500
Iscritto il: ven gen 16, 2004 0:00
Località: Venezia
Nome Cognome: Mauro Sacchetto
Slackware: 13.0
Kernel: 2.26
Desktop: KDE
Distribuzione: anche Debian

Problema slackbuild

Messaggioda Loris » lun feb 14, 2005 22:51

Se vuoi una conferma... controlla nel pacchetto, in opt/kde/lib/ la presenza di libDCOP.la<br>
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7589
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5


Torna a Packages

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite