KDE Connect 1.0

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3530
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

KDE Connect 1.0

Messaggioda Trotto@81 » mar set 06, 2016 13:55

Da poco è stata rilasciata la versione stabile di quella che reputo un'ottima soluzione per monitorare il proprio telefono tramite KDE, ovvero KDE Connect, ma su Slackware è presente la versione 0.8 risalente a due anni fa, carente in molte funzioni; ho provato a compilare la 1.0 tramite script ufficiali, ma ottengo un errore.
Se qualcuno è a conoscenza di un pacchetto già pronto ne sarei felice, altrimenti provo a postarvi l'errore per un'eventuale dritta.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2486
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: KDE Connect 1.0

Messaggioda ponce » mar set 06, 2016 14:52

credo che la versione 0.9 sia inclusa nel kde5 che fornisce alienbob: e' possibile che per installare la 1.0 ti ci voglia quella versione di kde.

Avatar utente
conraid
Staff
Staff
Messaggi: 13210
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: KDE Connect 1.0

Messaggioda conraid » mar set 06, 2016 14:54

Le specifiche parlano di KDE4 e Plasma5
Ammetto di non aver seguito l'evoluzione delle tecnologie KDE

CMakeLists.txt richiede le QT5.2 e ECM (extra modules cmake)
Forse va anche con KDE4 con questi, non so.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2486
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: KDE Connect 1.0

Messaggioda ponce » mar set 06, 2016 14:55

credo che plasma5 funzioni solo con le qt-5.x e con kde-5.x.

Avatar utente
conraid
Staff
Staff
Messaggi: 13210
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: KDE Connect 1.0

Messaggioda conraid » mar set 06, 2016 14:57

ponce ha scritto:credo che plasma5 funzioni solo con le qt-5.x e con kde-5.x.



Scusa, era "o"

## Supported platforms
- Computers running Plasma 5, KDE4, Unity (Ubuntu), Gnome 3, Elementary OS...


If you are not using Plasma 5 or KDE4, you will also need to install [indicator-kdeconnect](https://github.com/vikoadi/indicator-kdeconnect) (available as an [Ubuntu PPA](https://code.launchpad.net/~vikoadi/+ar ... buntu/ppa/)) for integration with other desktops using appindicator.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2486
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: KDE Connect 1.0

Messaggioda ponce » mar set 06, 2016 15:13

riguardo appindicator, specifico di ubuntu, non e' usato da niente su Slackware, non e' nemmeno su SBo (infatti quando ho preparato lo SlackBuild per dike, pre-compilato su una ubuntu, ho dovuto scrivere quello di libappindicator da zero): da quello che mi sembra di aver capito sopra e' opzionale.

prova a postare l'errore, Trotto, cosi' vediamo se troviamo qualcosa...

Avatar utente
conraid
Staff
Staff
Messaggi: 13210
Iscritto il: gio lug 14, 2005 0:00
Nome Cognome: Corrado Franco
Slackware: current64
Località: Livorno
Contatta:

Re: KDE Connect 1.0

Messaggioda conraid » mar set 06, 2016 15:50

Richiede KF5 mi sa

find_package(KF5 REQUIRED COMPONENTS I18n ConfigWidgets DBusAddons)
find_package(KF5DocTools


Infatti da errore anche con il cmake

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3530
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: KDE Connect 1.0

Messaggioda Trotto@81 » mar set 06, 2016 15:58

Ad essere sincero non ho provato a cercare i requisiti perché lo sviluppatore, pure sapendo che usassi KDE 4, mi ha solo suggerito di compilare la nuova versione o di trovare un pacchetto già pronto.
Comunque, l'errore che ricevo con gli script ufficiali è il seguente:

Codice: Seleziona tutto

-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:10 (find_package):
  Could not find a package configuration file provided by "ECM" (requested
  version 0.0.9) with any of the following names:

    ECMConfig.cmake
    ecm-config.cmake

  Add the installation prefix of "ECM" to CMAKE_PREFIX_PATH or set "ECM_DIR"
  to a directory containing one of the above files.  If "ECM" provides a
  separate development package or SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
See also "/tmp/kde-build/extragear/kdeconnect-kde-1.0/build/CMakeFiles/CMakeOutput.log".

Ho rinominato la patch usata per la 0.8 per non essere utilizzata.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2486
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: KDE Connect 1.0

Messaggioda ponce » mar set 06, 2016 17:36

quell'errore e' perche' ti manca extra-cmake-modules (che e' una dipendenza di KDE Frameworks 5): e' incluso tra le dipendenze del kde-5.x di alienbob.
Ultima modifica di ponce il mar set 06, 2016 17:38, modificato 1 volta in totale.

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3530
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: KDE Connect 1.0

Messaggioda Trotto@81 » mar set 06, 2016 17:38

Serve quindi KDE 5?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2486
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: KDE Connect 1.0

Messaggioda ponce » mar set 06, 2016 17:39

come scrivevo prima, credo proprio di si, a patto che il CMakefile non abbia delle opzioni specifiche per escluderlo: prova a entrare nella directory dei sorgenti, lancia il comando "cmake-gui" e guarda se vedi qualcosa che ti sembra serva a compilarlo con qt-4.x e kde-4.x (mi sembra difficile che ci sia).
Ultima modifica di ponce il mar set 06, 2016 17:41, modificato 1 volta in totale.

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3530
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: KDE Connect 1.0

Messaggioda Trotto@81 » mar set 06, 2016 17:41

Peccato, perché la 0.8 è piena di bug, essendo una vecchia versione di sviluppo.

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2486
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.19.0-rc8
Desktop: lxde
Località: Pisa
Contatta:

Re: KDE Connect 1.0

Messaggioda ponce » mar set 06, 2016 17:42

se hai parlato con lo sviluppatore prova a riparlarci e a chiederlo a lui, credo che sia la persona piu' indicata per dirti se esiste una soluzione per usarlo con kde 4.x.

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3530
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: KDE Connect 1.0

Messaggioda Trotto@81 » mar set 06, 2016 17:44

Ok, gli scrivo subito e vi riporto la sua risposta. Grazie a tutti.

Avatar utente
Trotto@81
Iper Master
Iper Master
Messaggi: 3530
Iscritto il: sab giu 26, 2004 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.2 bet
Kernel: default
Desktop: KDE 4.14.14
Località: Monasterace M. (RC)
Contatta:

Re: KDE Connect 1.0

Messaggioda Trotto@81 » mer set 07, 2016 10:21

Ecco la risposta di Albert Vaca che conferma quanto detto da voi.
It looks like you are missing some development packages, namely ECM (extra-cmake-modules). You will need to install it (and likely other packages it will also complain about) from the distro repos.