[RISOLTO]installazione pacchetto .tar.xz

Postate qui se avete consigli per migliorare i pacchetti disponibili in questo sito o se avete problemi con installazione, funzionamento o altro.

Moderatore: Staff

Regole del forum
1) Citare in modo preciso il nome del pacchetto.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: installazione pacchetto .tar.xz

Messaggioda ponce » dom ott 16, 2016 7:08

sbopkg usa il repository di SBo, che e' costituito solo da script per fare pacchetti che non sono gia' in Slackware, non puoi quindi usarlo per aggiornare tutto il sistema operativo.

se vuoi aggiornare quello puoi usare questa guida
http://docs.slackware.com/howtos:slackw ... temupgrade

Avatar utente
zoros
Linux 3.x
Linux 3.x
Messaggi: 1328
Iscritto il: lun mag 28, 2007 22:51
Nome Cognome: Fabio`Zorba`
Slackware: 14.1
Kernel: 3.10.30-smp
Desktop: KDE-3.5(works!)
Località: Gorizia
Contatta:

Re: installazione pacchetto .tar.xz

Messaggioda zoros » lun ott 17, 2016 22:51

boh,
sul mio pc ho ancora la 14.1 ... se lancio:

Codice: Seleziona tutto

./SBo_get.sh https://slackbuilds.org/repository/14.1/multimedia/vlc

come scritto sul mio sito:
http://www.zoros.org/wiki/index.php?tit ... ecursively
scarica tutto ... ho fatto 'sta roba proprio per le difficoltà di installare pacchetti tipo vlc ... mah ...
vorrei riavere le mie firme ...

Avatar utente
N1cuz
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: lun ott 06, 2008 0:41
Nome Cognome: Nicola Bartolomei
Slackware: 14.1
Kernel: 4.3.3
Desktop: xfce4
Località: Pieve a Nievole (PT)

Re: installazione pacchetto .tar.xz

Messaggioda N1cuz » mar ott 18, 2016 9:35

ponce ha scritto:devi tenere di conto di due cose:
- il repository della 14.1 non e' piu' supportato (da quando e' uscita la 14.2 e' supportata solo quella).
quindi, se vuoi usare il repository di SBo in modo indolore, devi necessariamente passare alla 14.2.



Non ho capito, perché dici che non conviene usare il repository di SBo per le versioni precedenti... Se intendi che non è banale tenere i pacchetti aggiornati all'ultima versione esistente mi torna, ma se ti basta averli aggiornati all'ultima versione relativa alla slackware che hai sul pc o laptop non capisco perché dovrebbero esserci problemi...

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: installazione pacchetto .tar.xz

Messaggioda ponce » mar ott 18, 2016 10:42

perche', per esempio:
- alcuni link per il download non funzionano piu';
- nella 14.1 sono state inserite patch con le quali gli script non sono stati testati, quindi potrebbero non funzionare;
- i maintainer dei vari script non li supportano piu' quindi non hai nessun aiuto se qualunque cosa va male;
- altro che ora non mi viene a mente :)

riguardo ad usare il repo della 14.2 con la 14.1, il problema si manifesta perche' il repository di SBo per la 14.2, per esempio, non ha i pacchetti che sono stati aggiunti nella distribuzione dalla versione 14.2, quindi alcuni pacchetti e dipendenze mancano proprio.
oppure perche' tutto quello che e' nel repository della 14.2 e' stato testato solo con quella versione quindi potrebbe non compilare (perche' patchato per il compilatore nuovo) o non funzionare.

Avatar utente
N1cuz
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: lun ott 06, 2008 0:41
Nome Cognome: Nicola Bartolomei
Slackware: 14.1
Kernel: 4.3.3
Desktop: xfce4
Località: Pieve a Nievole (PT)

Re: installazione pacchetto .tar.xz

Messaggioda N1cuz » mar ott 18, 2016 13:18

ponce ha scritto:perche', per esempio:
- alcuni link per il download non funzionano piu';
- nella 14.1 sono state inserite patch con le quali gli script non sono stati testati, quindi potrebbero non funzionare;
- i maintainer dei vari script non li supportano piu' quindi non hai nessun aiuto se qualunque cosa va male;
- altro che ora non mi viene a mente :)

riguardo ad usare il repo della 14.2 con la 14.1, il problema si manifesta perche' il repository di SBo per la 14.2, per esempio, non ha i pacchetti che sono stati aggiunti nella distribuzione dalla versione 14.2, quindi alcuni pacchetti e dipendenze mancano proprio.
oppure perche' tutto quello che e' nel repository della 14.2 e' stato testato solo con quella versione quindi potrebbe non compilare (perche' patchato per il compilatore nuovo) o non funzionare.


nel secondo punto intendi patch inserite eventualmente dopo l'uscita della 14.2 (quelle precedenti dovrebbero essere supportate dagli script immagino)?
Quindi tu consigli di aggiornare sempre all'ultima versione di slackware?

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: installazione pacchetto .tar.xz

Messaggioda ponce » mar ott 18, 2016 13:34

N1cuz ha scritto:nel secondo punto intendi patch inserite eventualmente dopo l'uscita della 14.2 (quelle precedenti dovrebbero essere supportate dagli script immagino)?

no, anche prima: il ramo 14.1 di SBo si e' chiuso, come di consueto, mesi prima che uscisse la 14.2 per darci il tempo di lavorare su quest'ultima.
comunque non e' che tutte le volte che esce una patch nel ramo stabile noi ricompiliamo tutti i 6000 script un'altra volta, quindi e' possibile che alcune cose fossero da aggiustare anche prima.
Quindi tu consigli di aggiornare sempre all'ultima versione di slackware?

e' il metodo piu' sicuro per avere tutto il materiale di terze parti sempre funzionante (ma va ricompilato tutto post-ugrade della distribuzione).
comunque quando devo aggiornare mi tengo l'installazione vecchia su una partizione e faccio la nuova su un'altra partizione cosi', se c'e' un problema con la nuova, ho sempre un paracadute.

Avatar utente
N1cuz
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: lun ott 06, 2008 0:41
Nome Cognome: Nicola Bartolomei
Slackware: 14.1
Kernel: 4.3.3
Desktop: xfce4
Località: Pieve a Nievole (PT)

Re: installazione pacchetto .tar.xz

Messaggioda N1cuz » mar ott 18, 2016 17:35

Ho capito, allora appena ho un pò di tempo (quando posso permettermi di stare un pò con il comuter non funzionante!!!) proverò ad aggiornare, non l'ho mai fatto prima... speriamo bene!!
Grazie mille ponce per le spiegazioni e per la pazienza!

Nico

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: installazione pacchetto .tar.xz

Messaggioda ponce » mar ott 18, 2016 17:41

N1cuz ha scritto:Ho capito, allora appena ho un pò di tempo (quando posso permettermi di stare un pò con il comuter non funzionante!!!) proverò ad aggiornare, non l'ho mai fatto prima... speriamo bene!!

se fai una nuova installazione da zero puoi passare da una all'altra facilmente, non dovresti avere il problema di avere il pc non funzionante...

puoi anche, in fase di installazione della nuova versione, non installare lilo nell'MBR del disco e invece farti una chiavetta usb di boot, in modo da continuare ad avviare normalmente la vecchia installazione quando parti da disco fisso e avviare la nuova partendo dalla chiavetta.

Avatar utente
N1cuz
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: lun ott 06, 2008 0:41
Nome Cognome: Nicola Bartolomei
Slackware: 14.1
Kernel: 4.3.3
Desktop: xfce4
Località: Pieve a Nievole (PT)

Re: installazione pacchetto .tar.xz

Messaggioda N1cuz » mar ott 18, 2016 18:07

ponce ha scritto:
N1cuz ha scritto:Ho capito, allora appena ho un pò di tempo (quando posso permettermi di stare un pò con il comuter non funzionante!!!) proverò ad aggiornare, non l'ho mai fatto prima... speriamo bene!!

se fai una nuova installazione da zero puoi passare da una all'altra facilmente, non dovresti avere il problema di avere il pc non funzionante...

puoi anche, in fase di installazione della nuova versione, non installare lilo nell'MBR del disco e invece farti una chiavetta usb di boot, in modo da continuare ad avviare normalmente la vecchia installazione quando parti da disco fisso e avviare la nuova partendo dalla chiavetta.


Si per la 14.1 feci un'installazione da zero, avevo la 13.37.
Ma se mi faccio una usb di installazione quando avvii da dico fisso e quindi con la vecchia che pacchetti usi? Devi tenerti anche tutti i vecchi pacchetti o usi quelli della 14.2 per entrambe le installazioni???

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: installazione pacchetto .tar.xz

Messaggioda ponce » mar ott 18, 2016 18:16

N1cuz ha scritto:Ma se mi faccio una usb di installazione quando avvii da dico fisso e quindi con la vecchia che pacchetti usi? Devi tenerti anche tutti i vecchi pacchetti o usi quelli della 14.2 per entrambe le installazioni???

non vorrei crearti confusione, ma sopra non parlavo di una usb per l'installazione (che pure ti puoi fare se preferisci installarla da usb invece che da dvd) ma di una usb solo per fare il boot della nuova versione che installerai su una partizione dedicata dell'hard disk: durante la procedura di installazione normale in un passaggio l'installer ti chiede se vuoi farti una chiavetta usb di boot, mi riferivo a quella.
quando avvierai dal disco fisso, se durante la nuova procedura di installazione non avrai installato il boot loader nell'MBR del disco fisso, troverai esattamente la solita installazione che avevi (se non l'avrai sovrascritta, si intende ;) ).

riguardo ai pacchetti fossi in te farei un'installazione completa del sistema e poi, come scrivevo sopra, dovrai installare pacchetti (da SBo, ad esempio) compilati sulla nuova versione della distribuzione: io me li ricompilo tutti da zero una volta installata la nuova versione su una macchina virtuale, ma puoi farlo anche su quella fisica.

SlackNewbie
Linux 2.0
Linux 2.0
Messaggi: 104
Iscritto il: dom dic 30, 2012 15:01

Re: installazione pacchetto .tar.xz

Messaggioda SlackNewbie » mar ott 18, 2016 19:11

Salve a tutti!!!
Dunque non e' possibile installare i pacchetti della slackware 14.2 sulla 14.1 tramite sbopkg giusto??
Ma cos'e' la slackware current??
Piccola damanda offtopic ( se posso permettermi :) ) : come faccio da terminale,prima di installare un pacchetto, a verificare se una determinata dipendenza
e' oppure no presente ??
Grazie mille per l'attenzione e scusate per il prolungato disturbo che ormai penso stia arrecando :oops:

Avatar utente
N1cuz
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: lun ott 06, 2008 0:41
Nome Cognome: Nicola Bartolomei
Slackware: 14.1
Kernel: 4.3.3
Desktop: xfce4
Località: Pieve a Nievole (PT)

Re: installazione pacchetto .tar.xz

Messaggioda N1cuz » mar ott 18, 2016 19:32

ponce ha scritto:
N1cuz ha scritto:Ma se mi faccio una usb di installazione quando avvii da dico fisso e quindi con la vecchia che pacchetti usi? Devi tenerti anche tutti i vecchi pacchetti o usi quelli della 14.2 per entrambe le installazioni???

non vorrei crearti confusione, ma sopra non parlavo di una usb per l'installazione (che pure ti puoi fare se preferisci installarla da usb invece che da dvd) ma di una usb solo per fare il boot della nuova versione che installerai su una partizione dedicata dell'hard disk: durante la procedura di installazione normale in un passaggio l'installer ti chiede se vuoi farti una chiavetta usb di boot, mi riferivo a quella.
quando avvierai dal disco fisso, se durante la nuova procedura di installazione non avrai installato il boot loader nell'MBR del disco fisso, troverai esattamente la solita installazione che avevi (se non l'avrai sovrascritta, si intende ;) ).

riguardo ai pacchetti fossi in te farei un'installazione completa del sistema e poi, come scrivevo sopra, dovrai installare pacchetti (da SBo, ad esempio) compilati sulla nuova versione della distribuzione: io me li ricompilo tutti da zero una volta installata la nuova versione su una macchina virtuale, ma puoi farlo anche su quella fisica.


ah ok avevo frainteso, comunqe codesta soluzione può essere un'idea per un fisso, ma sul mio portatile non ho abbastanza spazio per fare un'apposita partizione per la 14.2.
Comunque credo che farò come mi consigli, installazione completa e poi ricompilazione dei pacchetti che mi servono da SBo (che tanto son veramente pochi).

In generale io non aggiorno mai nulla, gli aggiornamenti ufficiali li faccio solo quando navigando su qualche sito mi dice che il browser è obsoleto.... (son pessimo lo so!)

Avatar utente
N1cuz
Linux 2.4
Linux 2.4
Messaggi: 333
Iscritto il: lun ott 06, 2008 0:41
Nome Cognome: Nicola Bartolomei
Slackware: 14.1
Kernel: 4.3.3
Desktop: xfce4
Località: Pieve a Nievole (PT)

Re: installazione pacchetto .tar.xz

Messaggioda N1cuz » mar ott 18, 2016 19:43

SlackNewbie ha scritto:Salve a tutti!!!
Dunque non e' possibile installare i pacchetti della slackware 14.2 sulla 14.1 tramite sbopkg giusto??
Ma cos'e' la slackware current??
Piccola damanda offtopic ( se posso permettermi :) ) : come faccio da terminale,prima di installare un pacchetto, a verificare se una determinata dipendenza
e' oppure no presente ??
Grazie mille per l'attenzione e scusate per il prolungato disturbo che ormai penso stia arrecando :oops:


Ma che disturbo e diturbo, mica bussi alla porte della gente! Se uno si sente disturbato non risponde, se uno rispetta le regole del forum nessuno ti infama per delle domande,
Per la questione dei pacchetti non è che non sia possibile, ma è vivamente sconsigliato, nel senso che ci stà che qualche pacchetto riesci a compilarlo e ti funziona, altri invece non ce la fai a compilarli, quindi non credo che ti convenga...
La current credo sia la versione non stable, dovrebbe essere per fare testing, per l'uso quotidiano non credo che convenga, men che meno se ci devi lavorare.
Comunqe aspetta ponce che ne capisce parecchio

Avatar utente
ponce
Iper Master
Iper Master
Messaggi: 2194
Iscritto il: mer mar 05, 2008 16:45
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 4.14.0
Desktop: lxde
Località: Pisa
Contatta:

Re: installazione pacchetto .tar.xz

Messaggioda ponce » mar ott 18, 2016 20:28

SlackNewbie ha scritto:Dunque non e' possibile installare i pacchetti della slackware 14.2 sulla 14.1 tramite sbopkg giusto??

giusto.
Ma cos'e' la slackware current??

e' la versione di sviluppo di Slackware.
Piccola damanda offtopic ( se posso permettermi :) ) : come faccio da terminale,prima di installare un pacchetto, a verificare se una determinata dipendenza
e' oppure no presente ??

Codice: Seleziona tutto

ls -1 /var/log/packages/* | grep nome_dipendenza

SlackNewbie
Linux 2.0
Linux 2.0
Messaggi: 104
Iscritto il: dom dic 30, 2012 15:01

Re: installazione pacchetto .tar.xz

Messaggioda SlackNewbie » mar ott 18, 2016 21:03

Buonasera a tutti !!!
Mi sa che sono costretto a riaprire a continuare il topic....Poiche uso la slackware 14.1 e leggendo quanto scritto negli ultimi post ho optato per l'uso di slackbuilds.org per installarmi il pacchetto vlc (lettore multimediale).
Credo di aver seguito alla lettera ed nel modo corretto quanto spiegatomi nei post precedenti (che si trovano oramai nella prima pagina ) e cioe' :
ho scaricato il pacchetto .tar.gz per slackware versione 14.1 e trovandomi da terminale nella directory in cui vi e' il detto pacchetto ho dato il comando

Codice: Seleziona tutto

 tar xvf vlc.tar.gz

dopodiche' mi sono spostato nella directory vlc tramite

Codice: Seleziona tutto

 cd vlc

ho dato il permesso di esecuzione allo slackbuild tramite il comando seguente

Codice: Seleziona tutto

chmod +x vlc.SlackBuild

Poi ho scaricato e copiato nella directory dove si trova vlc.SlackBuild il pacchetto .tar.xz e al che ho dato il comando seguente

Codice: Seleziona tutto

./vlc.SlackBuild

il cui output riporto di seguito

Codice: Seleziona tutto

checking for LUA... no
configure: WARNING: No package 'lua5.2' found, trying lua 5.1 instead
checking for LUA... no
configure: WARNING: No package 'lua5.1' found, trying lua >= 5.1 instead
checking for LUA... no
configure: WARNING: No package 'lua' found, trying manual detection instead
checking lua.h usability... no
checking lua.h presence... no
checking for lua.h... no
checking lauxlib.h usability... no
checking lauxlib.h presence... no
checking for lauxlib.h... no
checking lualib.h usability... no
checking lualib.h presence... no
checking for lualib.h... no
checking for luaL_newstate in -llua5.2 ... no
checking for luaL_newstate in -llua5.1 ... no
checking for luaL_newstate in -llua51 ... no
checking for luaL_newstate in -llua ... no
configure: error: Could not find lua. Lua is needed for some interfaces (rc, telnet, http) as well as many other custom scripts. Use --disable-lua to ignore this error.


in verita' ci sono piu righe ma ho riportato le ultime date in output perche' credo che queste facciano capire dove risiede il problema (almeno cosi' credo).
Non capisco dove sbaglio..
Come posso procedere ??Grazie mille per l'attenzione e scusate per l'inettitudine (aho' non ce la faccio a non scusarmi oramai sono 4 pagine di discussione.... :oops: )