Pagina 1 di 1

[Risolto] NVidia, opnGL e Steam non funzionante

Inviato: dom mag 21, 2017 13:53
da F4B1CK
Ciao a tutti, oggi chiedo consiglio per un passatempo. Ho una bella macchina, equipaggiata con una NVidia 950GTX e volevo tornare a giochicchiare di tanto in tanto con qualche FPS, solo che ho visto che praticamente, se non hai Steam, non hai speranze di scaricare un gioco, anche free o open, come ad esempio Team Fortess 2. Ho provato ad installare Steam sulla mia Slackware (tramite slackbuild e tramite il pacchetto di AlienBob) ma non parte. Premetto che ho installato i drivers binari di nvidia (come ho sempre fatto) e sembra tutto attivato correttamente, ma all'avvio di Steam in console mi da le seguenti righe d'errore :

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast

da quel che ho potuto capire, swrast è un driver raster di failing down perché non trova i drivers openGL, ma non riesco a capire cosa manchi, dato che dovrei avere tutto installato. Premetto che ho una Slackware in current a 64 bit, ma è la prima volta che ho a che fare con Steam e pare che esistano guide ed howto solo per debian e derivate. Qualcuno ha avuto la stessa esperienza con Steam e può aiutarmi?

Re: NVidia, opnGL e Steam non funzionante

Inviato: dom mag 21, 2017 19:28
da nyquist
Ciao,
volevo chiederti, hai installato anche i pacchetti multilib sulla tua Slackware?

Re: NVidia, opnGL e Steam non funzionante

Inviato: lun mag 22, 2017 13:09
da F4B1CK
Si, ho i multilib installati. Però ho il driver NVidia binario (ho sempre usato quello per la scheda video) e questo driver è in versione a 64 bit. Potrebbe essere questo un problema?

Re: NVidia, opnGL e Steam non funzionante

Inviato: lun mag 22, 2017 22:53
da nyquist
Premetto che la mia situazione è diversa dalla tua, nel senso che io ho un portatile con scheda video che ha tecnologia optimus, quindi per far funzionare i driver video ho usato lo script apposito che installa tutto in automatico e che si trova nella documentazione ufficiale.

Detto questo, ho notato che su slackbuilds.org c'è lo SlackBuild per i driver proprietari nvidia. In particolare nel README ho notato questa nota:
Installing the 32-bit compatibility libraries is available: if desired, do:
COMPAT32="yes" ./nvidia-driver.SlackBuild


Per caso avevi già provato a passare quel parametro?

Re: NVidia, opnGL e Steam non funzionante

Inviato: mar mag 23, 2017 11:55
da F4B1CK
No, ho sempre usato i drivers proprietari in binario. Ma se non erro ad un certo punto mi chiedono se voglio installare il pacchetto a 32 bit, ma alla fine non riesco a capire se l'installazione dello stesso va a buon fine o meno. Dato che poi l'accelerazione harware funziona, non ci ho mai fatto caso più di tanto. Sarei orientato a continuare ad usare i binari, piuttosto che passare allo slackbuild, ma se non ho altre soluzioni per far funzionare steam, proverò anche questo. Se nel frattempo tu, o altri, hanno avuto modo di risolvere il problema con l'uso del driver binario, la preferirei come soluzione. Nel frattempo ti ringrazio

Re: NVidia, opnGL e Steam non funzionante

Inviato: mar mag 23, 2017 19:32
da Eberoth
Giusto per fare un chiarimento veloce, lo slackbuild usa comunque il binario per costruire il pacchetto .txz.

Re: NVidia, opnGL e Steam non funzionante

Inviato: mar mag 23, 2017 21:17
da F4B1CK
Ok, oggi sono riuscito a risolvere in questo modo. Ho eseguito i seguenti comandi per aggiornare ed integrare la sezione multilib del sistema (che comunque era regolarmente installata):

slackpkg update
slackpkg install multilib
slackpkg upgrade multilib

dopo ho scaricato gli ultimi drivers in beta dal sito NVidia, sempre a 64 bit (su suggerimento di AlienBob, che mi ha confermato che bastano quelli perché installano anche il pacchetto di compatibilità a 32 bit).
Ho installato i drivers, riavviato il server grafico e Steam è partito regolarmente!