Repository 32bit  Forum
Repository 64bit  Wiki

History consol con una parte "strana" direi quasi

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

History consol con una parte "strana" direi quasi

Messaggioda SyNko » mer giu 22, 2005 0:20

Ave a voi slackwariani.....

ho notato un fenomeno insolito: l'history della console nella prima parte è così:
"•âF›\ü² ž“X$ÍÒYÙ/Gšµ
­½ˆJž¡·õœ;¦ˆ¦×g…˜§{-ïù¼>=åâ_.öi~ï¥Á\Š¥A½’,ï¡®
X)<eKƒÕ|=SŒXÔ3Õ\½žzi0vñ¯ûn1~áPß}Y±ûn1~IÒØ}Á²ûn1~±3»ûRh1öÝbü2jn÷EÖbì»Åʋʱ˷ÅØw‹ñK¿…݆‹±ïã•‹;/9gŠ±ïcßÍÇö²|l_ÈÇjl>N¯ô³Ø¥_“öP=b¹º(±õnìv™™
SyNko
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: mer mar 02, 2005 0:00
Località: Vanzaghello

Messaggioda Loris » mer giu 22, 2005 8:46

http://www.slacky.it/modules.php?name=F ... ht=history
reset consigliato da Alba... funziona ?
"Ho una testa piuttosto balzana e comunque non sono quello che credete" - Roger Keith Barrett
Avatar utente
Loris
Admin
Admin
 
Messaggi: 7583
Iscritto il: dom mar 30, 2003 23:00
Località: Gradisca D'Isonzo
Nome Cognome: Loris Vincenzi
Slackware: 14.1
Kernel: 3.10.17
Desktop: Kde 4.10.5

Messaggioda SyNko » mer giu 22, 2005 9:48

Eh no, attenzione; in quel caso si trattava dell'output video ad essere alterato e bastava riavviare per far ritornare tutto a posto mentre ora è il file ad essere strano. come si spiega?
SyNko
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: mer mar 02, 2005 0:00
Località: Vanzaghello

Messaggioda Paoletta » mer giu 22, 2005 10:04

secondo me quelli sono i "comandi" che .bash_history ha memorizzato quando non avevi ancora fatto reset

Ciao!
Avatar utente
Paoletta
Staff
Staff
 
Messaggi: 3899
Iscritto il: dom apr 24, 2005 23:00
Località: Varese
Slackware: 13.1
Desktop: fluxbox

Messaggioda Sickk » mer giu 22, 2005 12:06

si infatti...il reset e' l'unica cosa...per quanto riguarda la history nn c puoi fare nulla..orami e' memorizzato cosi'
Sickk
Linux 2.6
Linux 2.6
 
Messaggi: 678
Iscritto il: gio nov 27, 2003 0:00

Messaggioda SyNko » mer giu 22, 2005 17:09

Insolito... :roll:
sono i primi 50 comandi ad essere così. Inoltre ho provato ad impallare con il cat per vedere se effettivamente vengono salvati poi male: risultato negativo, i comandi rimangono leggibilissimi nel file di history.

qualche altra idea?
SyNko
Linux 1.0
Linux 1.0
 
Messaggi: 10
Iscritto il: mer mar 02, 2005 0:00
Località: Vanzaghello


Torna a Sicurezza

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite