Repository 32bit  Forum
Repository 64bit  Wiki

Problemone con /etc/mtab, HELP!!!

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problemone con /etc/mtab, HELP!!!

Messaggioda Rhuo » ven lug 22, 2005 12:18

Ieri sera ho fatto una cosa allucinante, dopo aver giocato per due ore a gta san andreas, sono andato a dormire :lol: :lol: . Niente di strano in questo 8O se non fosse che al momento di spegnere il pc, poco prima che si chiudesse, come un cretino ho levato la corrente, facendo saltare la fase finale di halt. Oggi accendo il pc e cosa ti succede? cannot read '/etc/mtab/': access denied!!!!!!! Sia da Root che da utente il file è completamente inaccessibile e anzi comincio a pensare che non esista proprio dato che non è elencato. Ho provato con chown e chmod a cambiarne i permessi, a modificarlo con vi e con altri programmi ma niente.
Sono disperato, quel file serve tantissimo ( ma è possibile che il root non possa modificare un file?????? :roll: :roll: ).

Help!!!!
Rhuo
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: ven set 17, 2004 23:00

Messaggioda Firetux » ven lug 22, 2005 12:22

potresti provare partendo da cd live, cancellare il file, ricrearlo e dargli permessi 644, proprietario root e gruppo root
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda Paoletta » ven lug 22, 2005 12:39

Oggi accendo il pc e cosa ti succede? cannot read '/etc/mtab/': access denied!!!!!!! Sia da Root che da utente il file è completamente inaccessibile e anzi comincio a pensare che non esista proprio dato che non è elencato. Ho provato con chown e chmod a cambiarne i permessi, a modificarlo con vi e con altri programmi ma niente.
Sono disperato, quel file serve tantissimo ( ma è possibile che il root non possa modificare un file??????).


se riesci ad avviare la tua macchina non è necessario un cd live...comunque,sembra che basti ricrearlo!

da root,fai:

#touch /etc/mtab
Avatar utente
Paoletta
Staff
Staff
 
Messaggi: 3900
Iscritto il: dom apr 24, 2005 23:00
Località: Varese
Slackware: 13.1
Desktop: fluxbox

Messaggioda Firetux » ven lug 22, 2005 12:51

io mi sono buttato sulla soluzione "cd live" onde evitare che poi succedano casini nel montare/smontare le partizioni... comunque prova come ha detto Paoletta... poi al massimo provi come ho detto io :D
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda useless » ven lug 22, 2005 12:55

io farei anche un bel check del disco già che ci sono...
Avatar utente
useless
Staff
Staff
 
Messaggi: 3896
Iscritto il: sab ott 11, 2003 23:00
Località: A place where the streets have no name

Messaggioda Rhuo » ven lug 22, 2005 13:37

Check del disco? Come si fa?
Comunque ovviamente il comando touch non funziona perchè non ho i permessi anche se sono root
Rhuo
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: ven set 17, 2004 23:00

Messaggioda gallows » ven lug 22, 2005 14:00

Rhuo ha scritto:Check del disco? Come si fa?
Comunque ovviamente il comando touch non funziona perchè non ho i permessi anche se sono root

man fsck
Avatar utente
gallows
Staff
Staff
 
Messaggi: 3466
Iscritto il: dom set 19, 2004 23:00
Località: Palermo
Kernel: FreeBSD 8.0-RELEASE-p3
Desktop: ratpoison

Messaggioda Firetux » ven lug 22, 2005 14:06

sei non riesci proprio ad avere i permessi... vai di live
Avatar utente
Firetux
Linux 3.x
Linux 3.x
 
Messaggi: 1465
Iscritto il: mer giu 09, 2004 23:00
Località: Lecco

Messaggioda Rhuo » ven lug 22, 2005 14:06

Ottengo il seguente risultato con fsck>

Warning... fsck.reiserfs for device /dev/hda1 exited with signal 6.

Inoltre anche dalle distribuzioni live il file non si puo vedere\modificare in alcun modo

Se non ci sono altri suggerimenti passo alla formattazione...
Rhuo
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: ven set 17, 2004 23:00

Re: Problemone con /etc/mtab, HELP!!!

Messaggioda MAT » ven lug 22, 2005 15:45

Rhuo ha scritto:Ieri sera ho fatto una cosa allucinante, dopo aver giocato per due ore a gta san andreas, sono andato a dormire

OT: cosa usi per giocare a SA? Wine? Funziona bene?
Avatar utente
MAT
Linux 3.x
Linux 3.x
 
Messaggi: 1242
Iscritto il: mer mar 09, 2005 0:00
Località: Vignola, Modena
Nome Cognome: Matteo Magni
Kernel: 2.6.20
Desktop: Fluxbox
Distribuzione: Gentoo

Messaggioda gallows » ven lug 22, 2005 15:54

Rhuo ha scritto:Ottengo il seguente risultato con fsck>

Warning... fsck.reiserfs for device /dev/hda1 exited with signal 6.

Inoltre anche dalle distribuzioni live il file non si puo vedere\modificare in alcun modo

Se non ci sono altri suggerimenti passo alla formattazione...


reiser colpisce ancora :?
stato di uscita 6 vuol dire che il sistema è da riavviare(2) e che gli errori del fs non sono stati corretti(4)
vedi cosa riesci a recuperare...
Avatar utente
gallows
Staff
Staff
 
Messaggi: 3466
Iscritto il: dom set 19, 2004 23:00
Località: Palermo
Kernel: FreeBSD 8.0-RELEASE-p3
Desktop: ratpoison

Messaggioda Rhuo » ven lug 22, 2005 16:25

Non so cosa sia successo ma dopo un'oretta è tornato tutto a posto. La fede in slakc aiuta :D :D :D . Comunque uso cedega e va alla perfezione gta :lol: , a parte qualche problema con le luci delle auto ma non posso pretendere....la cosa divertente è che va coi filtri a palla attivati da nvidia-settings :D :D :D :D ed è verametne spettacolare.

grazie per l'aiuto
Rhuo
Linux 1.0
Linux 1.0
 
Messaggi: 57
Iscritto il: ven set 17, 2004 23:00

Messaggioda Paoletta » ven lug 22, 2005 16:28

ha ragione gallows, tanto più che il tuo vero problema non è il file mancante, ma il fatto che da root non riesci più ad eseguire alcun comando...

comunque se devi riformattare e reinstallare ti consiglio di passare ad ext3...IMHO reiserfs, per quanto più performante (gestisce i files con gli alberi bilanciati) non è supportato bene da strumenti come fsck come ext3;
Avatar utente
Paoletta
Staff
Staff
 
Messaggi: 3900
Iscritto il: dom apr 24, 2005 23:00
Località: Varese
Slackware: 13.1
Desktop: fluxbox

Messaggioda gallows » ven lug 22, 2005 16:35

Rhuo ha scritto:Non so cosa sia successo ma dopo un'oretta è tornato tutto a posto. La fede in slakc aiuta :D :D :D . Comunque uso cedega e va alla perfezione gta :lol: , a parte qualche problema con le luci delle auto ma non posso pretendere....la cosa divertente è che va coi filtri a palla attivati da nvidia-settings :D :D :D :D ed è verametne spettacolare.

grazie per l'aiuto


sei stato fortunato, io comunque farei un bel backuppone :roll:
Avatar utente
gallows
Staff
Staff
 
Messaggi: 3466
Iscritto il: dom set 19, 2004 23:00
Località: Palermo
Kernel: FreeBSD 8.0-RELEASE-p3
Desktop: ratpoison

Messaggioda Paoletta » ven lug 22, 2005 16:56

che fortuna! :P
Avatar utente
Paoletta
Staff
Staff
 
Messaggi: 3900
Iscritto il: dom apr 24, 2005 23:00
Località: Varese
Slackware: 13.1
Desktop: fluxbox

Prossimo

Torna a Sicurezza

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite