Repository 32bit  Forum
Repository 64bit  Wiki

vpn - iptable

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

vpn - iptable

Messaggioda format » sab nov 05, 2005 10:58

Ciao a tutti,
sto cercando di connettere con una vpn (openswan) una sede remota alla mia rete aziendale. Premetto che localmente abbiamo un firewall sonicwall che fa da router-nat...etc ed è gia collegato con altre 3 vpn. Dopo mille peripezie sono riuscito a stabilire il tunnel fra le 2 sedi. Il problema è che non riesco a raggiungere gli host dall'altra parte. Il server linux che fa la vpn è anche il gateway della stessa rete quindi è abilitato ip-forward, ho configurato il nat e mascheramento dalla rete, ed è qui che credo sia il problema. devo dare una regola che faccia passare tutto cio che arriva da ipsec0(la vpn) verso eth0(rete interna) e contrario. Se puo' essere d'aiuto usando netwatch ed eseguendo un ping da client(locale) ad un client(remoto) vedo che il pacchetto arriva ma da come errore mac addr.
Questo è tutto, se qualcuno puo' aiutarmi mi faccia sapere tutti i dati che gli servono così li pubblico sul forum.
grazie.
format
Linux 1.0
Linux 1.0
 
Messaggi: 49
Iscritto il: dom feb 20, 2005 0:00

Messaggioda format » sab nov 05, 2005 12:35

Scusatemi ma ho risolto, dovevo inserire una route statica che puntasse all'interfaccia ipsec0 per il raggiungimento della mia rete.
grazie comunque
format
Linux 1.0
Linux 1.0
 
Messaggi: 49
Iscritto il: dom feb 20, 2005 0:00


Torna a Sicurezza

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

cron