Repository 32bit  Forum
Repository 64bit  Wiki

Problema con iptables :: Firewall si...ma non funziona

Postate qui per tutte le discussioni legate alla sicurezza di Linux/Slackware

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Specificare se discussione/suggerimento o richiesta d'aiuto.
3) Leggere attentamente le risposte ricevute.
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problema con iptables :: Firewall si...ma non funziona

Messaggioda Ir0nFl4m3 » lun nov 28, 2005 17:55

Ciao a tutti,
ho un pc con 2 interfaccie di rete, una interna con ip di classe C (eth0) e una che si affaccia su internet con ip pubblico (eth1).
Con questo firewall

#!/bin/sh

echo "1" > /proc/sys/net/ipv4/ip_forward
#modprobe iptables
modprobe iptable_mangle
modprobe ip_conntrack
modprobe ipt_conntrack
modprobe iptable_nat
modprobe ipt_MASQUERADE
modprobe ipt_TOS
modprobe ipt_mark
modprobe ipt_tos
modprobe ipt_ecn
modprobe ipt_dscp
modprobe ipt_ttl
modprobe ip_nat_irc

iptables -F INPUT
iptables -F OUTPUT
iptables -F FORWARD


iptables -A INPUT -s 127.0.0.1/8 -j ACCEPT
iptables -A INPUT -i eth0 -s 10.0.0.0/255.255.255.0 -j ACCEPT

iptables -A INPUT -i eth1 -s 0/0 -p tcp --syn --dport http -j ACCEPT
iptables -A INPUT -i eth1 -s 0/0 -p tcp --syn --dport ssh -j ACCEPT

iptables -A INPUT -p icmp -m icmp --icmp-type 8 -m limit --limit 1/s -j ACCEPT

iptables -A INPUT -p icmp --icmp-type echo-reply -j ACCEPT

iptables -A INPUT -p udp -m state --state NEW -j DROP

iptables -A INPUT -p tcp ! --syn -m state --state NEW -j DROP

iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

iptables -P INPUT DROP
iptables -A FORWARD -p icmp -m icmp --icmp-type 8 -m limit --limit 5/s -j ACCEPT

iptables -t nat -A POSTROUTING -d ! 10.0.0.0/24 -j MASQUERADE
iptables -A FORWARD -s 10.0.0.0/24 -j ACCEPT
iptables -A FORWARD -d 10.0.0.0/24 -j ACCEPT
iptables -A FORWARD -j DROP

iptables -P FORWARD DROP

# OUTPUT CHAIN
iptables -P OUTPUT ACCEPT

teoricamente dovrei ottenere che dall'esterno sia possibile collegarsi solo alle porte web e ssh invece risultano tutte aperte ma non capisco dove sia il problema....
Vi prego datemi una mano...
Ir0nFl4m3
Linux 2.4
Linux 2.4
 
Messaggi: 204
Iscritto il: sab set 27, 2003 23:00

Messaggioda IceSlack » mar nov 29, 2005 9:56

emm........ cosa stupida.... ma sei dietro a un router? hai aperto la porta del router?
Avatar utente
IceSlack
Linux 3.x
Linux 3.x
 
Messaggi: 1313
Iscritto il: dom ott 30, 2005 13:27

Messaggioda Ir0nFl4m3 » mar nov 29, 2005 13:05

Sono dietro al router ma con ip pubblico su eth1 e ip di lan su eth0
Ciao
Ir0nFl4m3
Linux 2.4
Linux 2.4
 
Messaggi: 204
Iscritto il: sab set 27, 2003 23:00


Torna a Sicurezza

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron