skype broken su current

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.
Avatar utente
ZeroUno
Staff
Staff
Messaggi: 5120
Iscritto il: ven giu 02, 2006 14:52
Nome Cognome: Matteo Rossini
Slackware: current
Kernel: slack-current
Desktop: ktown-latest
Distribuzione: 01000000-current
Località: Roma / Castelli
Contatta:

skype broken su current

Messaggioda ZeroUno » lun set 24, 2018 22:40

Ci risiamo che bisogna rifare gli impicci per far funzionare skype!!!

Ricordate quando skype 4.4 non funzionava più perchè era stato rimosso il supporto per alsa e slackware ancora non aveva pulseaudio? e microsoft non consentiva più la login con skype 4.3?
A suo tempo si risolse prima compilando una versione ridotta di pulseaudio e mettendola direttamente nel pacchetto di skype_static, poi uscì apulse che simulava pulseaudio (ma sempre un piccolo binario esterno andava compilato e messo nel pacchetto).

Ora ci risiamo.
L'ultima release di skype è la 8.31
slackware ha aggiornato glibc a 2.28 e skype da 8.20 a 8.29 vanno in segmentation fault.
skype 8.30 e 8.31 richiedono systemd&logind !!!

Ora si ricomincerà con "basta skype" e blah blah blah, ma nel frattempo su linuxquestions se ne è parlato e pare che al pari di apulse esiste un emulatore di logind:
https://github.com/elogind/elogind
https://www.linuxquestions.org/question ... 175638990/
https://www.linuxquestions.org/question ... 175638207/

per ora non ho tempo di mettermici, ma skype 8.18 e inferiori funzionano. Finchè microsoft si limiterà a mostrare l'avvertimento che c'è una nuova versione disponibile non è un problema. Quando deciderà di inibire l'accesso alla 8.18 beh, Pat vede e provvede ;)
Packages finder: slakfinder.org | Slackpkg+, per aggiungere repository a slackpkg

Codice: Seleziona tutto

1011010 1100101 1110010 1101111 - 0100000 - 1010101 1101110 1101111