Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Adobe Reader non funziona

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Adobe Reader non funziona

Messaggioda scorpion77 » mar set 01, 2009 10:45

Ciao, da pochi giorni ho installato Slackware64 13. Ho provato a installare Adobe Reader, usando il pacchetto di ponce, avendo prima installato tutte le librerie di compatibilità 32 bit da qui: http://mirrors.evolva.ro/slamd64/slackware64-current/slackware64/ e ho pure installato pixman e libxml2 sempre di ponce.
Però se lancio acroread, ottengo questo output:

Codice: Seleziona tutto
$ acroread
dirname: missing operand
Usare `dirname --help' per ulteriori informazioni.
/usr/bin/acroread: symbol lookup error: /usr/lib/libpangocairo-1.0.so.0: undefined symbol: cairo_surface_has_show_text_glyphs


Cosa c'è che non va?

Grazie,

Scorpion77
Ultima modifica di scorpion77 il mar set 01, 2009 12:58, modificato 1 volta in totale.
Avatar utente
scorpion77
Linux 1.0
Linux 1.0
 
Messaggi: 92
Iscritto il: gio gen 20, 2005 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Desktop: KDE 4.10.5

Re: Adobe Reader non funziona

Messaggioda ponce » mar set 01, 2009 11:31

sembra che la libreria libpangocairo contenuta in pango-compat32 non gli piaccia, prova a disinstallare i pacchetti *compat32* e installare questi, eventualmente puoi provare ad aggiornare solo pango-compat32.
Avatar utente
ponce
Master
Master
 
Messaggi: 1503
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: Adobe Reader non funziona

Messaggioda scorpion77 » mar set 01, 2009 12:57

ponce ha scritto:sembra che la libreria libpangocairo contenuta in pango-compat32 non gli piaccia, prova a disinstallare i pacchetti *compat32* e installare questi, eventualmente puoi provare ad aggiornare solo pango-compat32.


Ora funziona perfettamente. Ho reinstallato cairo-compat32-1.8.6-x86_64-3.txz e pango-compat32-1.22.4-x86_64-4.txz.

Grazie mille!

Scorpion77
Avatar utente
scorpion77
Linux 1.0
Linux 1.0
 
Messaggi: 92
Iscritto il: gio gen 20, 2005 0:00
Nome Cognome: Andrea
Slackware: Slackware64 14.1
Desktop: KDE 4.10.5

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda Vito » gio set 03, 2009 11:31

Ho problemi anche io con adobe reader :

Codice: Seleziona tutto
[vito@Freedom:~]$ acroread
dirname: missing operand
Try `dirname --help' for more information.
/usr/bin/acroread: line 22: /opt/Adobe/Reader9/Reader/intellinux/bin/acroread: No such file or directory
/usr/bin/acroread: line 22: /opt/Adobe/Reader9/Reader/intellinux/bin/acroread: Success


Sto utilizzando i pacchetti compat32 di Alien.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda Vito » gio set 03, 2009 11:52

Ho risolto, non avevo installato i pacchetti *multilib di Alien. #-o
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda Vito » mer dic 23, 2009 11:11

Per caso vi ricordate in che pacchetot si trova questa libreria?

libgdk_pixbuf_xlib-2.0.so.0
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda JohnnyMnemonic » mer dic 23, 2009 11:15

Codice: Seleziona tutto
johnny@localhost:/var/log/packages$ grep libgdk_pixbuf_xlib *
gtk+2-2.12.12-i486-1:usr/lib/libgdk_pixbuf_xlib-2.0.so.0.1200.12
gtk+2-2.12.12-i486-1:usr/lib/libgdk_pixbuf_xlib-2.0.la


Su una 12.2, però ti può essere utile lo stesso
Avatar utente
JohnnyMnemonic
Staff
Staff
 
Messaggi: 2732
Iscritto il: sab set 04, 2004 23:00
Località: Bologna
Nome Cognome: Giuseppe Palmiotto
Slackware: 14.0
Kernel: 3.5.5-thanatos

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda Vito » mer dic 23, 2009 12:36

Grazie mille!
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda Vito » mer dic 23, 2009 12:59

Codice: Seleziona tutto
[vito@Freedom:~]$ acroread
dirname: missing operand
Try `dirname --help' for more information.

(acroread:32719): Pango-CRITICAL **: No modules found:
No builtin or dynamically loaded modules were found.
PangoFc will not work correctly.
This probably means there was an error in the creation of:
  '/etc/pango/pango.modules'
You should create this file by running:
  pango-querymodules > '/etc/pango/pango.modules'

(acroread:32719): Pango-WARNING **: failed to find shape engine, expect ugly output. engine-type='PangoRenderFc', script='latin'

(acroread:32719): Pango-WARNING **: failed to find shape engine, expect ugly output. engine-type='PangoRenderFc', script='common'


Mi sta restituendo questo tipo di errore,
ho provato a ricreare quel file come mi viene suggerito,ma niente..
I caratteri non mi vengono visualizzati quando avvio il programma.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda ponce » mer dic 23, 2009 15:30

io proverei a reinstallare i compat32 (e i relativi glibc-* e gcc-*) di alien.
Avatar utente
ponce
Master
Master
 
Messaggi: 1503
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda Vito » mer dic 23, 2009 16:17

L'errore persiste... :-k
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda ponce » mer dic 23, 2009 17:33

dovresti riavviare il pc (i file in questione dovrebbero essere creati al riavvio).
Avatar utente
ponce
Master
Master
 
Messaggi: 1503
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda Vito » mer dic 23, 2009 19:13

ponce ha scritto:dovresti riavviare il pc (i file in questione dovrebbero essere creati al riavvio).


Sono passado da init1 a init4..
riavvio comunque?
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda ponce » mer dic 23, 2009 20:16

prova, eventualmente riavvia: l'ha appena fatto anche a me a casa dove mi sono reinstallato una current64 pulita: prima di riavviare vedevo dei quadratini al posto dei caratteri nell'interfaccia di acrobat :)
Avatar utente
ponce
Master
Master
 
Messaggi: 1503
Iscritto il: mer mar 05, 2008 16:45
Località: Pisa
Nome Cognome: Matteo Bernardini
Slackware: slackware64-current
Kernel: 3.17-rc3
Desktop: lxde

Re: [RISOLTO] Adobe Reader non funziona

Messaggioda Vito » mer dic 23, 2009 20:24

Ok, risolto..
Grazie mille ponce!
Avevo commentato quelle righe.
"Stat rosa pristina nomina, nomina nuda tenemus." [ Umberto Eco - Il nome della rosa]

"Faber est suae quisque fortunae ." [ Appio Claudio Cieco]
Avatar utente
Vito
Staff
Staff
 
Messaggi: 4135
Iscritto il: mar dic 05, 2006 17:28
Località: Augsburg (DE)
Nome Cognome: Vito
Slackware: 64 14.0 multilib
Kernel: 3.2.29-xps
Desktop: KDE 4.10.2
Distribuzione: Linux Mint 17


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti