Pagina 1 di 1

GoogleEarth [Risolto]

Inviato: mer set 30, 2009 15:25
da Bakkio2
Ho visto in altri forum, ma non ho trovato la soluzione adatta.
Ho installato i pacchetti di compatibilità a 32bit,
Dopo di che da slackbuilds.org ho scaricato sia il bin sia lo slackb.
ho lanciato il comando

Codice: Seleziona tutto

ARCH=x86_64 ./GoogleEarth.SlackBuild
che mi ha creato il tgz che ho regolarmente installato.
A questo punto avvio il programma ma mi da errore Segment Default.
Quindi scarico e copio come da guida la libreria:

Codice: Seleziona tutto

cd /opt/GoogleEarth/
bash-3.1# wget http://librarian.launchpad.net/7037027/libGL.so.1 -O libGL.so.1

Ricompilo i driver della scheda video.
A questo punto parte googleearth regolarmente, ma non visualizzo "le mappe", overro vedo la parte dedicata alla vista tutta nera.
In giro non trovo soluzioni...
Qualcuno sa aiutarmi?!?

Re: GoogleEarth.

Inviato: mer set 30, 2009 15:56
da Blallo
E' strano che ti vada in SegFault, io pure sto con i pacchetti di compatibilità e senza copiare la libreria funziona tutto alla grande.. :-k
EDIT prova a sostituire ARCH=x86_64 e CHOST=x86_64 direttamente nello slackbuild e rifai il pacchetto
è strano che comunque abbia le maiuscole il nome del pacchetto...rinominalo tutto in minuscolo senno lo SB non lo copia nel pacchetto

Re: GoogleEarth.

Inviato: mer set 30, 2009 21:50
da Bakkio2
Ho provato, ma mi da sempre lo stesso problema...
Ho tentato anche di compilarlo con ARCH=i486, ma come sopra...

Re: GoogleEarth.

Inviato: gio ott 01, 2009 0:58
da Blallo
prova con questo, magari hai toccato qualcosa di troppo, e non rinominarlo
PS rimuovi quella libreria che hai scaricato prima
EDIT installa TUTTI questi pacchetti http://airex.altervista.org/slackware64-compat32/ (con upgradepkg --install-new ovviamente), può darsi ne hai saltato qualcuno

Re: GoogleEarth.

Inviato: sab ott 03, 2009 21:40
da Bakkio2
jimmy_page_89 ha scritto:prova con questo, magari hai toccato qualcosa di troppo, e non rinominarlo
PS rimuovi quella libreria che hai scaricato prima
EDIT installa TUTTI questi pacchetti http://airex.altervista.org/slackware64-compat32/ (con upgradepkg --install-new ovviamente), può darsi ne hai saltato qualcuno


Hai proprio ragione, è bastato rimuovere quella libreria e installare i pacchetti mancanti e tutto ha funzionato!