Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] aiuto non sento l'audio

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] aiuto non sento l'audio

Messaggioda maso » mer set 30, 2009 20:07

Ragazzi ho nel mio pc installati sia slackware a 32 bit che quello a 64 bit. L'installazione è stata identica ma nella 64 bit non si sente l'audio...che fare? Ho un Dell studio xps con le seguenti caratteristiche:
Codice: Seleziona tutto
root@slack:~# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)                                                                   
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)                                                               
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)                                                                 
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)                                                                 
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)                                                                 
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)                                                                 
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)                                                                       
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)                                                                         
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility HD 3670
01:00.1 Audio device: ATI Technologies Inc RV635 Audio device [Radeon HD 3600 Series]
04:00.0 Network controller: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] Network Connection
08:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe (rev 10)
09:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
09:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
09:01.2 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 12)
09:01.3 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
09:01.4 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev ff)
Ultima modifica di maso il gio ott 01, 2009 9:58, modificato 1 volta in totale.
maso
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: ven set 25, 2009 11:12

Re: aiuto non sento l'audio

Messaggioda madtux » mer set 30, 2009 21:09

Che versione hai?
se è la 12.2 a me l'audio non si sentita se mettevo il login grafico,
quindi in runlevel 4
se andavo in login testuale,runlevel 3,tutto fungeva.
prova a vedere da terminale se il volume sta a 0.
Codice: Seleziona tutto
alsamixer
verifichi il volume

Codice: Seleziona tutto
alsactl store
salvi la configurazione
faccè sapè
Avatar utente
madtux
Linux 2.0
Linux 2.0
 
Messaggi: 138
Iscritto il: ven dic 29, 2006 20:34
Località: Castel di Sangro
Slackware: 13.1
Kernel: 2.6.33.4-smp
Desktop: xfce

Re: aiuto non sento l'audio

Messaggioda maso » mer set 30, 2009 21:35

come ho notato in un altro topic la scheda audio, volume, ecc sono perfetti, in quanto se inserisco nel pc degli auricolari si sente tutto perfettamente, il problema è quando questi non ci sono, ovvero gli altoparlanti. Cosa faccio?
maso
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: ven set 25, 2009 11:12

Re: aiuto non sento l'audio

Messaggioda lamarozzo » mer set 30, 2009 21:55

Prova a impostare manualmente il modello della tua scheda audio.

Fai una ricerca in base al chipset su

http://www.mjmwired.net/kernel/Document ... Models.txt

e poi in /etc/modprobe.d/sound.conf

metti
Codice: Seleziona tutto
options snd-hda-intel model=MODEL


dove snd-hda-intel model sarà il tuo driver audio e MODEL il modello che trovi nella pagina che ti ho linkato.
Avatar utente
lamarozzo
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: mer lug 13, 2005 23:00
Località: Roma
Desktop: xfce
Distribuzione: archlinux

Re: aiuto non sento l'audio

Messaggioda maso » mer set 30, 2009 22:15

su slackware64 13 non ho il file /etc/modprobe.d/sound.conf, ho un file /etc/modprobe.d/sound in cui c'è soltanto
Codice: Seleziona tutto
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
è lui?

PS: tranne il file sound, che non ha estensione, tutti gli altri file che sono nella directory /etc/modprobe.d/ sono tutti del tipo *.conf :? mistero???
maso
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: ven set 25, 2009 11:12

Re: aiuto non sento l'audio

Messaggioda SIV » mer set 30, 2009 23:13

maso ha scritto:su slackware64 13 non ho il file /etc/modprobe.d/sound.conf, ho un file /etc/modprobe.d/sound in cui c'è soltanto
Codice: Seleziona tutto
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
è lui?

PS: tranne il file sound, che non ha estensione, tutti gli altri file che sono nella directory /etc/modprobe.d/ sono tutti del tipo *.conf :? mistero???


Che modello di pc hai? Io il file /etc/modprobe.d/sound.conf me lo sono creato solo per metterci dentro:

Codice: Seleziona tutto
options snd_hda_intel model=acer


In modo da avere tutti i canali audio abilitati sul mio modello acer.
Avatar utente
SIV
Linux 2.6
Linux 2.6
 
Messaggi: 918
Iscritto il: mer apr 25, 2007 13:07
Località: Bari (Provincia)

Re: aiuto non sento l'audio

Messaggioda lamarozzo » gio ott 01, 2009 9:35

Prova a metterlo in sound, e se non funziona in sound.conf, o altrimenti in entrambi. La cosa dipende dagli script di avvio di Slackware che probabilmente leggono ancora tutti i file nella directory /etc/modprobe.d. Io uso archlinux e da un po' di tempo hanno reso obbligatoria l'estensione .conf per i file della directory.
Avatar utente
lamarozzo
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: mer lug 13, 2005 23:00
Località: Roma
Desktop: xfce
Distribuzione: archlinux

Re: aiuto non sento l'audio

Messaggioda maso » gio ott 01, 2009 9:38

Già provato anch'io. Il mio pc è un dell studio xps 16. Ho creato un file sound.conf con:
Codice: Seleziona tutto
options snd_hda_intel model=dell-m6

nada.

Ho ricontrollato entrambe le mie slack installate nel mio pc (la 32 e la 64 bit) e sono IDENTICHE, gli stessi file, le stesse configurazioni...ma nella 32 l'audio funziona, nella 64 no :cry:
Il partizionamento del mio HD è il seguente:
Codice: Seleziona tutto
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1           5       40131   de  Dell Utility
/dev/sda2               6        1918    15360000    7  HPFS/NTFS
/dev/sda3   *        1919       27412   204780555    7  HPFS/NTFS
/dev/sda4           27413       60801   268197142+   5  Extended
/dev/sda5           27413       27910     4000153+  82  Linux swap
/dev/sda6           27911       40068    97659103+  83  Linux
/dev/sda7           40069       41892    14651248+  83  Linux
/dev/sda8           41893       43804    15358108+  83  Linux
/dev/sda9           43805       45671    14996646   83  Linux
dove slackware da 32 bit sta in sda8, e slack 64 in sda9. Può darsi che il bios abbia difficoltà a raggiungerla essendo situata al 350esimo GB??? Inoltre la slack 32 ha comefiesystem ext3, la 64 ext4, c'entra nulla?
maso
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: ven set 25, 2009 11:12

[RISOLTO] Re: aiuto non sento l'audio

Messaggioda maso » gio ott 01, 2009 9:57

Scusate il doppio post, ma in QUESTO TOPIC hanno risolto il mio problema: nel KMix di KDE lo speaker di default era impostato su muto.

Ha propio ragione Volkerding quando rammenta il motto KISS (Keep it Simple, Stupid!), a volte ci complichiamo la vita per niente. :rabbit:

Grazie a tutti per le risposte :mille:
maso
Linux 1.0
Linux 1.0
 
Messaggi: 56
Iscritto il: ven set 25, 2009 11:12

Re: aiuto non sento l'audio

Messaggioda lamarozzo » gio ott 01, 2009 10:01

Questa non la sapevo, immaginavo che il mixer di kde fosse legato ad alsamixer in qualche modo, così come succede per xfce.
Avatar utente
lamarozzo
Linux 2.6
Linux 2.6
 
Messaggi: 732
Iscritto il: mer lug 13, 2005 23:00
Località: Roma
Desktop: xfce
Distribuzione: archlinux


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Yahoo [Bot] e 1 ospite