Repository 32bit  Forum
Repository 64bit  Wiki

Risolto [problemi con chroot in cross-tool environment]

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Risolto [problemi con chroot in cross-tool environment]

Messaggioda scartozzo » dom dic 20, 2009 2:23

Ho finalmente risolto il problema.
Premessa.
Nella curiosità e nel desiderio di accrescere le mie conoscenze ho iniziato ad avvicinarmi a progetti quali LFS e DIY-linux [jaguar-linux].
Pur essendo ignorante, nel senso di non avere cognizioni di programmazione, ho iniziato a configurare e compilare un ambiente con la sua toolchain partendo dal progetto DIY. Il prossimo sviluppo, se non mi areno prima, sarà compilare il sistema di base e pacchettizzarlo con pkgtool.
La soluzione al problema, rispetto al messaggio in questione, è stata la configurazione di alcuni variabili di ambiente [--buil --host --target] per la preparazione del makefile di binutils, gcc e glibc ed una aggiustamento sulla compilazione vera e propria [es. al posto di make make all-host, ecc.].

Mi scuso per il messaggio fuori tema, ma data la mia ignoranza pensavo ad un problema della slackware installata.

Comunque, ho predisposto uno script (molto semplice) per la creazione dell'ambiente crossing-tool.
il sistema host che ho installato è Slackware 13.0
mentre per quanto riguarda il sistema target ho lavorato con
gcc-4.4.3
glibc-2.11
binutils-2.20
linux-2.6.32.2.


Ho terminato la preparazione di una toolchain. Al chroot ho di ritorno Il messaggio:
Codice: Seleziona tutto
/bin/bash: error while loading shared libraries: libtermcap.so.2: cannot open shared object file: No such file or directory


Codice: Seleziona tutto
root@freud:/lib64# ldd /bin/bash
        linux-vdso.so.1 =>  (0x00007fff6e762000)
        libtermcap.so.2 => /lib64/libtermcap.so.2 (0x00007f28a8763000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007f28a855f000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f28a81ef000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f28a8966000)


Ho provato a compilare e reinstallare bash con l'opzione --with-curses ed anche con ncurses il risultato è lo stesso.
Benvengano suggerimenti.
Grazie

Avatar utente
scartozzo
Packager
Packager
 
Messaggi: 249
Iscritto il: mar feb 08, 2005 0:00
Località: Torino
Nome Cognome: Flavio Gallucci
Kernel: 3.10.10
Desktop: fluxbox
Distribuzione: blfs-7.4

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite