Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]Tastiera Italiana con XFCE

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO]Tastiera Italiana con XFCE

Messaggioda Zosty70 » lun gen 25, 2010 10:02

Ciao a tutti,

ho appena installato Slackware64 e quasi tutto e' OK.
Ho un piccolo problema con il settaggio del layout della tastiera sotto XFCE. Utilizzando System-System Settings ho impostato la tastiera italiana e funziona correttamente (compare anche la bandierina italiana sul pannello). Il problema e' che, appena esco dalla sessione e rientro, le impostazioni vanno perse...e la tastiera ritorna US anche se nel System Settings compare selezionato il solo layout italiano.

Ho provato a modificare il file /etc/hal/fdi/policy/10-keymap.fdi cosi
Codice: Seleziona tutto
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->

<!-- DO NOT EDIT THIS FILE - IT WILL BE OVERWRITTEN ON UPGRADES.
     SEE THE "READ THIS" NOTE BELOW FOR INSTRUCTIONS -->

<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">

      <!-- Restore Ctrl-Alt-Bksp Xserver Zapping -->
      <merge key="input.xkb.options" type="string">terminate:ctrl_alt_bksp</mer

      <!-- Edit (as needed) these four lines in the copied fdi file -->
      <merge key="input.xkb.rules" type="string">base</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">it</merge>
      <merge key="input.xkb.variant" type="string" />

    </match>


escludendo xorg.conf...ma non funziona ancora.... :(

Dove sbaglio?

Grazie
Z
Ultima modifica di Zosty70 il lun gen 25, 2010 18:26, modificato 1 volta in totale.
Zosty70
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: lun gen 25, 2010 9:52
Slackware: 13
Kernel: 2.6.29.6 #2 SMP
Desktop: xfce

Re: Tastiera Italiana con XFCE

Messaggioda teme » lun gen 25, 2010 10:40

Se vai in impostazioni -> tastiera che configurazione hai?
Io ho nella scheda mappatura questa configurazione: usa predefiniti da sistema...Tu usi qualche impostazione diversa?
Avatar utente
teme
Linux 2.4
Linux 2.4
 
Messaggi: 362
Iscritto il: mar gen 27, 2004 0:00

Re: Tastiera Italiana con XFCE

Messaggioda Cenni » lun gen 25, 2010 11:49

prova a vedere qui, io ho risolto così:
viewtopic.php?f=1&t=30547&p=263509#p263509
ciao
Avatar utente
Cenni
Linux 2.0
Linux 2.0
 
Messaggi: 104
Iscritto il: mar feb 27, 2007 15:12
Località: Torino
Nome Cognome: Cenni
Slackware: 13.37
Kernel: 2.6.37.6
Desktop: XFCE
Distribuzione: salix e puppeee

Re: Tastiera Italiana con XFCE

Messaggioda brainvision » lun gen 25, 2010 13:15

devi salvare la sessione quando esci da xfce.. ciao!

p.s. oppure segui l'altro metodo, scegli tu!
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Tastiera Italiana con XFCE

Messaggioda GatewayAsteroid » lun gen 25, 2010 14:18

Io ho fatto aggiungendo questa riga ad uno script che carico all'avvio :)
Codice: Seleziona tutto
setxkbmap -model pc105 -layout it
Avatar utente
GatewayAsteroid
Linux 1.0
Linux 1.0
 
Messaggi: 65
Iscritto il: ven nov 27, 2009 18:26
Località: Milano
Nome Cognome: Davide
Slackware: 13.37
Desktop: XFCE

Re: Tastiera Italiana con XFCE

Messaggioda Zosty70 » lun gen 25, 2010 18:24

brainvision ha scritto:devi salvare la sessione quando esci da xfce.. ciao!

p.s. oppure segui l'altro metodo, scegli tu!


Naturalmente...salvavo la sessione!
Ora pero' funziona....non so come mai! Forse dovevo riavviare completamente il pc...mentre per le prove semplicemente chiudevo la sessione grafica e riaprivo una nuova sessione (mi sloggavo e mi riloggavo...)

comunque...ho seguito la procedura con HAL.

Grazie
Zosty70
Linux 1.0
Linux 1.0
 
Messaggi: 2
Iscritto il: lun gen 25, 2010 9:52
Slackware: 13
Kernel: 2.6.29.6 #2 SMP
Desktop: xfce


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron