Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO]Aggiornare Python

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: [RISOLTO]Aggiornare Python

Messaggioda danix » sab feb 20, 2010 11:11

scusami shock, mi diresti quali differenze ci sono tra il 2.6 e il 3 da convincerti che valga la pena imparare a programmare su quest'ultimo piuttosto che su quello che già avevi?? Te lo chiedo perchè dal momento che hai scelto avrai avuto le tue buone motivazioni e vorrei capire se anche per me vale la pena installare il 3 per programmare...

Grazie in anticipo...
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Re: [RISOLTO]Aggiornare Python

Messaggioda shock » sab feb 20, 2010 13:24

Beh...penso sia inutile postarti link, quindi rispondo direttamente alla tua domanda.
Ho scelto il tre per tre motivi:

-seguendo la guida "pensare da informatico" ogni codice devo anche "convertirlo" alla nuova versione poiche il libro è vecchiotto...dunque cosi ricordo meglio il tutto, dati i vari tentativi che devo fare per far funzionare il codice.
Ad esempio se prima il comando per stampare era print "testo da visualizzare" ora è print ("testo da visualizzare")

-poi anche perche per adesso la maggior parte delle applicazioni gira sulla 2.x ma penso che presto ci sara un aggiornamento globale.

-infine anche perche preferisco tenermi al passo coi tempi..dato che comunque ci sono state anche dele implementazioni di varie librerie che rendono migliore l'utilizzo del linguaggio.

Tutte queste cose concorrono alla scelta...spero di esserti stato d'aiuto.

Ciao :D
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: [RISOLTO]Aggiornare Python

Messaggioda danix » sab feb 20, 2010 18:30

grazie della risposta...
Avatar utente
danix
Staff
Staff
 
Messaggi: 3280
Iscritto il: ven ott 27, 2006 18:32
Località: Siderno (RC)
Nome Cognome: Danilo M.
Slackware: 64 14.0
Kernel: 3.2.29
Desktop: fluxbox

Precedente

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti