Repository 32bit  Forum
Repository 64bit  Wiki

Problemi con wine

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problemi con wine

Messaggioda shock » sab feb 20, 2010 18:25

Scusate...tramite il pacchetto qui su slacky ho installato wine e sono riuscito anche ad installare due giochi:vene cito solo uno perche è il piu conosciuto "resident evil 4".....il gioco si installa perfettamente, quando lo avvio mi dice che a causa di un errore il gioco è stato fermato...perche?Onestamente mi era nato il dubbio sulla prersenza o meno della directx.

Potete darmi una mano?

Ciao.

P.S. Mi sono documentato solo che non sono riuscito a venire a capo del problema. :(
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Problemini con wine

Messaggioda Blallo » sab feb 20, 2010 18:34

che versione di wine stai usando?
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Problemini con wine

Messaggioda shock » sab feb 20, 2010 18:49

Questo è il pacchetto che ho scaricato http://www.slacky.eu/aadm/pkgs/index.php?ver=13&pkg=189

Ciao e grazie
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Problemini con wine

Messaggioda Blallo » sab feb 20, 2010 18:49

ma sei in 32 o 64 bit?
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Problemini con wine

Messaggioda shock » sab feb 20, 2010 18:59

Come puoi vedere dalle mie info sono in 64.

Ciao.
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Problemini con wine

Messaggioda Ansa89 » sab feb 20, 2010 19:01

Hai le librerie a 32 bit?
Tutti i pacchetti di slacky.eu sono compilati per slackware a 32 bit.
Avatar utente
Ansa89
Iper Master
Iper Master
 
Messaggi: 2621
Iscritto il: mer ago 29, 2007 16:57
Località: Modena
Nome Cognome: Stefano Ansaloni
Slackware: 13.1
Kernel: 3.16.1-ck1
Desktop: XFCE 4.6.1

Re: Problemini con wine

Messaggioda Blallo » sab feb 20, 2010 19:05

è meglio comunque secondo me ricompilare sulla 64, così si sta sicuri che linki perfettamente alle compat32
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Problemini con wine

Messaggioda brainvision » sab feb 20, 2010 19:15

Comunque, visto che lo avevi chiesto ed ancora nessuno vi ha fatto cenno, a meno di non dover installare un programma o gioco che richieda espressamente un'altra versione directX, wine ha già di suo tutte le librerie strettamente necessarie.
Online trovi una specie di database dove vengono segnalati tutti programmi funzionanti e quelli non e quelli a patto che, l'indirizzo è http://appdb.winehq.org/. Francamente non ho controllato ma credo che un titolo come resident evil qualcuno ci abbia provato eccome ad installarlo con wine..

P.S.: ma hai il gioco originale? lo hai scaricato? a me farebbe piacere provarlo, più per curiosità che altro..
Avatar utente
brainvision
Packager
Packager
 
Messaggi: 756
Iscritto il: ven dic 26, 2008 18:23
Località: bologna (bo)
Nome Cognome: Leonardo Totaro
Slackware: x86_64-current
Kernel: 3.7.1
Desktop: xfce 4.10

Re: Problemini con wine

Messaggioda Blallo » sab feb 20, 2010 19:19

ho visto io
con la 1.1.25 ha una valutazione silver, quindi ora boh...
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Problemini con wine

Messaggioda Amrod » sab feb 20, 2010 19:35

Ciao, oltre che avere aggiornato i vari pacchetti per essere multilib, devi avere installati anche la versione a 32 bit dei driver della scheda video.
Sia i driver nvidia che ati dovrebbero installare automaticamente anche la versione a 32 bit per la compatibilita, in piu' io per far andare i giochi
a 32 bit sia nativi che via wine devo dirgli dove trovare i driver, nel mio caso uso per esempio questo comando
LIBGL_DRIVERS_PATH=/usr/lib:/usr/lib/modules/dri wine quellocheè.exe

spero di esserti stato di aiuto


[edit]: ricollegandomi a quanto detto da brainvision sulle directx ti consiglio di usare winetriks per installare directx 9/10, .net e compagnia bella
quando richiesto dal gioco
Amrod
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: sab dic 09, 2006 19:03
Località: Cantu' -Co-
Slackware: x86_64 current
Desktop: Openbox

Re: Problemini con wine

Messaggioda Blallo » dom feb 21, 2010 1:06

Offtopic: @amrod: vedo che usi enlightenment...come l'hai installato in current?
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Problemini con wine

Messaggioda 414N » dom feb 21, 2010 11:05

Amrod ha scritto:Sia i driver nvidia che ati dovrebbero installare automaticamente anche la versione a 32 bit per la compatibilita

Falso, almeno per quanto ho visto con i driver ATI.
L'ultima volta che li ho usati ho dovuto lanciare manualmente lo script di installazione con il wrapper linux32, in modo da fargli generare il pacchetto con le librerie a 32 bit.
Amrod ha scritto:in piu' io per far andare i giochi a 32 bit sia nativi che via wine devo dirgli dove trovare i driver, nel mio caso uso per esempio questo comando
LIBGL_DRIVERS_PATH=/usr/lib:/usr/lib/modules/dri wine quellocheè.exe

Questo è piuttosto strano... Io non devo fare nulla del genere.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Problemini con wine

Messaggioda shock » dom feb 21, 2010 13:38

Quindi mi consigliate di installare "oltre" ai driver a 64 bit,anche quelli a 32? Ma poi voglio dire...non si va a creare un po di casino?Oppure posso procedere tranquillamente?

Ciao e grazie per le tantissime risposte.
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Problemini con wine

Messaggioda Amrod » dom feb 21, 2010 14:22

@414N: si sono stato impreciso, dipende da come installi i driver, anch'io ho una ATI e se creo il pacchetto con lo slackbuild interno devo fare come dici tu e
creare separatamente il pacchetto a 32 bit, mentre se usi l'installer senza fargli fare il pacchetto li installa automaticamente.

@shock: per far andare applicazioni a 32 bit devi installare tutte le librerie da cui dipendono, quindi devi avere, nel caso dei giochi per esempio, tutto X e, forse
sbagliando i termini, la parte dei driver della scheda video che sovrascrivono lo stack openGL di mesa, mentre il modulo del kernel e' solo quello a 64 bit


Offtopic: @ jimmi_page_89: non uso mai la versione svn e aspetto i vari snapshot piu' o meno stabili, poi non compilo tutto ma solo le librerie core;
sotto current mi ha ricompilato tutto senza problemi
Ultima modifica di Amrod il dom feb 21, 2010 22:52, modificato 1 volta in totale.
Amrod
Linux 1.0
Linux 1.0
 
Messaggi: 91
Iscritto il: sab dic 09, 2006 19:03
Località: Cantu' -Co-
Slackware: x86_64 current
Desktop: Openbox

Re: Problemini con wine

Messaggioda muzzle » dom feb 21, 2010 14:38

shock ha scritto:Quindi mi consigliate di installare "oltre" ai driver a 64 bit,anche quelli a 32? Ma poi voglio dire...non si va a creare un po di casino?Oppure posso procedere tranquillamente?

Ciao e grazie per le tantissime risposte.


Non devi installare i 32 bit sopra i 64 bit, se no si genera il caos.

Prima si installano i pacchetti multilib forniti da AlienBob, in altri post si è già parlato già di questo.

Per quanto riguarda i driver per la scheda grafica, determinati pacchetti a 64 bit (credo che valga per nvidia come per ati) contengono già i necessari moduli e librerie per i 32 bit).

Se stai usando una scheda Nvidia devi scaricare il pacchetto a 64bit con la dicitura: NVIDIA-Linux-x86_64-xxx.yy.zz-pkg2, il pkg2 è il pacchetto completo, comprendente anche la parte riguardante i 32 bit.
Durante l'installazione ti verrà chiesto se vuoi installare anche i file per i 32 bit, tu rispondi di sì e il gioco è fatto.

Per Ati non saprei dirti ma credo che la trafila sia la stessa, comunque credo che qualcuno saprà aiutarti.

Ciao
muzzle
Linux 1.0
Linux 1.0
 
Messaggi: 60
Iscritto il: sab gen 03, 2009 11:24
Slackware: current_64
Kernel: 2.6.36-zen1
Desktop: xfce

Prossimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti