Repository 32bit  Forum
Repository 64bit  Wiki

Compiz pazzo?

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Compiz pazzo?

Messaggioda shock » dom feb 28, 2010 16:46

Scusate ma ho letto una paranza di wiki ma non sono riuscito a capire...perche se dal pannello impostazioni kde attivo compiz...mi si tolgono i contorni delle finestre?

Pardon, ma proprio non riesco a capire.

Ho provato a scaricarlo da qui http://linux.softpedia.com/get/Utilitie ... 9791.shtml al comando "./configure" alla fine mi da questo:

Codice: Seleziona tutto
checking for EMERALD... configure: error: Package requirements ( xrender >= 0.8.4                   gtk+-2.0 >= 2.8.0     libwnck-1.0                     pangocairo              libberyldecoration ) were not met:

No package 'libberyldecoration' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EMERALD_CFLAGS
and EMERALD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Come posso risolvere?

Ciao e grazie in anticipo.
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Compiz pazzo?

Messaggioda SIV » dom feb 28, 2010 17:28

libberyldecoration dovrebbe avere a che fare con beryl, ormai non più supportato.

Anche sul link che hai postato fa riferimento al The Beryl Project

Per i contorni che spariscono non ti so dire, ma hai necessità di usare compiz? Se ti accontenti gli effetti più comuni (e non sono poi così pochi) ci sono già in kwin, che si integra (quasi) alla perfezione con kde.

Forse ti possono aiutare queste, anche se un po' old:
http://slacky.eu/wikislack/index.php?ti ... _Slackware
http://www.slacky.eu/wikislack/index.ph ... Compiz-git
Avatar utente
SIV
Linux 2.6
Linux 2.6
 
Messaggi: 918
Iscritto il: mer apr 25, 2007 13:07
Località: Bari (Provincia)

Re: Compiz pazzo?

Messaggioda m0rdr3d » lun mar 01, 2010 0:10

Immagino che la sparizione delle decorazioni delle finestre sia dovuta la fatto che compiz tenta di rimpiazzare kwin, evidentemente senza troppo successo.
Se cerchi tra i post del forum trovi una marea di discussioni al riguardo, anche con le istruzioni ed uno script per avviare compiz così com'è installato di default nella Slackware, senza aggiungere nessun package.
Avatar utente
m0rdr3d
Linux 2.4
Linux 2.4
 
Messaggi: 404
Iscritto il: dom dic 24, 2006 13:40
Slackware: Slackware64-current
Kernel: 3.4.*
Desktop: KDE 4.8.2

Re: Compiz pazzo?

Messaggioda Meskalamdug » mer mar 03, 2010 2:05

shock ha scritto:Scusate ma ho letto una paranza di wiki ma non sono riuscito a capire...perche se dal pannello impostazioni kde attivo compiz...mi si tolgono i contorni delle finestre?

Pardon, ma proprio non riesco a capire.

Ho provato a scaricarlo da qui http://linux.softpedia.com/get/Utilitie ... 9791.shtml al comando "./configure" alla fine mi da questo:

Codice: Seleziona tutto
checking for EMERALD... configure: error: Package requirements ( xrender >= 0.8.4                   gtk+-2.0 >= 2.8.0     libwnck-1.0                     pangocairo              libberyldecoration ) were not met:

No package 'libberyldecoration' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables EMERALD_CFLAGS
and EMERALD_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Come posso risolvere?

Ciao e grazie in anticipo.

Ci sono qualcosa come duecento discussioni su come avviare compiz su slackware
C'è anche la mia guida(non è aggiornatissima..ma dovrebbe andare)
http://digilander.libero.it/linux352/aiglx.html

Beryl?Preistoria...

p.s=perchè scaricare sorgenti perdipiù vetusti
quando c'è compiz già pronto per slackware?
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3593
Iscritto il: gio mag 13, 2004 23:00

Re: Compiz pazzo?

Messaggioda shock » mar mar 16, 2010 15:27

Scusate...ma ho cercato sul forum ma non sono riuscito a trovare questo script...i driver che installo sono ufficiali, e non mi danno alcun errore durante l'installazione.Ho seguito passo passo ltutte le guide che mi avete consigliato ma non arrivo da nessuna parte, sempre il solito problema.Con la consigliatami in questo topic, arrivo a questo:

Codice: Seleziona tutto
# compiz (core) - Error: Couldn't load plugin 'ccp'


Cosa significa?

P.S. Oltre al file xorg.con, presento anche il file xorg.conf-vesa (infatti la guida qui su slacky per avviare compiz la ho seguita con questo file...dato che alcune sections non c'erano nel primo)
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Compiz pazzo?

Messaggioda max_paso » mer mar 17, 2010 20:02

E' normale che spariscano i bordi delle finestre, compiz si sostituisce al window manager. Devi usare emerald per attivare i bordi delle finestre (basta digitare emerald da shell) , poi impostalo anche all'avvio di KDE
max_paso
Linux 1.0
Linux 1.0
 
Messaggi: 8
Iscritto il: gio ott 28, 2004 23:00

Re: Compiz pazzo?

Messaggioda shock » gio mar 18, 2010 15:39

Mi spieghi bene il procedimento??

Grazie in anticipo.
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Compiz pazzo?

Messaggioda max_paso » lun mar 22, 2010 18:12

Vai sulla shell e digita il seguente comando

emerald

a questo punto dovrebbe apparirti la cornice delle finestre anche con compiz. Se questo risolve il tuo problema dovresti automatizzare il comando all'avvio di KDE, purtroppo io uso Gnome e non so come si faccia con KDE, ma penso che sia qualcosa di molto semplice tipo un menù intitolato "programmi all'avvio", "esegui all'avvio", "esegui comando all'avvio".

Spero di essere stato d'aiuto
max_paso
Linux 1.0
Linux 1.0
 
Messaggi: 8
Iscritto il: gio ott 28, 2004 23:00


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti