Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] Alsamixer dopo l'aggiornamento di Marzo

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] Alsamixer dopo l'aggiornamento di Marzo

Messaggioda Vic Steele » ven mar 05, 2010 13:08

Ciao a tutti.

Incuriosito dal corposissimo changelog, ho aggiornato Slackware alla current in modo completamente manuale.
In sostanza credo di non aver dimenticato nulla, a parte i miei pacchetti la differenza nell'aggiornamento ufficiale l'ho fatta aggiornando KDE alla 4.4.1 di Alien.

Mi ritrovo un problema: notando che non a tutte le applicazioni funzionasse l'audio (ad esempio funziona con XMMS, ma non con YouTube), ho scoperto che alsamixer mi fa questo scherzetto:

bash-4.1$ alsamixer
cannot open mixer: No such file or directory


/dev/mixer esiste, magari è un problema di permessi?

bash-4.1# ls -l mixer
crw-rw----+ 1 root audio 14, 0 Mar 5 12:55 mixer


Avete idea di cosa posso aver eventualmente dimenticato?
Vi ringrazio in anticipo per il supporto.
Ultima modifica di Vic Steele il ven mar 05, 2010 19:03, modificato 2 volte in totale.
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: Alsamixer dopo l'aggiornamento di Marzo

Messaggioda phobos3576 » ven mar 05, 2010 17:32

Hai aggiornato anche il kernel al 2.6.33?

In tal caso, dovresti aggiornare anche alsa-lib, alsa-utils e alsa-oss.

Prima però vai sul Centro di Controllo, sezione Multimedia e assicurati che il backend di Phonon con la priorità più alta sia Xine; poi riavvia KDE.
Avatar utente
phobos3576
Staff
Staff
 
Messaggi: 2980
Iscritto il: sab apr 16, 2005 23:00
Slackware: 13.1
Kernel: 2.6.37-smp
Desktop: KDE 4.5.3

Re: Alsamixer dopo l'aggiornamento di Marzo

Messaggioda targzeta » ven mar 05, 2010 17:46

Controlla che il tuo utente faccia parte del gruppo audio. Inoltre controlla se il mixer è proprio /dev/mixer. Avvia alsamixer con
Codice: Seleziona tutto
strace -e open /bin/alsamixer
(non sono sicuro che alsamixer sia in /bin) e controlla i device che tenta di aprire.

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6155
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Alsamixer dopo l'aggiornamento di Marzo

Messaggioda Vic Steele » ven mar 05, 2010 18:19

Grazie mille per le risposte.

@phobos: ho aggiornato al kernel 2.6.33, ma non ho ancora riavviato in esso (continuo per ora ad usarne uno mio, mantenendo ancora il vecchio fstab). Alsa-lib e alsa-utils sono aggiornati, alsa-oss no, ma del resto perché non è stato aggiornato nella current.
Il backend di Phonon è Xine, è stato uno dei primi controlli che ho fatto. Sembra che le poche applicazioni in cui l'audio funziona dipendano proprio da lui infatti :D .

@spina: il mio utente fa parte del gruppo audio, il sistema fino a ieri con i vecchi pacchetti funzionava alla perfezione. Inoltre è un problema che ottengo anche se avvio alsamixer da root.
In effetti, non so dirti con certezza che il mixer fosse /dev/mixer:
Codice: Seleziona tutto
bash-4.1# strace -e open /usr/bin/alsamixer
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/usr/lib64/libformw.so.5", O_RDONLY) = 3
open("/usr/lib64/libmenuw.so.5", O_RDONLY) = 3
open("/usr/lib64/libpanelw.so.5", O_RDONLY) = 3
open("/lib64/libncursesw.so.5", O_RDONLY) = 3
open("/usr/lib64/libasound.so.2", O_RDONLY) = 3
open("/lib64/libm.so.6", O_RDONLY)      = 3
open("/lib64/libdl.so.2", O_RDONLY)     = 3
open("/lib64/libpthread.so.0", O_RDONLY) = 3
open("/lib64/libc.so.6", O_RDONLY)      = 3
open("/lib64/librt.so.1", O_RDONLY)     = 3
open("/usr/share/alsa/alsa.conf", O_RDONLY) = 3
open("/etc/asound.conf", O_RDONLY)      = 3
open("/dev/snd/controlC0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/dev/aloadC0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
cannot open mixer: No such file or directory


Non ditemi che l'identificazione delle device è cambiata anche su queste cose.

Confermo nell'inesistenza di /dev/snd/controlC0 e /dev/aloadC0.
Ultima modifica di Vic Steele il ven mar 05, 2010 18:23, modificato 1 volta in totale.
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: Alsamixer dopo l'aggiornamento di Marzo

Messaggioda targzeta » ven mar 05, 2010 18:22

Codice: Seleziona tutto
open("/dev/snd/controlC0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
open("/dev/aloadC0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

Molto probabilmente hai problemi con i moduli audio, se esegui
Codice: Seleziona tutto
lsmod | grep snd
cosa ti restituisce?

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6155
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Alsamixer dopo l'aggiornamento di Marzo

Messaggioda Vic Steele » ven mar 05, 2010 18:24

Ho editato poco dopo il tuo reply, confermando l'inesistenza dei due /dev.

Codice: Seleziona tutto
bash-4.1# lsmod | grep snd
snd_seq_dummy           3236  0
snd_seq_oss            32096  0
snd_seq_midi_event      7520  1 snd_seq_oss
snd_seq                57056  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_pcm_oss            43936  0
snd_mixer_oss          18432  3 snd_pcm_oss
snd_emu10k1           151840  2
snd_rawmidi            23584  1 snd_emu10k1
snd_ac97_codec        120056  1 snd_emu10k1
ac97_bus                1952  1 snd_ac97_codec
snd_pcm                81992  3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
snd_seq_device          7316  5 snd_seq_dummy,snd_seq_oss,snd_seq,snd_emu10k1,snd_rawmidi
snd_timer              22768  3 snd_seq,snd_emu10k1,snd_pcm
snd_page_alloc          9840  2 snd_emu10k1,snd_pcm
snd_util_mem            4128  1 snd_emu10k1
snd_hwdep               8840  1 snd_emu10k1
snd                    64936  11 snd_seq_oss,snd_seq,snd_pcm_oss,snd_mixer_oss,snd_emu10k1,snd_rawmidi,snd_ac97_codec,snd_pcm,snd_seq_device,snd_timer,snd_hwdep
soundcore               7328  3 snd


I moduli sembrano caricati, tanto più che ho una conferma da lspci:

Codice: Seleziona tutto
bash-4.1# lspci -v
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
   Subsystem: Giga-byte Technology Device 5001
   Flags: bus master, 66MHz, fast devsel, latency 0
   Capabilities: [44] HyperTransport: Slave or Primary Interface
   Capabilities: [dc] HyperTransport: MSI Mapping Enable+ Fixed-

00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
   Subsystem: Giga-byte Technology Device 0c11
   Flags: bus master, 66MHz, fast devsel, latency 0

00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
   Subsystem: Giga-byte Technology Device 0c11
   Flags: 66MHz, fast devsel, IRQ 11
   I/O ports at b400 [size=64]
   I/O ports at 1c00 [size=64]
   I/O ports at 1c40 [size=64]
   Capabilities: [44] Power Management version 2
   Kernel driver in use: nForce2_smbus
   Kernel modules: i2c-nforce2

00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
   Subsystem: Giga-byte Technology Device 0c11
   Flags: 66MHz, fast devsel

00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3) (prog-if 10 [OHCI])
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
   Memory at ea208000 (32-bit, non-prefetchable) [size=4K]
   Capabilities: [44] Power Management version 2
   Kernel driver in use: ohci_hcd
   Kernel modules: ohci-hcd

00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3) (prog-if 20 [EHCI])
   Subsystem: Giga-byte Technology Device 5004
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
   Memory at ea207000 (32-bit, non-prefetchable) [size=256]
   Capabilities: [44] Debug port: BAR=1 offset=0098
   Capabilities: [80] Power Management version 2
   Kernel driver in use: ehci_hcd
   Kernel modules: ehci-hcd

00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1) (prog-if 01 [Subtractive decode])
   Flags: bus master, 66MHz, fast devsel, latency 0
   Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
   I/O behind bridge: 00009000-00009fff
   Memory behind bridge: ea000000-ea0fffff
   Prefetchable memory behind bridge: ea100000-ea1fffff
   Capabilities: [b8] Subsystem: Giga-byte Technology Device 026f
   Capabilities: [8c] HyperTransport: MSI Mapping Enable- Fixed-

00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
   Subsystem: Giga-byte Technology Device a002
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 5
   Memory at ea200000 (32-bit, non-prefetchable) [size=16K]
   Capabilities: [44] Power Management version 2
   Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
   Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+

00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2) (prog-if 8a [Master SecP PriP])
   Subsystem: Giga-byte Technology Device 5002
   Flags: bus master, 66MHz, fast devsel, latency 0
   [virtual] Memory at 000001f0 (32-bit, non-prefetchable) [size=8]
   [virtual] Memory at 000003f0 (type 3, non-prefetchable) [size=1]
   [virtual] Memory at 00000170 (32-bit, non-prefetchable) [size=8]
   [virtual] Memory at 00000370 (type 3, non-prefetchable) [size=1]
   I/O ports at f000 [size=16]
   Capabilities: [44] Power Management version 2
   Kernel driver in use: AMD_IDE
   Kernel modules: pata_amd

00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
   Subsystem: Giga-byte Technology Device e000
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 25
   Memory at ea204000 (32-bit, non-prefetchable) [size=4K]
   I/O ports at b800 [size=8]
   Capabilities: [44] Power Management version 2
   Capabilities: [50] MSI: Enable+ Count=1/8 Maskable+ 64bit+
   Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
   Kernel driver in use: forcedeth

00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2) (prog-if 85 [Master SecO PriO])
   Subsystem: Giga-byte Technology Device b002
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
   I/O ports at 09f0 [size=8]
   I/O ports at 0bf0 [size=4]
   I/O ports at 0970 [size=8]
   I/O ports at 0b70 [size=4]
   I/O ports at cc00 [size=16]
   Memory at ea205000 (32-bit, non-prefetchable) [size=4K]
   Capabilities: [44] Power Management version 2
   Capabilities: [b0] MSI: Enable- Count=1/4 Maskable- 64bit+
   Capabilities: [cc] HyperTransport: MSI Mapping Enable- Fixed+
   Kernel driver in use: sata_nv

00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2) (prog-if 85 [Master SecO PriO])
   Subsystem: Giga-byte Technology Device b002
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 22
   I/O ports at 09e0 [size=8]
   I/O ports at 0be0 [size=4]
   I/O ports at 0960 [size=8]
   I/O ports at 0b60 [size=4]
   I/O ports at e000 [size=16]
   Memory at ea206000 (32-bit, non-prefetchable) [size=4K]
   Capabilities: [44] Power Management version 2
   Capabilities: [b0] MSI: Enable- Count=1/4 Maskable- 64bit+
   Capabilities: [cc] HyperTransport: MSI Mapping Enable- Fixed+
   Kernel driver in use: sata_nv

00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2) (prog-if 00 [Normal decode])
   Flags: bus master, fast devsel, latency 0
   Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
   I/O behind bridge: 0000a000-0000afff
   Memory behind bridge: e8000000-e9ffffff
   Prefetchable memory behind bridge: 00000000d0000000-00000000dfffffff
   Capabilities: [40] Subsystem: nVidia Corporation Device 0000
   Capabilities: [48] Power Management version 2
   Capabilities: [50] MSI: Enable+ Count=1/2 Maskable- 64bit+
   Capabilities: [60] HyperTransport: MSI Mapping Enable- Fixed-
   Capabilities: [80] Express Root Port (Slot+), MSI 00
   Capabilities: [100] Virtual Channel <?>
   Kernel driver in use: pcieport-driver
   Kernel modules: shpchp

00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
   Flags: fast devsel
   Capabilities: [80] HyperTransport: Host or Secondary Interface

00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
   Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
   Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
   Flags: fast devsel
   Capabilities: [f0] Secure device <?>
   Kernel driver in use: k8temp
   Kernel modules: k8temp

01:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
   Subsystem: Creative Labs Device 0052
   Flags: bus master, medium devsel, latency 32, IRQ 16
   I/O ports at 9000 [size=32]
   Capabilities: [dc] Power Management version 2
   Kernel driver in use: EMU10K1_Audigy
   Kernel modules: snd-emu10k1

01:06.1 Input device controller: Creative Labs SB Audigy Game Port (rev 03)
   Subsystem: Creative Labs SB Audigy Game Port
   Flags: bus master, medium devsel, latency 32
   I/O ports at 9400 [size=8]
   Capabilities: [dc] Power Management version 2
   Kernel driver in use: Emu10k1_gameport
   Kernel modules: emu10k1-gp

01:07.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
   Flags: bus master, medium devsel, latency 32, IRQ 17
   Memory at ea100000 (32-bit, prefetchable) [size=4K]
   Capabilities: [44] Vital Product Data
   Capabilities: [4c] Power Management version 2
   Kernel driver in use: bttv
   Kernel modules: bttv

01:07.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)
   Flags: bus master, medium devsel, latency 32, IRQ 10
   Memory at ea101000 (32-bit, prefetchable) [size=4K]
   Capabilities: [44] Vital Product Data
   Capabilities: [4c] Power Management version 2

01:0e.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link) (prog-if 10 [OHCI])
   Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard
   Flags: bus master, medium devsel, latency 32, IRQ 18
   Memory at ea004000 (32-bit, non-prefetchable) [size=2K]
   Memory at ea000000 (32-bit, non-prefetchable) [size=16K]
   Capabilities: [44] Power Management version 2
   Kernel driver in use: ohci1394
   Kernel modules: ohci1394

02:00.0 VGA compatible controller: ATI Technologies Inc RV620 LE [Radeon HD 3450] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device e400
   Flags: bus master, fast devsel, latency 0, IRQ 16
   Memory at d0000000 (64-bit, prefetchable) [size=256M]
   Memory at e9000000 (64-bit, non-prefetchable) [size=64K]
   I/O ports at a000 [size=256]
   [virtual] Expansion ROM at e8000000 [disabled] [size=128K]
   Capabilities: [50] Power Management version 3
   Capabilities: [58] Express Legacy Endpoint, MSI 00
   Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
   Capabilities: [100] Vendor Specific Information <?>

02:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
   Subsystem: PC Partner Limited Device aa28
   Flags: bus master, fast devsel, latency 0, IRQ 10
   Memory at e9010000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 3
   Capabilities: [58] Express Legacy Endpoint, MSI 00
   Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
   Capabilities: [100] Vendor Specific Information <?>


È indispensabile che smanetti fstab per provare sul nuovo kernel (e sulla nuova configurazione/nomenclatura dei device)?
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: Alsamixer dopo l'aggiornamento di Marzo

Messaggioda targzeta » ven mar 05, 2010 18:45

Hai due device audio ma di nessuno dei due sembra essere caricato il modulo
Codice: Seleziona tutto
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
   Subsystem: Giga-byte Technology Device a002
   Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 5
   Memory at ea200000 (32-bit, non-prefetchable) [size=16K]
   Capabilities: [44] Power Management version 2
   Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
   Capabilities: [6c] HyperTransport: MSI Mapping Enable- Fixed+
Codice: Seleziona tutto
01:06.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
   Subsystem: Creative Labs Device 0052
   Flags: bus master, medium devsel, latency 32, IRQ 16
   I/O ports at 9000 [size=32]
   Capabilities: [dc] Power Management version 2
   Kernel driver in use: EMU10K1_Audigy
   Kernel modules: snd-emu10k1
Codice: Seleziona tutto
02:00.1 Audio device: ATI Technologies Inc RV620 Audio device [Radeon HD 34xx Series]
   Subsystem: PC Partner Limited Device aa28
   Flags: bus master, fast devsel, latency 0, IRQ 10
   Memory at e9010000 (64-bit, non-prefetchable) [size=16K]
   Capabilities: [50] Power Management version 3
   Capabilities: [58] Express Legacy Endpoint, MSI 00
   Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
   Capabilities: [100] Vendor Specific Information <?>
Ad esempio il modulo della scheda ati dovrebbe essere
Codice: Seleziona tutto
snd-hda-intel
. Controlla l'esistenza della directory /dev/snd e poi esegui
Codice: Seleziona tutto
modprobe snd-hda-intel
e quindi ricontrolla.

Facci sapere,
Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6155
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: Alsamixer dopo l'aggiornamento di Marzo

Messaggioda Vic Steele » ven mar 05, 2010 19:02

Ops, risolto, e non era niente di tutto questo.
Semplicemente, dovevo avviare dal 2.6.33 aggiornato. Non c'è più spazio per le vecchie configurazioni dei kernel, non solo nel riconoscimento delle periferiche di mount.
Non lo avevo ancora fatto per la noia di aggiornare il fstab, ma ora posso dire che è estremamente importante.

Mi ha risolto parecchi problemi questo boot, anche uno alla scheda tv (probabilmente anche questa periferica ha cambiato nome).

Ringrazio spina per avermi ispirato, e lascio un consiglio sperando di essere utile a qualcuno: aggiornate il kernel (o almeno la sua configurazione).
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15

Re: [RISOLTO] Alsamixer dopo l'aggiornamento di Marzo

Messaggioda targzeta » ven mar 05, 2010 19:05

In effetti sembrava un po' strano che non ci fossero i moduli caricati in memoria. Forse questo potrebbe anche risolvere il problema di questo thread:
viewtopic.php?f=1&t=31495

Tra l'altro io mi sento un po' arretrato con tutti questi PC con due device audio...non ci capisco più niente :).

Emanuele
Linux Registered User #454438
Se pensi di essere troppo piccolo per fare la differenza, prova a dormire con una zanzara -- Dalai Lama
20/04/2013 - Io volevo Rodotà
Avatar utente
targzeta
Iper Master
Iper Master
 
Messaggi: 6155
Iscritto il: gio nov 03, 2005 14:05
Località: Carpignano Sal. (LE) <-> Pisa
Nome Cognome: Emanuele Tomasi
Slackware: current
Kernel: latest stable
Desktop: IceWM

Re: [RISOLTO] Alsamixer dopo l'aggiornamento di Marzo

Messaggioda Vic Steele » ven mar 05, 2010 19:34

Non so, perché parla di Slackware 13.0 (io fino a ieri, a parte qualche cambiamento leggero, potevo dire di avere Slackware stable, e tutto andava per il meglio).
Ho riscontrato questi problemi aggiornando a pacchetti che lavorano a stretto contatto con i /dev (come lo stesso alsamixer, che nella sua versione ufficiale è stato ricompilato su un kernel che assegna questi nuovi nomi alle periferiche). Sarà quindi un problema ristretto alla current.

P.S.: il device audio della scheda integrata è stato volutamente blacklistato (snd-hda-intel), per far funzionare l'Audigy. I due moduli insieme non potevano stare, il conflitto di interessi su chi deve funzionare su cosa, anche settando esplicitamente delle preferenze, è ormai un classico :D .
Vic Steele
Linux 2.6
Linux 2.6
 
Messaggi: 534
Iscritto il: dom apr 27, 2008 12:46
Località: Potenza
Nome Cognome: Luigi Caiazza
Slackware: current x86_64
Kernel: 3.0.0
Desktop: Fluxbox / KDE 4.7.0
Distribuzione: Fedora 15


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti