Repository 32bit  Forum
Repository 64bit  Wiki

Problemi all'avvio e alla disinstallazione di python 3.1.1

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Problemi all'avvio e alla disinstallazione di python 3.1.1

Messaggioda shock » ven mar 19, 2010 11:50

Scusate...non ho mai avuto questo problema...tempo fa vi chiesi se era possibile installare l'ultima versione di python (3.1.1).Voi mi deste uno slackbuild che mi creava un pacchetto che non disturbava l'installazione base di python.
Non ho mai avuto problemi con quel pacchetto...lo invocavo con il comando "python3"
Oggi dopo aver formattato, lo ho reistallato...nessun problema durante l'installazione.Solo che:

- se da terminale cerco di avviare python...dice che il comando non è riconosciuto
- se cerco di disinstallare il pacchetto questo è l'output:

Codice: Seleziona tutto
Removing package /var/log/packages/python3-3.1.1-x86_64-1_SBo...
Removing files:
sort: write failed: standard output: No space left on device
sort: write error
sort: fflush failed: standard output: No space left on device
sort: write error
sort: write failed: standard output: No space left on device
sort: write error
sort: write failed: standard output: No space left on device
sort: write error
comm: write error: No space left on device


Perche??Ditemi che non ho fatto un casino #-o

Ciao e grazie in anticipo.

P.S. Ho installato anche firefox minefield dimenticandomi di disinstallare il firefox vecchio che c'era di default in slackware.Accortomi della dimenticanza ho provato a disinstallare il pacchetto e questo è l'output:

Codice: Seleziona tutto
Removing package /var/log/packages/mozilla-firefox-3.5.2-x86_64-1...
Removing files:
sort: write failed: standard output: No space left on device
sort: write error
sort: fflush failed: standard output: No space left on device
sort: write error
sort: write failed: standard output: No space left on device
sort: write error
sort: write failed: standard output: No space left on device
sort: write error
comm: write error: No space left on device


Cosa sta accadendo? :roll:
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Problemi all'avvio e alla disinstallazione di python 3.1

Messaggioda d4z_c0nf » ven mar 19, 2010 12:05

Sembra un problema al disco. No space left on device, significa che hai il disco pieno, certo è un po' anomalo che te lo segnali durante una disinstallazione, magari prova a cancellare qualche file pesante e riprovare la disinstallazione.
Avatar utente
d4z_c0nf
Packager
Packager
 
Messaggi: 1293
Iscritto il: mar mar 14, 2006 18:07
Località: Salerno
Nome Cognome: Rocco Aliberti
Slackware: 14.1-64bit
Kernel: 3.10.17
Desktop: xfce

Re: Problemi all'avvio e alla disinstallazione di python 3.1

Messaggioda shock » ven mar 19, 2010 12:41

Ho scoperto...mio malgrado che questo errore lo fa con tutti i pacchetti...poi se vado a controllare nella directory var/log/packages...quei pacchetti non ci sono piu, ma il programma rimane installato.

Formatto di nuovo?E' un problema hardware?

Ho formattato ed ho sempre gli stessi errori. :( :(
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Problemi all'avvio e alla disinstallazione di python 3.1

Messaggioda shock » ven mar 19, 2010 17:00

Ho formattato tre volte...due con slackware e una persino con debian (che pero mi dava dei problemi con il boot loader...non mi installava ne lilo ne grub)

Non capisco perche il comando di python non funzioni...voglio dire, se è un problema hardware...cosa c'entra python??
Ho anche aperto il case del pc per vedere se c'era qualcosa fuori posto, ma sembra tutto ok.
Vi posso dire inoltre che io ho formattato in principio proprio perche il pc si era impallato...stavo giocando con wine ed ad un certo punto la tastiera non ha piu risposto...poi il mouse.Poi mi apparivano messaggi d'errore, tipo che la scheda audio aveva qualcosa ecc. ecc. Come se fosse andato a fuoco il pc.

E' giunta l'apocalisse?

Che faccio??Vi imploro aiutatemi!!! [-o< [-o<


Ciao.
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Problemi all'avvio e alla disinstallazione di python 3.1

Messaggioda d4z_c0nf » ven mar 19, 2010 17:04

shock ha scritto:Ho formattato tre volte...due con slackware e una persino con debian (che pero mi dava dei problemi con il boot loader...non mi installava ne lilo ne grub)

Non capisco perche il comando di python non funzioni...voglio dire, se è un problema hardware...cosa c'entra python??
Ho anche aperto il case del pc per vedere se c'era qualcosa fuori posto, ma sembra tutto ok.

Che faccio??Vi imploro aiutatemi!!! [-o< [-o<


Ciao.


Scusami ma forse mi sono perso, non hai detto che quel problema ce l'hai con tutti i pacchetti che cerchi di disinstallare?
E ce li hai solo dopo che hai installato quello specifico pacchetto?
Che pacchetto è, qual'è il suo contenuto, controlla che non corrompa qualche file..
Avatar utente
d4z_c0nf
Packager
Packager
 
Messaggi: 1293
Iscritto il: mar mar 14, 2006 18:07
Località: Salerno
Nome Cognome: Rocco Aliberti
Slackware: 14.1-64bit
Kernel: 3.10.17
Desktop: xfce

Re: Problemi all'avvio e alla disinstallazione di python 3.1

Messaggioda shock » ven mar 19, 2010 17:20

Il pacchetto in questione è quello di python 3.1.1 Lo ho sempre utilizzato e non mi ha mai dato problemi http://slackbuilds.org/repository/13.0/ ... t/python3/
Perche all'improvviso non va piu?? Comunque sono piu propenso a pensare ad un errore hardware, dato che il mouse e la tastiera non andavano piu.

Spero di riuscier a risolvere...ciao e grazie
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Problemi all'avvio e alla disinstallazione di python 3.1

Messaggioda navajo » ven mar 19, 2010 20:19

tieni il pc acceso per un po e poi controlla anche da Bios le temperature. dopo di che prova una distribuzione live e vedi se hai problemi o va tutto bene. Potrebbe essere anche che sia partito l hd
Avatar utente
navajo
Staff
Staff
 
Messaggi: 3765
Iscritto il: gio gen 08, 2004 0:00
Località: Roma
Nome Cognome: Massimiliano
Slackware: 13.37 (x86_64)
Kernel: 2.6.37.6
Desktop: KDE 4.7.0 (Alien)

Re: Problemi all'avvio e alla disinstallazione di python 3.1

Messaggioda shock » ven mar 19, 2010 21:00

Il mio pc possiede una funzione che mi permette di testare il vario hardware...ram,hd ecc.
E'stata la prima cosa che ho fatto e non ha trovato alcun errore, tutti i test sono andati a buon fine.

Ciao.
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti