Repository 32bit  Forum
Repository 64bit  Wiki

Dubbi sulle versioni di wine

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Dubbi sulle versioni di wine

Messaggioda shock » sab mar 20, 2010 13:29

Scusate, ma io vi devo fare questa domanda...anche se ho il pc imballato per adesso.
Prima con wine 1.1.39 un gioco mi funzionava...dopo la formattazione non va piu.Voglio dire uno si deve installare una versione di wine per ogni programma?non è possibile farlo funzionare e basta?Come fa uno che deve far funzionare tipo tre programmi ad essere costretto ad usarne tipo solo due?Come si fa?Con wine, voglio dire...non vale la regola di scaricare l'ultima versione perche migliorata.Anzi piu si va avanti piu a me non funziona nulla.Voi come vi regolate?

Ciao e rispondete in tanti :thumbright:

P.S. Ho provato ad installare wine 1.1.41 ed alla fine di ./configure mi è uscito scritto:

Codice: Seleziona tutto
configure: libsane 32-bit development files not found, scanners won't be supported.
configure: libv4l 32-bit development files not found.
configure: libcapi20 32-bit development files not found, ISDN won't be supported.
configure: libgsm 32-bit development files not found, gsm 06.10 codec won't be supported.
configure: libmpg123 32-bit development files not found (or too old), mp3 codec won't be supported.
configure: libopenal 32-bit development files not found (or too old), OpenAL won't be supported.


Come faccio ad inserire queste altre librerie?
Avatar utente
shock
Linux 2.4
Linux 2.4
 
Messaggi: 359
Iscritto il: mer ott 28, 2009 18:47
Nome Cognome: Ivan
Slackware: 13.1 x86_64
Kernel: 2.6.33.4-huge-smp
Desktop: KDE 4.4.3

Re: Dubbi sulle versioni di wine

Messaggioda 414N » sab mar 20, 2010 14:48

shock ha scritto:Scusate, ma io vi devo fare questa domanda...anche se ho il pc imballato per adesso.
Prima con wine 1.1.39 un gioco mi funzionava...dopo la formattazione non va piu.Voglio dire uno si deve installare una versione di wine per ogni programma?

Dipende... Può darsi che nello procedere dello sviluppo avvengano delle regressioni, ovvero ciò che prima funzionava, in una nuova versione non funziona più. Nel caso capiti, la cosa migliore è battezzare il cambiamento che ha introdotto la regressione e segnalarlo agli sviluppatori, magari inviando una patch che risolva il problema. Qui è anche indicato come fare i cosiddetti "regression test".
Può anche darsi che dopo aver formattato il sistema tu non abbia poi reinstallato tutte le librerie necessarie a wine per funzionare correttamente. Mi riferisco soprattutto alle librerie a 32 bit, poiché sono quelle che "scappano" più facilmente.
shock ha scritto:Non è possibile farlo funzionare e basta?Come fa uno che deve far funzionare tipo tre programmi ad essere costretto ad usarne tipo solo due?Come si fa?Con wine, voglio dire...non vale la regola di scaricare l'ultima versione perche migliorata.Anzi piu si va avanti piu a me non funziona nulla.Voi come vi regolate?

Se proprio non se ne viene a capo, si può sempre usare diverse versioni di wine con diversi programmi. Basta metterli in prefissi diversi, in modo che non si "inzucchino". Mi sembra che jimmy_page_89 abbia espresso proprio questo in un vecchio post in cui era spuntato fuori wine.

shock ha scritto:P.S. Ho provato ad installare wine 1.1.41 ed alla fine di ./configure mi è uscito scritto:

Codice: Seleziona tutto
configure: libsane 32-bit development files not found, scanners won't be supported.
configure: libv4l 32-bit development files not found.
configure: libcapi20 32-bit development files not found, ISDN won't be supported.
configure: libgsm 32-bit development files not found, gsm 06.10 codec won't be supported.
configure: libmpg123 32-bit development files not found (or too old), mp3 codec won't be supported.
configure: libopenal 32-bit development files not found (or too old), OpenAL won't be supported.


Come faccio ad inserire queste altre librerie?

Devi installare le librerie in questione a 32 bit. O raccatti dei pacchetti già compilati per Slackware13 a 32 bit e li "adatti" con lo script di alien convertpkg-compat32, oppure li ricostruisci da capo modificando la ARCH che normalmente useresti per compilare il pacchetto...
Comunque non si tratta di librerie fondamentali, a meno che tu non abbia bisogno di fare video grabbing (v4l), scansioni (sane), ascoltare mp3 ecc. tramite programmi per Windows.
Ultima modifica di 414N il sab mar 20, 2010 18:21, modificato 1 volta in totale.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: Dubbi sulle versioni di wine

Messaggioda muzzle » sab mar 20, 2010 17:12

Dalla versione 1.1.38 ci sono stati dei cambiamenti che possono creare problemi nel funzionamento di determinati programmi sotto wine.
Esempio: in Fallout 3 si creano problemi con l'audio.

Il mio consiglio è di rimanere alla versione 1.1.37, se invece vuoi avere per forza l'ultima versione (va ricordato che queste versioni sono comunque versioni di sviluppo, con tutto quello che comporta) o aspetti che qualcuno posti patch per risolvere i suddetti problemi o nuove versioni di wine che risolvano, o se hai voglia o capacità, adatti o crei nuove patch per le nuove versioni.
muzzle
Linux 1.0
Linux 1.0
 
Messaggi: 60
Iscritto il: sab gen 03, 2009 11:24
Slackware: current_64
Kernel: 2.6.36-zen1
Desktop: xfce


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti