Repository 32bit  Forum
Repository 64bit  Wiki

[RISOLTO] wifi wpa_supplicant

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

[RISOLTO] wifi wpa_supplicant

Messaggioda ¥ Brutus ¥ » sab mar 20, 2010 21:15

Salve a tutti!
Ho da poco installato Slackware 13.0 e mi sono subito trovato dinanzi a diversi problemi (purtroppo vengo da distribuzioni più facili da domare). Il problema che ho riguarda la connessione wifi con la mia scheda Broadcom: ho installato con successo i driver, il problema è che l'unico modo per avviare la connessione è

Codice: Seleziona tutto
wpa_supplicant -Dwext -ieth1 -c /etc/wpa_supplicant.conf -B
dhclient


e questo posso farlo solo da root: come faccio a connettermi da utente normale???
WPA_GUI non riconosce nessuna interfaccia, se non dopo essermi connesso attraverso il comando di cui sopra!
Grazie
Ultima modifica di ¥ Brutus ¥ il mar mag 18, 2010 11:07, modificato 1 volta in totale.
¥ Brutus ¥
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: sab mar 20, 2010 20:10

Re: WIFI WPA_SUPPLICANT

Messaggioda 414N » sab mar 20, 2010 21:36

wpa_gui (e wpa_cli) hanno bisogno di wpa_supplicant già attivo come demone, quindi è normale che non funzionino se non hai prima lanciato wpa_supplicant.
Per rendere permanente l'attivazione di wpa_supplicant all'avvio del sistema, devi modificare il file /etc/rc.d/rc.inet1.conf nei campi opportuni.
C'è già una sezione interamente commentata riguardante un'ipotetica scheda wireless wlan0.
  • decommenta e modifica l'IFNAME da wlan0 a eth1 (se la tua scheda è riconosciuta con questo nome);
  • decommenta e modifica la riga riguardante il DHCP (attivo/spento, in soldoni);
  • decommenta WLAN_WPA (senza modificarlo).
Ora puoi o riavviare il PC, oppure, da root, eseguire
Codice: Seleziona tutto
/etc/rc.d/rc.inet1 eth1 restart
per far partire wpa_supplicant.
A questo punto, se hai già la tua rete configurata in /etc/wpa_supplicant.conf, dovrebbe connetterticisi in automatico.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: wifi wpa_supplicant

Messaggioda Toni » sab mar 20, 2010 21:37

se vuoi semplificarti molto la vita :D

ftp://ftp.slackware.com/pub/slackware/s ... xtra/wicd/

leggi bene il README
Avatar utente
Toni
Linux 2.6
Linux 2.6
 
Messaggi: 993
Iscritto il: lun gen 30, 2006 22:08
Località: milano
Slackware: slackware-14
Kernel: 3.10.5
Desktop: i3

Re: wifi wpa_supplicant

Messaggioda ¥ Brutus ¥ » sab mar 20, 2010 22:02

Grazie Toni, la tua soluzione è tanto rapida quanto efficace, però quello che voglio per ora è capire un po' di più del sistema operativo, anche se dopo aver capito userò wicd.
414N, ho seguito i tuoi consigli, l'unico problema è che mi dice:

Codice: Seleziona tutto
/etc/rc.d/rc.inet1:  eth1 information: 'Any ESSID'


A questo punto ho provato ad inserire nel file:

Codice: Seleziona tutto
WLAN_ESSID[4]=Alice-92369987


ma ancora non va!
¥ Brutus ¥
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: sab mar 20, 2010 20:10

Re: wifi wpa_supplicant

Messaggioda sya54M » dom mar 21, 2010 8:54

a questo punto non si connette all'avvio se non configuri anche wpa_supplicant da /etc/wpa_supplicant.conf
però già ora avendolo avviato anche se non configurato, wpa_gui ti funziona
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1434
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: wifi wpa_supplicant

Messaggioda 414N » dom mar 21, 2010 11:30

¥ Brutus ¥ ha scritto:414N, ho seguito i tuoi consigli, l'unico problema è che mi dice:

Codice: Seleziona tutto
/etc/rc.d/rc.inet1:  eth1 information: 'Any ESSID'


A questo punto ho provato ad inserire nel file:

Codice: Seleziona tutto
WLAN_ESSID[4]=Alice-92369987


ma ancora non va!

Probabilmente hai un file di configurazione per wpa_supplicant che dà priorità maggiore alle reti non conosciute rispetto a quelle già configurate.
Prova a modificare le priorità e a riconfigurare wpa_supplicant. Lo puoi fare lanciando wpa_cli (sempre da root) e dando il comando reconfigure.
Se poi vuoi forzare una connessione, prova con il comando reassociate.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: wifi wpa_supplicant

Messaggioda ¥ Brutus ¥ » mar mar 23, 2010 11:28

Questo è il mio file wpa_supplicant:

Codice: Seleziona tutto
# See /usr/doc/wpa_supplicant-0.6.9/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1
#country=US

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
  scan_ssid=0
  ssid="Alice-92369987"
  proto=WPA RSN
  key_mgmt=WPA-PSK
  pairwise=CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk="**********************************"
  priority=10
}

# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
  key_mgmt=NONE
  priority=0
}


La priorità 10 non è massima?
¥ Brutus ¥
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: sab mar 20, 2010 20:10

Re: wifi wpa_supplicant

Messaggioda 414N » mar mar 23, 2010 19:01

Prova a commentare scan_ssid=0.
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE

Re: wifi wpa_supplicant

Messaggioda ¥ Brutus ¥ » mer mar 24, 2010 18:58

Ancora nulla, continua a scrivermi "Any ESSID".
Toglietemi una curiosità, WICD non utilizza il file wpa_supplicant.conf???
¥ Brutus ¥
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: sab mar 20, 2010 20:10

Re: wifi wpa_supplicant

Messaggioda sya54M » mer mar 24, 2010 19:24

Codice: Seleziona tutto
network={
  ssid="Alice-92369987"
  proto=WPA
  key_mgmt=WPA-PSK
  pairwise=TKIP
  group=TKIP
  psk="**********************************"
}

altrimenti usate tutte le crittografie assieme? bah
¥ Brutus ¥ ha scritto:Toglietemi una curiosità, WICD non utilizza il file wpa_supplicant.conf???

no
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1434
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.17.x
Desktop: KDE 4.14

Re: wifi wpa_supplicant

Messaggioda Meskalamdug » mer mar 24, 2010 23:13

http://digilander.libero.it/linux352/wirelesswpa.html

Prova la mia guida ovviamente adattala
alla tua scheda.
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3593
Iscritto il: gio mag 13, 2004 23:00

Re: wifi wpa_supplicant

Messaggioda ¥ Brutus ¥ » mer apr 28, 2010 21:13

Grazie mille ragazzi, per merito vostro ho capito un bel po' di cose!
Grazie ancora!
¥ Brutus ¥
Linux 1.0
Linux 1.0
 
Messaggi: 24
Iscritto il: sab mar 20, 2010 20:10

Re: wifi wpa_supplicant

Messaggioda 414N » ven apr 30, 2010 17:17

Modifica il titolo del primo messaggio del thread con [RISOLTO], allora :)
Avatar utente
414N
Iper Master
Iper Master
 
Messaggi: 2882
Iscritto il: mer feb 13, 2008 16:19
Località: Bulagna
Slackware: 14.0 (x64)
Kernel: 3.2.29
Desktop: LXDE


Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti