Repository 32bit  Forum
Repository 64bit  Wiki

Nouveau..vi interessa?

Se avete problemi con l'installazione e la configurazione di Slackware64 postate qui. Non usate questo forum per argomenti che trattano la Slackware32 o generali... per quelli usate rispettivamente il forum Slackware e Gnu/Linux in genere.

Moderatore: Staff

Regole del forum
1) Citare sempre la versione di Slackware64 usata, la versione del Kernel e magari anche la versione della libreria coinvolta. Questi dati aiutano le persone che possono rispondere.
2) Per evitare confusione prego inserire in questo forum solo topic che riguardano appunto Slackware64, se l'argomento è Slackware32 o generale usate rispettivamente il forum Slackware o Gnu/Linux in genere.
3) Leggere attentamente le risposte ricevute
4) Scrivere i messaggi con il colore di default, evitare altri colori.
5) Scrivere in Italiano o in Inglese, se possibile grammaticalmente corretto, evitate stili di scrittura poco chiari, quindi nessuna abbreviazione tipo telegramma o scrittura stile SMS o CHAT.
6) Appena registrati è consigliato presentarsi nel forum dedicato.

La non osservanza delle regole porta a provvedimenti di vari tipo da parte dello staff, in particolare la non osservanza della regola 5 porta alla cancellazione del post e alla segnalazione dell'utente. In caso di recidività l'utente rischia il ban temporaneo.

Re: Nouveau..vi interessa?

Messaggioda Meskalamdug » lun apr 05, 2010 18:32

Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3585
Iscritto il: gio mag 13, 2004 23:00

Re: Nouveau..vi interessa?

Messaggioda sya54M » mar apr 06, 2010 16:32

Meskalamdug ha scritto:È un bug di mesa.
https://bugs.launchpad.net/ubuntu/+sour ... bug/537721

infatti :cry:
ma vorrei sapere, prima di consumare bonus per scaricarlo, se su git è stato corretto, a te si compila quel file?
grazie mille
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Nouveau..vi interessa?

Messaggioda Meskalamdug » mer apr 07, 2010 8:41

sya54M ha scritto:
Meskalamdug ha scritto:È un bug di mesa.
https://bugs.launchpad.net/ubuntu/+sour ... bug/537721

infatti :cry:
ma vorrei sapere, prima di consumare bonus per scaricarlo, se su git è stato corretto, a te si compila quel file?
grazie mille

Ora provo.
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3585
Iscritto il: gio mag 13, 2004 23:00

Re: Nouveau..vi interessa?

Messaggioda Meskalamdug » mer apr 07, 2010 8:51

Con questo configure

Codice: Seleziona tutto
./configure   --disable-asm --with-dri-drivers= --enable-gallium-nouveau --disable-gallium-intel \
--disable-gallium-radeon --disable-gallium-svga --with-state-trackers=glx,dri --with-demos=xdemos,demos,trivial,tests \
--prefix=/usr --libdir=/usr/lib64/ --with-dri-driverdir=/usr/lib64/xorg/modules/dri


Nessun errore,ma mi pare di aver sentito che per le vecchie nvidia
il configure deve essere così

Codice: Seleziona tutto
./configure   --disable-asm -with-dri-drivers=swrast,nouveau  --disable-gallium-nouveau --disable-gallium-intel \
--disable-gallium-radeon --disable-gallium-svga --with-state-trackers=glx,dri --with-demos=xdemos,demos,trivial,tests \
--prefix=/usr --libdir=/usr/lib64/ --with-dri-driverdir=/usr/lib64/xorg/modules/dri
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3585
Iscritto il: gio mag 13, 2004 23:00

Re: Nouveau..vi interessa?

Messaggioda sya54M » mer apr 07, 2010 9:00

si, l'importante è che ci sia
Codice: Seleziona tutto
-with-dri-drivers=nouveau

swrast sta per software rasterizer e viene caricato nel caso non esista la libreria adatta.

il problema è che è proprio quel -with-dri-drivers=nouveau (che dovrebbe creare il file che chiedevo) che fa fallire la compilazione (almeno nella versione 7.8 ).
ora però ho notato che è uscito mesa 7.8.1 e oggi sono all'università, quindi posso scaricare di tutto :D , provo subito se è stato corretto e faccio sapere. l'unico problema è che poi non lo posso testare perchè qui non ho i pc con le nvidia.
grazie e scusa il disturbo
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Nouveau..vi interessa?

Messaggioda sya54M » mer apr 07, 2010 11:02

con mesa 7.8.1 stesso errore della 7.8
ma da git ha funzionato :D
ho il pacchetto con dentro nouveau_vieux_dri.so \:D/
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Nouveau..vi interessa?

Messaggioda sya54M » lun apr 12, 2010 15:32

venerdì notte ho installato il pacchetto di mesa, che avevo preparato col portatile mercoledì, sul pc che ha la tnt2 (pentium4 2.66ghz, 1gb di ram) e finalmente si è attivata l'accelerazione 3d \:D/
... ma le prestazioni sono penose, così scarse da non riuscire a far girare decentemente anche il gioco più scarso :x
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Nouveau..vi interessa?

Messaggioda Meskalamdug » mar apr 13, 2010 2:30

sya54M ha scritto:venerdì notte ho installato il pacchetto di mesa, che avevo preparato col portatile mercoledì, sul pc che ha la tnt2 (pentium4 2.66ghz, 1gb di ram) e finalmente si è attivata l'accelerazione 3d \:D/
... ma le prestazioni sono penose, così scarse da non riuscire a far girare decentemente anche il gioco più scarso :x

Noti molta differenza rispetto ai 3d
nvidia proprietari?
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3585
Iscritto il: gio mag 13, 2004 23:00

Re: Nouveau..vi interessa?

Messaggioda sya54M » mar apr 13, 2010 7:16

non ti posso rispondere perchè non ho mai potuto provarli su questa tnt2 perchè su xorg 1.6 e 1.7 non vanno, proprio per questo mi interessavano molto questi nouveau.
però sullo stesso pc prima ci tenevo una voodoo3 2000 e, anche se non molto veloce, ci funzionava abbastanza wolfeinstain: enemy territory e ho letto su internet che la tnt2 dovrebbe essere sullo stesso livello o qualcosa in più (ha il doppio della ram video: 16mb vs 32mb), invece con questi nouveau sembrava quasi senza accelerazione tanto che era lento (ma in realtà c'era l'accelerazione).
nemmeno extreme tux racer ce la fa a portare, anczi su questo fa anche dei difetti grafici oltre ad essere lento all'inutilizzabile.
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Nouveau..vi interessa?

Messaggioda Meskalamdug » mar apr 13, 2010 22:36

sya54M ha scritto:non ti posso rispondere perchè non ho mai potuto provarli su questa tnt2 perchè su xorg 1.6 e 1.7 non vanno, proprio per questo mi interessavano molto questi nouveau.
però sullo stesso pc prima ci tenevo una voodoo3 2000 e, anche se non molto veloce, ci funzionava abbastanza wolfeinstain: enemy territory e ho letto su internet che la tnt2 dovrebbe essere sullo stesso livello o qualcosa in più (ha il doppio della ram video: 16mb vs 32mb), invece con questi nouveau sembrava quasi senza accelerazione tanto che era lento (ma in realtà c'era l'accelerazione).
nemmeno extreme tux racer ce la fa a portare, anczi su questo fa anche dei difetti grafici oltre ad essere lento all'inutilizzabile.

Conta che sono drivers ancora in via di sviluppo.
È già troppo che il 3d vada,io comunque spero
che un giorno(e non è impossibile) soppiantino
i proprietari che per me sono troppo limitanti(
danno problemi nella sospensione,non partono
con Xen..).
Io comunque sono passato ad ATI,non sono schede
eccezionali..ma gli effetti 3d vanno,xen gira e
la sospensione/ibernazione va...senza patch :)
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3585
Iscritto il: gio mag 13, 2004 23:00

Re: Nouveau..vi interessa?

Messaggioda sya54M » sab mag 22, 2010 6:55

comunque per chi volesse provare su current 32 bit ho pubblicato i pacchetti aggiornati qui
http://sya54m.altervista.org/repository ... ry/nouveau
non c'è il pacchetto col driver per il kernel, basta compilarsi il 2.6.34 e funziona.
l'unico pacchetto che si sostituisce ad uno di sistema è mesa, necessario per il 3d.
Ultima modifica di sya54M il dom mag 23, 2010 14:28, modificato 1 volta in totale.
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

Re: Nouveau..vi interessa?

Messaggioda Blallo » sab mag 22, 2010 7:03

Fa un po' strano sentire che si è passati ad ATI da un linux user :D
Io sono il detective Arsenio Magret, e porto sempre la camicia TATUATA!
Avatar utente
Blallo
Packager
Packager
 
Messaggi: 3226
Iscritto il: ven ott 12, 2007 10:37
Località: Torino / Torremaggiore (FG)
Nome Cognome: Savino Liguori
Slackware: 14.1 / 12.2
Kernel: 3.12.2-ck
Desktop: Openbox

Re: Nouveau..vi interessa?

Messaggioda Meskalamdug » sab mag 22, 2010 12:29

jimmy_page_89 ha scritto:Fa un po' strano sentire che si è passati ad ATI da un linux user :D

A me interessa usare il pc per testare sistemi(quindi virtualizzazione,etc..)
,lavorare coi video,internet,etc e mi vanno benissimo i driver a sorgente aperta.
Il 3d mi bastano gli effetti di kwin..:)
Certo se uno deve fare uso pesante del 3d sotto linux,i driver(chiusi) nvidia
sono praticamente d'obbligo.
Meskalamdug
Iper Master
Iper Master
 
Messaggi: 3585
Iscritto il: gio mag 13, 2004 23:00

Re: Nouveau..vi interessa?

Messaggioda shark1500 » sab ott 16, 2010 13:02

Tiro fuori di nuovo questo topic perche` ho provato anche io questi driver (e li sto usando tutt'ora).

Io pero` ho fatto molti meno passaggi di questa guida :-), innanzitutto ho abilitato i nouveau nel kernel (sotto lo staging), e poi ho semplicemente ricompilato le mesa (consiglio la 7.8.2 invece della 7.8.1 della slackware) usando lo SlackBuild di pat, semplicemente aggiungendo "--enable-gallium-nouveau", e dopo avrete i driver sia per il 2d che per il 3d.

Usando il 3d dopo un po` inizia ad avere problemi (semplicemente con gli effetti di kde), io con il 2d mi sto trovando alla grande
Avatar utente
shark1500
Linux 2.6
Linux 2.6
 
Messaggi: 785
Iscritto il: gio apr 03, 2008 13:33
Località: Modna
Slackware: current
Kernel: 2.6.27.7-smp
Desktop: kde

Re: Nouveau..vi interessa?

Messaggioda sya54M » sab ott 16, 2010 14:41

li sto usando anchio su una geforce fx5700 e l'unico gioco che riescono a far girare fluido è quake 3 arena :) ... wolfenstain che coi proprietari faceva un sacco di fotogrammi, fino a limitarsi con la sincronia verticale dello schermo, ora ne fa pochissimi tanto da non essere fluido. quindi et-quake wars che coi proprietari andava a stento, coi nouveau non lo provo proprio :)
però con kde vanno molto meglio, coi propritari il desktop era tutto appesantito mentre coi nouveau si è allegerito di molto, in entrambi i casi senza effetti grafici.

comunque per mesa, come dicevo nell'altro topic sto usando la 7.9 e per il kernel quella guida si riferiva ad una versione in cui non era funzionante il driver incluso, quindi è normale usare quello incluso ora, per il quale non servono nemmeno firmware esterni
Avatar utente
sya54M
Linux 3.x
Linux 3.x
 
Messaggi: 1430
Iscritto il: mer giu 06, 2007 13:44
Località: (Salerno)
Nome Cognome: Andrea P.
Slackware: 64-current
Kernel: 3.14.x
Desktop: KDE 4.13

PrecedenteProssimo

Torna a Slackware64

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron